summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PKGBUILD10
-rw-r--r--i2p.conf49
-rw-r--r--i2pd.install2
-rw-r--r--i2pd.service25
-rw-r--r--i2pd.tmpfiles.conf2
5 files changed, 22 insertions, 66 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9b77919b73f4..9219e727084e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -58,7 +58,7 @@ package(){
_dest="$pkgdir/${_share_dest}/doc/${_pkgname}"
install -Dm644 $srcdir/$pkgname-$pkgver/README.md "${_dest}/README.md"
install -Dm644 $srcdir/$pkgname-$pkgver/docs/configuration.md "${_dest}/configuration.md"
-# install -Dm644 $srcdir/$pkgname-$pkgver/docs/family.md "${_dest}/family.md"
+ install -Dm644 $srcdir/$pkgname-$pkgver/docs/family.md "${_dest}/family.md"
install -Dm644 $srcdir/$pkgname-$pkgver/docs/config_opts_after_2.3.0.md "${_dest}/config_opts_after_2.3.0.md"
#man
@@ -68,5 +68,11 @@ package(){
}
md5sums=('086cd191a9a3e1adb45e71b65cc417fc'
- '25bf75261bc501b89b18b22392fefebd'
+ 'adca50403d39229a25c0acd1cac4ea20'
'acda29e5b46a0c9fade734a6a467b381')
+md5sums=('086cd191a9a3e1adb45e71b65cc417fc'
+ 'adca50403d39229a25c0acd1cac4ea20'
+ '3a2525a728d944f0d2aeb978ec12ee13')
+md5sums=('086cd191a9a3e1adb45e71b65cc417fc'
+ '1db645e5069f868b15fc9a74822e4e01'
+ '3a2525a728d944f0d2aeb978ec12ee13')
diff --git a/i2p.conf b/i2p.conf
deleted file mode 100644
index d14e034bbd14..000000000000
--- a/i2p.conf
+++ /dev/null
@@ -1,49 +0,0 @@
-# The external IP
-host=1.2.3.4
-
-# The port to listen on
-port=4567
-
-# The http port to listen on
-httpport=7070
-
-# Enable or disable logging to file. 1 for yes, 0 for no
-log=1
-
-# 1 if router is declared as unreachable and works through introducers
-#unreachable=
-
-# 1 if supports communication through ipv6, off by default
-#v6=
-
-# The port to listen on (HTTP Proxy)
-#httpproxyport=
-
-# The port to listen on (SOCKS Proxy)
-#socksproxyport=
-
-# The local port of IRC tunnel to listen on. 6668 by default
-#ircport=
-
-# I2P destination address of IRC server. For example irc.postman.i2p
-#ircdest=
-
-# optional keys file for local destination
-#irckeys=
-
-# File name containing destination keys, for example privKeys.dat. The file will be created if it does
-#not already exist (issue #110)
-#eepkeys=
-
-# Address incoming trafic forward to. 127.0.0.1 by default
-eephost=127.0.0.1
-
-# Port incoming trafic forward to. 80 by default
-eepport=80
-
-# Port of SAM bridge. Usually 7656. SAM is off if not specified
-#samport=7656
-
-# Port of BOB command channel. Usually 2827. BOB is off if not specified
-#bobport=2827
-
diff --git a/i2pd.install b/i2pd.install
index ec8e914ff755..3462f53dad47 100644
--- a/i2pd.install
+++ b/i2pd.install
@@ -1,4 +1,4 @@
-USER=i2p
+USER=i2pd
HOME=/var/lib/i2pd
post_install() {
diff --git a/i2pd.service b/i2pd.service
index c3cf60b117e3..15075deef9d4 100644
--- a/i2pd.service
+++ b/i2pd.service
@@ -1,22 +1,21 @@
[Unit]
-Description=I2P Router in C++
+Description=C++ daemon for accessing the I2P network
After=network.target
[Service]
-User=i2p
-Group=i2p
Type=forking
-ExecStart=/usr/bin/i2pd --conf=/var/lib/i2pd/i2pd.conf --pidfile=/run/i2pd/i2pd.pid --service --daemon
-ExecReload=/usr/bin/kill -HUP $MAINPID
+Restart=on-abnormal
PIDFile=/run/i2pd/i2pd.pid
-### Uncomment, if auto restart needed
-#Restart=on-failure
-
-### Use SIGINT for gracefull stop daemon.
-KillSignal=SIGINT
-
-LimitNOFILE=8192
-PrivateDevices=yes
+User=i2pd
+Group=i2pd
+LimitNOFILE=4096
+PermissionsStartOnly=yes
+ExecStartPre=/usr/bin/mkdir -p /run/i2pd
+ExecStartPre=/usr/bin/chown i2pd:i2pd /run/i2pd
+ExecStartPre=/usr/bin/touch /run/i2pd/i2pd.pid /var/log/i2pd.log
+ExecStartPre=/usr/bin/chown i2pd:i2pd /run/i2pd/i2pd.pid /var/log/i2pd.log
+ExecStart=/usr/bin/i2pd --daemon --service --pidfile=/run/i2pd/i2pd.pid --log=file --logfile=/var/log/i2pd.log --conf=/etc/i2pd/i2pd.conf
+--tunconf=/etc/i2pd/tunnels.conf
[Install]
WantedBy=multi-user.target
diff --git a/i2pd.tmpfiles.conf b/i2pd.tmpfiles.conf
index cbd9f6480db2..3f7127f29459 100644
--- a/i2pd.tmpfiles.conf
+++ b/i2pd.tmpfiles.conf
@@ -1,2 +1,2 @@
-d /run/i2pd 0755 i2p i2p -
+d /run/i2pd 0755 i2pd i2pd -