summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--005-i2pd-tests-use-arch-flags.conf14
-rw-r--r--PKGBUILD5
3 files changed, 21 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f3c99a5f6db0..4529defabc93 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = i2pd-git
pkgdesc = A full-featured C++ implementation of the I2P router (git version)
- pkgver = 2.46.0.r5.gce05cce3
+ pkgver = 2.46.1.r0.g200ad552
pkgrel = 1
url = https://i2pd.website/
arch = x86_64
@@ -20,6 +20,7 @@ pkgbase = i2pd-git
backup = etc/i2pd/tunnels.conf
backup = etc/logrotate.d/i2pd
source = git+https://github.com/PurpleI2P/i2pd.git#branch=openssl
+ source = 005-i2pd-tests-use-arch-flags.conf
source = 010-i2pd-config.patch
source = 020-i2pd-do-not-override-config.patch
source = 030-i2pd-systemd-service-hardening.patch
@@ -27,6 +28,7 @@ pkgbase = i2pd-git
source = i2pd.sysusers
source = i2pd.tmpfiles
sha256sums = SKIP
+ sha256sums = 2ddf15f1c1cdf5d747a0af667145238023fd126ab00c65f2897cacae935015b1
sha256sums = 45dae1e2f798d23df92c996c233fccb07349d62992d0f625be7fd913719875af
sha256sums = e98eaa783fcd8e1ab84980f68158e3bb9eb5ec101f26c748946a313152643f11
sha256sums = 2b84d85d4234eb3b640925d0dd244c8abe3b48bc69c8456629af923de17acf10
diff --git a/005-i2pd-tests-use-arch-flags.conf b/005-i2pd-tests-use-arch-flags.conf
new file mode 100644
index 000000000000..1a02317849b3
--- /dev/null
+++ b/005-i2pd-tests-use-arch-flags.conf
@@ -0,0 +1,14 @@
+--- a/tests/CMakeLists.txt
++++ b/tests/CMakeLists.txt
+@@ -4,9 +4,9 @@ include_directories(${CHECK_INCLUDE_DIRS
+
+ # Compiler flags:
+ if(APPLE)
+- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -O0 -g -Wl,-undefined,dynamic_lookup")
++ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wl,-undefined,dynamic_lookup")
+ else()
+- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -O0 -g -Wl,--unresolved-symbols=ignore-in-object-files")
++ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wl,--unresolved-symbols=ignore-in-object-files")
+ endif()
+
+ set(TEST_PATH ${CMAKE_CURRENT_BINARY_DIR})
diff --git a/PKGBUILD b/PKGBUILD
index 96a792b46a6b..03ebcb4a0e7d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
# Contributor: DDoSolitary <DDoSolitary@gmail.com>
pkgname=i2pd-git
-pkgver=2.46.0.r5.gce05cce3
+pkgver=2.46.1.r0.g200ad552
pkgrel=1
pkgdesc='A full-featured C++ implementation of the I2P router (git version)'
arch=('x86_64')
@@ -19,6 +19,7 @@ backup=('etc/i2pd/i2pd.conf'
'etc/i2pd/tunnels.conf'
'etc/logrotate.d/i2pd')
source=('git+https://github.com/PurpleI2P/i2pd.git#branch=openssl'
+ '005-i2pd-tests-use-arch-flags.conf'
'010-i2pd-config.patch'
'020-i2pd-do-not-override-config.patch'
'030-i2pd-systemd-service-hardening.patch'
@@ -26,6 +27,7 @@ source=('git+https://github.com/PurpleI2P/i2pd.git#branch=openssl'
'i2pd.sysusers'
'i2pd.tmpfiles')
sha256sums=('SKIP'
+ '2ddf15f1c1cdf5d747a0af667145238023fd126ab00c65f2897cacae935015b1'
'45dae1e2f798d23df92c996c233fccb07349d62992d0f625be7fd913719875af'
'e98eaa783fcd8e1ab84980f68158e3bb9eb5ec101f26c748946a313152643f11'
'2b84d85d4234eb3b640925d0dd244c8abe3b48bc69c8456629af923de17acf10'
@@ -34,6 +36,7 @@ sha256sums=('SKIP'
'fe8cc2ec83cb5b5c2b2ec8cce9a989e0cb6fd347e00b84e03a17b12efd152fac')
prepare() {
+ patch -d i2pd -Np1 -i "${srcdir}/005-i2pd-tests-use-arch-flags.conf"
patch -d i2pd -Np1 -i "${srcdir}/010-i2pd-config.patch"
patch -d i2pd -Np1 -i "${srcdir}/020-i2pd-do-not-override-config.patch"
patch -d i2pd -Np1 -i "${srcdir}/030-i2pd-systemd-service-hardening.patch"