summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD6
-rw-r--r--i3status.install9
3 files changed, 17 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 902d1eb98cb9..d322e3f057fe 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,9 @@
pkgbase = i3status-mpd-git
pkgdesc = Generates a status bar to use with i3bar, dzen2 or xmobar (with mpd support).
- pkgver = r401.0e4c207
+ pkgver = r473.8008db2
pkgrel = 1
url = https://github.com/Gravemind/i3status
+ install = i3status.install
arch = i686
arch = x86_64
license = BSD
@@ -11,11 +12,13 @@ pkgbase = i3status-mpd-git
depends = alsa-lib
depends = confuse
depends = libmpdclient
+ depends = libpulse
depends = wireless_tools
depends = yajl
provides = i3status
conflicts = i3status
conflicts = i3status-git
+ options = docs
backup = etc/i3status.conf
source = i3status-mpd-git::git://github.com/Gravemind/i3status.git
sha1sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 33f57188f6d6..4a1537f64b8b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,17 +2,19 @@
# Contributor: Suhaimi Ghazali <serdotlinecho@gmail.com>
pkgname=i3status-mpd-git
-pkgver=r401.0e4c207
+pkgver=r473.8008db2
pkgrel=1
pkgdesc="Generates a status bar to use with i3bar, dzen2 or xmobar (with mpd support)."
arch=('i686' 'x86_64')
url="https://github.com/Gravemind/i3status"
license=('BSD')
-depends=('alsa-lib' 'confuse' 'libmpdclient' 'wireless_tools' 'yajl')
+depends=('alsa-lib' 'confuse' 'libmpdclient' 'libpulse' 'wireless_tools' 'yajl')
makedepends=('asciidoc' 'git')
provides=('i3status')
conflicts=('i3status' 'i3status-git')
backup=('etc/i3status.conf')
+install=i3status.install
+options=('docs')
source=("$pkgname"::'git://github.com/Gravemind/i3status.git')
sha1sums=('SKIP')
diff --git a/i3status.install b/i3status.install
new file mode 100644
index 000000000000..e86d21b80720
--- /dev/null
+++ b/i3status.install
@@ -0,0 +1,9 @@
+post_install() {
+ setcap 'CAP_NET_ADMIN=ep' /usr/bin/i3status
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+# vim:set ts=2 sw=2 et: