summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO9
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD12
3 files changed, 11 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b43f245df0b7..08ae4c359357 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,15 @@
pkgbase = i4oled
pkgdesc = Utility to set and render OLED icons on Wacom Intuos4 family tablets.
pkgver = 1.3
- pkgrel = 1
- url = https://github.com/PrzemoF/i4oled
+ pkgrel = 2
+ url = https://gitlab.com/PrzemoF/i4oled
arch = i686
arch = x86_64
license = GPL3
depends = pango>=1.29.0
depends = cairo>=1.10.0
depends = libpng
- source = https://github.com/PrzemoF/i4oled/archive/v1.3.tar.gz
- md5sums = 3477a07133fe7d0f7b629b0b1a8d7cdc
+ source = git+https://gitlab.com/PrzemoF/i4oled.git#tag=v1.3
+ sha256sums = SKIP
pkgname = i4oled
-
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..72e8ffc0db8a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+*
diff --git a/PKGBUILD b/PKGBUILD
index 17f6e80a98e0..f6acbe28029d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,23 +4,23 @@
pkgname=i4oled
pkgver=1.3
-pkgrel=1
+pkgrel=2
pkgdesc="Utility to set and render OLED icons on Wacom Intuos4 family tablets."
arch=('i686' 'x86_64')
-url="https://github.com/PrzemoF/i4oled"
+url="https://gitlab.com/PrzemoF/i4oled"
license=('GPL3')
depends=('pango>=1.29.0' 'cairo>=1.10.0' 'libpng')
-source=("https://github.com/PrzemoF/${pkgname}/archive/v${pkgver}.tar.gz")
-md5sums=('3477a07133fe7d0f7b629b0b1a8d7cdc')
+source=("git+https://gitlab.com/PrzemoF/$pkgname.git#tag=v$pkgver")
+sha256sums=('SKIP')
build() {
- cd "$srcdir/$pkgname-$pkgver"
+ cd "$srcdir/$pkgname"
./autogen.sh
./configure --prefix=/usr
make
}
package() {
- cd "$srcdir/$pkgname-$pkgver"
+ cd "$srcdir/$pkgname"
make DESTDIR="$pkgdir" install
}