summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD34
2 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..12b1f8f10d11
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = ibrcommon
+ pkgdesc = IBR-DTN - A modular and lightweight implementation of the bundle protocol - Common libraries
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://github.com/ibrdtn/ibrdtn
+ arch = i686
+ arch = x86_64
+ license = Apache License 2.0
+ makedepends = git
+ makedepends = binutils
+ makedepends = gcc
+ makedepends = libtool
+ makedepends = cppunit
+ makedepends = automake
+ makedepends = autoconf
+ makedepends = pkgconf
+ depends = sqlite
+ depends = libcurl-compat
+ depends = libcurl-gnutls
+ depends = libnl
+ provides = ibrcommon
+ source = git://github.com/ibrdtn/ibrdtn.git
+ sha512sums = SKIP
+
+pkgname = ibrcommon
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..793fcecd9a6f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Lucien LOISEAU (Marlinski) <marlinski@disruptedsystems.org>
+
+pkgname=ibrcommon
+pkgver=1.0.0
+pkgrel=1
+pkgdesc='IBR-DTN - A modular and lightweight implementation of the bundle protocol - Common libraries'
+arch=('i686' 'x86_64')
+url='https://github.com/ibrdtn/ibrdtn'
+license=('Apache License 2.0')
+depends=(libcurl-compat libcurl-gnutls libnl)
+makedepends=(git binutils gcc libtool cppunit automake autoconf pkgconf)
+provides=(ibrcommon)
+
+source=(git://github.com/ibrdtn/ibrdtn.git)
+sha512sums=('SKIP')
+
+prepare() {
+ cd ibrdtn
+}
+
+build() {
+ CXXFLAGS=""
+ cd ibrdtn/ibrcommon
+ [ -f Makefile ] && make clean
+ bash autogen.sh
+ ./configure --prefix=/usr --with-lowpan
+ make -j
+ cd ..
+}
+
+package() {
+ cd ibrdtn/ibrcommon
+ make DESTDIR="$pkgdir" install
+}