summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD25
-rw-r--r--ice.patch73
3 files changed, 80 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index efc232fd3228..9531890579bd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ice-ssb-git
pkgdesc = Desktop integration for webapps
pkgver = 6.0.8.r30.5ddfc8e
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/peppermintos/ice
arch = any
license = GPL2
@@ -22,7 +22,6 @@ pkgbase = ice-ssb-git
source = git+https://github.com/peppermintos/ice.git
source = ice.patch
sha256sums = SKIP
- sha256sums = 1b3ba9c290faa8a9f2c8caf6c754378ac7ae82cf1117318a115e075b800c10d3
+ sha256sums = f5c36986ee2f96860108ae3537fdf9ebb41c4478aa13a9fe3578b18ebd518eb4
pkgname = ice-ssb-git
-
diff --git a/PKGBUILD b/PKGBUILD
index ad18331129a9..c37d3585987b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,11 +4,9 @@
_name=ice
pkgname=ice-ssb-git
-pkgver() {
- git -C "$_name" describe --tags | sed 's/v\?\([^-]\+\)-/\1.r/;s/-g/./'
-}
+pkgver() { git -C "$_name" describe --tags | sed 's/v\?\([^-]\+\)-/\1.r/;s/-g/./'; }
pkgver=6.0.8.r30.5ddfc8e
-pkgrel=1
+pkgrel=2
pkgdesc='Desktop integration for webapps'
url="https://github.com/peppermintos/$_name"
@@ -24,22 +22,21 @@ optdepends=('brave' 'firefox' 'chromium' 'google-chrome' 'vivaldi')
source=("git+$url.git" "$_name.patch")
sha256sums=('SKIP'
- '1b3ba9c290faa8a9f2c8caf6c754378ac7ae82cf1117318a115e075b800c10d3')
+ 'f5c36986ee2f96860108ae3537fdf9ebb41c4478aa13a9fe3578b18ebd518eb4')
prepare() {
- cd "$_name"
- # patch browser binary filenames to match Archlinux packages
- patch --verbose -Np1 <"../$_name.patch"
- # delete PeppermintOS specific assets
- rm -r usr/lib
+ cd "$_name"
+ patch --verbose -Np1 <"../$_name.patch"
+ # delete PeppermintOS specific assets
+ rm -r usr/lib
}
package() {
- cd "$_name"
- cp -a --no-preserve=o usr "$pkgdir/"
- install -Dm644 README.md -t"$pkgdir/usr/share/doc/$_name/"
+ cd "$_name"
+ cp -a --no-preserve=o usr "$pkgdir/"
+ install -Dm644 README.md -t"$pkgdir/usr/share/doc/$_name/"
}
-# vim: ts=4 sw=4 et ft=PKGBUILD:
+# vim: ts=2 sw=2 et ft=PKGBUILD:
diff --git a/ice.patch b/ice.patch
index 267a4f40ae48..58cf7596ffe7 100644
--- a/ice.patch
+++ b/ice.patch
@@ -1,18 +1,79 @@
-diff -rpu --color old/usr/bin/ice new/usr/bin/ice
---- old/usr/bin/ice 2021-05-10 15:47:34.278040167 +0200
-+++ new/usr/bin/ice 2021-05-10 15:48:35.098265219 +0200
-@@ -44,8 +44,8 @@ _EPIPHANY_PROFILES_DIR = "{0}/epiphany".
+Contributor: Kevin Veldman (taconomix) - Thanks !
+
+diff -ru old/usr/bin/ice new/usr/bin/ice
+--- old/usr/bin/ice 2021-07-12 21:31:01.690964712 +0200
++++ new/usr/bin/ice 2021-07-12 21:32:57.990445554 +0200
+@@ -43,9 +43,9 @@
+ _EPIPHANY_PROFILES_DIR = "{0}/epiphany".format(_ICE_DIR)
_ICE_ICON = "/usr/share/pixmaps/ice.png"
_ICON_DIR = "{0}/icons".format(_ICE_DIR)
- _BRAVE_BIN = "/usr/bin/brave-browser"
+-_BRAVE_BIN = "/usr/bin/brave-browser"
-_CHROME_BIN = "/usr/bin/google-chrome"
-_CHROMIUM_BIN = "/usr/bin/chromium-browser"
++_BRAVE_BIN = "/usr/bin/brave"
+_CHROME_BIN = "/usr/bin/google-chrome-stable"
+_CHROMIUM_BIN = "/usr/bin/chromium"
_VIVALDI_BIN = "/usr/bin/vivaldi-stable"
_FIREFOX_BIN = "/usr/bin/firefox"
_EPIPHANY_BIN = "/usr/bin/epiphany"
-@@ -699,7 +699,7 @@ class Ice(Gtk.Window):
+@@ -255,39 +255,39 @@
+ self.isolate_button.add(self.isolate_lab)
+ self.isolate_button.connect("toggled", self.isolate_clicked)
+
+- self.firefox = Gtk.RadioButton.new_with_label_from_widget(None,
+- "Firefox")
++ self.brave = Gtk.RadioButton.new_with_label_from_widget(None,
++ "Brave")
+
+- if not os.path.exists(_FIREFOX_BIN):
+- self.firefox.set_sensitive(False)
++ if not os.path.exists(_BRAVE_BIN):
++ self.brave.set_sensitive(False)
+
+ if not os.path.exists(_CHROMIUM_BIN) and not \
+ os.path.exists(_CHROME_BIN) and not \
+- os.path.exists(_BRAVE_BIN) and not \
++ os.path.exists(_FIREFOX_BIN) and not \
+ os.path.exists(_EPIPHANY_BIN) and not \
+ os.path.exists(_VIVALDI_BIN) and \
+- os.path.exists(_FIREFOX_BIN):
+- self.firefox.set_active(True)
++ os.path.exists(_BRAVE_BIN):
++ self.brave.set_active(True)
+
+- self.firefox.connect("clicked", self.browser_button)
++ self.brave.connect("clicked", self.browser_button)
+
+- self.brave = Gtk.RadioButton.new_from_widget(self.firefox)
+- self.brave.set_label("Brave")
++ self.firefox = Gtk.RadioButton.new_from_widget(self.brave)
++ self.firefox.set_label("Firefox")
+
+- if not os.path.exists(_BRAVE_BIN):
+- self.brave.set_sensitive(False)
++ if not os.path.exists(_FIREFOX_BIN):
++ self.firefox.set_sensitive(False)
+
+ if not os.path.exists(_CHROMIUM_BIN) and not \
+- os.path.exists(_FIREFOX_BIN) and not \
++ os.path.exists(_BRAVE_BIN) and not \
+ os.path.exists(_CHROME_BIN) and not \
+ os.path.exists(_EPIPHANY_BIN) and not \
+ os.path.exists(_VIVALDI_BIN) and \
+- os.path.exists(_BRAVE_BIN):
+- self.brave.set_active(True)
++ os.path.exists(_FIREFOX_BIN):
++ self.firefox.set_active(True)
+
+- self.brave.connect("clicked", self.browser_button)
++ self.firefox.connect("clicked", self.browser_button)
+
+- self.chrome = Gtk.RadioButton.new_from_widget(self.brave)
++ self.chrome = Gtk.RadioButton.new_from_widget(self.firefox)
+ self.chrome.set_label("Chrome")
+
+ if not os.path.exists(_CHROME_BIN):
+@@ -699,7 +699,7 @@
if self.chrome.get_active() is True:
self.browser = "google-chrome"
elif self.chromium.get_active() is True: