summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD45
-rw-r--r--ice.patch14
3 files changed, 85 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..949ce53591a5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = ice-ssb-git
+ pkgdesc = Desktop integration for webapps
+ pkgver = 6.0.8.r3.961cd57
+ pkgrel = 1
+ url = https://github.com/peppermintos/ice
+ arch = any
+ license = GPL2
+ makedepends = git
+ depends = python-requests
+ depends = python-beautifulsoup4
+ depends = python-gobject
+ depends = python-lxml
+ optdepends = brave
+ optdepends = firefox
+ optdepends = chromium
+ optdepends = google-chrome
+ optdepends = vivaldi
+ provides = ice-ssb
+ conflicts = ice-ssb
+ source = git+https://github.com/peppermintos/ice.git
+ source = ice.patch
+ sha256sums = SKIP
+ sha256sums = 8aaff26c46a803ea6fb3a9e442a6fed830ff5c70228939783ceaa33578af5732
+
+pkgname = ice-ssb-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0b94f6342221
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer : Kr1ss $(echo \<kr1ss+x-yandex+com\>|sed s/\+/./g\;s/\-/@/)
+
+
+_pkgname=ice
+pkgname=ice-ssb-git
+
+pkgver() {
+ git -C "$_pkgname" describe --tags | sed 's/v\?\([^-]\+\)-/\1.r/;s/-g/./'
+}
+pkgver=6.0.8.r3.961cd57
+pkgrel=1
+
+pkgdesc='Desktop integration for webapps'
+url="https://github.com/peppermintos/$_pkgname"
+arch=('any')
+license=('GPL2')
+
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+
+makedepends=('git')
+depends=('python-requests' 'python-beautifulsoup4' 'python-gobject' 'python-lxml')
+optdepends=('brave' 'firefox' 'chromium' 'google-chrome' 'vivaldi')
+
+source=("git+$url.git" "$_pkgname.patch")
+sha256sums=('SKIP'
+ '8aaff26c46a803ea6fb3a9e442a6fed830ff5c70228939783ceaa33578af5732')
+
+
+prepare() {
+ cd "$_pkgname"
+ # patch browser binary filenames to match Archlinux packages
+ patch -Np1 <"../$_pkgname.patch"
+ # delete PeppermintOS specific assets
+ rm -r usr/lib
+}
+
+package() {
+ cd "$_pkgname"
+ cp -a --no-preserve=ownership usr "$pkgdir/"
+ install -Dm644 README.md -t"$pkgdir/usr/share/doc/$_pkgname/"
+}
+
+
+# vim: ts=4 sw=4 et ft=PKGBUILD:
diff --git a/ice.patch b/ice.patch
new file mode 100644
index 000000000000..b4286cd9a932
--- /dev/null
+++ b/ice.patch
@@ -0,0 +1,14 @@
+diff --color -ru old/usr/bin/ice new/usr/bin/ice
+--- old/usr/bin/ice 2020-02-03 02:51:36.368382791 +0100
++++ new/usr/bin/ice 2020-02-03 02:52:06.268382110 +0100
+@@ -39,8 +39,8 @@
+ _FF_PROFILES_DIR = "{0}/firefox".format(_ICE_DIR)
+ _ICE_ICON = "/usr/share/pixmaps/ice.png"
+ _BRAVE_BIN = "/usr/bin/brave"
+-_CHROME_BIN = "/usr/bin/google-chrome"
+-_CHROMIUM_BIN = "/usr/bin/chromium-browser"
++_CHROME_BIN = "/usr/bin/google-chrome-stable"
++_CHROMIUM_BIN = "/usr/bin/chromium"
+ _VIVALDI_BIN = "/usr/bin/vivaldi-stable"
+ _FIREFOX_BIN = "/usr/bin/firefox"
+