summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD39
-rw-r--r--firefox-gcc-6.0.patch26
-rw-r--r--fix-wifi-scanner.diff16
-rw-r--r--gcc6-fix-compilation-for-IceCat.patch37
-rw-r--r--mozconfig9
-rw-r--r--rust-i686.patch16
7 files changed, 62 insertions, 105 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 08f51ab6f008..6142d441c236 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = icecat
pkgdesc = GNU version of the Firefox browser.
- pkgver = 45.7.0
+ pkgver = 52.0.2
pkgrel = 1
url = http://www.gnu.org/software/gnuzilla/
arch = i686
@@ -20,6 +20,7 @@ pkgbase = icecat
makedepends = gst-plugins-base-libs
makedepends = inetutils
makedepends = cargo
+ depends = gtk3
depends = gtk2
depends = mozilla-common
depends = libxt
@@ -36,26 +37,25 @@ pkgbase = icecat
depends = sqlite
depends = ttf-font
optdepends = networkmanager: Location detection via available WiFi networks
- optdepends = upower: Battery API
- options = !emptydirs
- options = !makeflags
- source = http://ftpmirror.gnu.org/gnuzilla/45.7.0/icecat-45.7.0-gnu1.tar.bz2
- source = http://ftpmirror.gnu.org/gnuzilla/45.7.0/icecat-45.7.0-gnu1.tar.bz2.sig
+ optdepends = libnotify: Notification integration
+ optdepends = speech-dispatcher: Text-to-Speech
+ source = http://ftpmirror.gnu.org/gnuzilla/52.0.2/icecat-52.0.2-gnu1.tar.bz2
+ source = http://ftpmirror.gnu.org/gnuzilla/52.0.2/icecat-52.0.2-gnu1.tar.bz2.sig
source = mozconfig
source = icecat.desktop
source = icecat-safe.desktop
source = vendor.js
- source = gcc6-fix-compilation-for-IceCat.patch
- source = firefox-gcc-6.0.patch
+ source = rust-i686.patch
+ source = fix-wifi-scanner.diff
validpgpkeys = A57369A8BABC2542B5A0368C3C76EED7D7E04784
- sha256sums = 635b2d458b22221dcaff4463ce3ed2983e6fc4981c09170899fd63ea231dc7d6
+ sha256sums = 8901a4ab7f2b87d5516c77cbdec6d276cdde64421725d4ed613c1b4f805a4a2b
sha256sums = SKIP
- sha256sums = 0f9c8f4e7795ded4f661af9ff73a5b091fda4eebc969a76e00e48d005feebe7d
+ sha256sums = 1fe0c64404ec088ad3900bf482ab9cdd317b2f57c8fcc3b38e9f3321fb237b60
sha256sums = c44eab35f71dd3028a74632463710d674b2e8a0682e5e887535e3233a3b7bbb3
sha256sums = 190577ad917bccfc89a9bcafbc331521f551b6f54e190bb6216eada48dcb1303
sha256sums = 4b50e9aec03432e21b44d18c4c97b2630bace606b033f7d556c9d3e3eb0f4fa4
- sha256sums = 329cf6753d29ae64a4336a8a76ee71f0d331a39132159401e4d11de65b708a07
- sha256sums = 4d1e1ddabc9e975ed39f49e134559a29e01cd49439e358233f1ede43bf5a52bf
+ sha256sums = f61ea706ce6905f568b9bdafd1b044b58f20737426f0aa5019ddb9b64031a269
+ sha256sums = 9765bca5d63fb5525bbd0520b7ab1d27cabaed697e2fc7791400abc3fa4f13b8
pkgname = icecat
diff --git a/PKGBUILD b/PKGBUILD
index d9ae43c930b2..da11d075d0f0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
# Contributor: Muhammad 'MJ' Jassim <UnbreakableMJ@gmail.com>
pkgname=icecat
-pkgver=45.7.0
+pkgver=52.0.2
_pkgver=${pkgver}-gnu1
_pkgverbase=${pkgver%%.*}
pkgrel=1
@@ -14,33 +14,28 @@ pkgdesc="GNU version of the Firefox browser."
arch=(i686 x86_64)
url="http://www.gnu.org/software/gnuzilla/"
license=('GPL' 'MPL' 'LGPL')
-depends=('gtk2' 'mozilla-common' 'libxt' 'startup-notification' 'mime-types'
- 'dbus-glib' 'alsa-lib' 'ffmpeg'
+depends=('gtk3' 'gtk2' 'mozilla-common' 'libxt' 'startup-notification' 'mime-types' 'dbus-glib' 'alsa-lib' 'ffmpeg'
'libvpx' 'icu' 'libevent' 'nss' 'hunspell' 'sqlite' 'ttf-font')
makedepends=('unzip' 'zip' 'diffutils' 'python2' 'yasm' 'mesa' 'imake' 'gconf'
'libpulse' 'gst-plugins-base-libs' 'inetutils' 'cargo')
optdepends=('networkmanager: Location detection via available WiFi networks'
- 'upower: Battery API')
-options=('!emptydirs' '!makeflags')
+ 'libnotify: Notification integration'
+ 'speech-dispatcher: Text-to-Speech')
source=(http://ftpmirror.gnu.org/gnuzilla/${pkgver}/${pkgname}-${_pkgver}.tar.bz2{,.sig}
#source=(https://ftp.gnu.org/gnu/gnuzilla/${pkgver}/${pkgname}-${_pkgver}.tar.bz2{,.sig} ## Main upstream download site
#source=(https://mirrors.kernel.org/gnu/gnuzilla/${pkgver}/${pkgname}-${_pkgver}.tar.bz2 ## Good mirror
#source=(http://jenkins.trisquel.info/icecat/${pkgname}-${_pkgver}.tar.bz2 ## Official developer (Ruben Rodriguez) site. Probably only has developer releases.
- mozconfig
- icecat.desktop
- icecat-safe.desktop
- vendor.js
- gcc6-fix-compilation-for-IceCat.patch
- firefox-gcc-6.0.patch)
-
-sha256sums=('635b2d458b22221dcaff4463ce3ed2983e6fc4981c09170899fd63ea231dc7d6'
+ mozconfig icecat.desktop icecat-safe.desktop vendor.js
+ rust-i686.patch fix-wifi-scanner.diff)
+
+sha256sums=('8901a4ab7f2b87d5516c77cbdec6d276cdde64421725d4ed613c1b4f805a4a2b'
'SKIP'
- '0f9c8f4e7795ded4f661af9ff73a5b091fda4eebc969a76e00e48d005feebe7d'
+ '1fe0c64404ec088ad3900bf482ab9cdd317b2f57c8fcc3b38e9f3321fb237b60'
'c44eab35f71dd3028a74632463710d674b2e8a0682e5e887535e3233a3b7bbb3'
'190577ad917bccfc89a9bcafbc331521f551b6f54e190bb6216eada48dcb1303'
'4b50e9aec03432e21b44d18c4c97b2630bace606b033f7d556c9d3e3eb0f4fa4'
- '329cf6753d29ae64a4336a8a76ee71f0d331a39132159401e4d11de65b708a07'
- '4d1e1ddabc9e975ed39f49e134559a29e01cd49439e358233f1ede43bf5a52bf')
+ 'f61ea706ce6905f568b9bdafd1b044b58f20737426f0aa5019ddb9b64031a269'
+ '9765bca5d63fb5525bbd0520b7ab1d27cabaed697e2fc7791400abc3fa4f13b8')
validpgpkeys=(A57369A8BABC2542B5A0368C3C76EED7D7E04784) # Ruben Rodriguez (GNU IceCat releases key) <ruben@gnu.org>
@@ -52,10 +47,12 @@ prepare() {
sed -e 's;$(libdir)/$(MOZ_APP_NAME)-$(MOZ_APP_VERSION);$(libdir)/$(MOZ_APP_NAME);g' -i config/baseconfig.mk
sed -e 's;$(libdir)/$(MOZ_APP_NAME)-devel-$(MOZ_APP_VERSION);$(libdir)/$(MOZ_APP_NAME)-devel;g' -i config/baseconfig.mk
- # Compilation fix (FS#49243 and FS#49363), internet and Thunderbird package
- patch -Np1 -i $srcdir/gcc6-fix-compilation-for-IceCat.patch
- patch -Np1 -i $srcdir/firefox-gcc-6.0.patch
+ # https://bugzilla.mozilla.org/show_bug.cgi?id=1314968
+ patch -Np1 -i ../fix-wifi-scanner.diff
+ # Build with the rust targets we actually ship
+ patch -Np1 -i ../rust-i686.patch
+
msg2 "Starting build..."
cp -v ${srcdir}/mozconfig .mozconfig
@@ -76,10 +73,6 @@ build() {
# Hardening
LDFLAGS+=" -Wl,-z,now"
- # GCC 6
- CFLAGS+=" -fno-delete-null-pointer-checks -fno-lifetime-dse -fno-schedule-insns2"
- CXXFLAGS+=" -fno-delete-null-pointer-checks -fno-lifetime-dse -fno-schedule-insns2"
-
export PATH="$srcdir/path:$PATH"
make -f client.mk build
diff --git a/firefox-gcc-6.0.patch b/firefox-gcc-6.0.patch
deleted file mode 100644
index 0a74d3616e3f..000000000000
--- a/firefox-gcc-6.0.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-diff -up firefox-44.0/nsprpub/config/make-system-wrappers.pl.back firefox-44.0/nsprpub/config/make-system-wrappers.pl
---- firefox-44.0/nsprpub/config/make-system-wrappers.pl.back 2016-01-24 00:23:49.000000000 +0100
-+++ firefox-44.0/nsprpub/config/make-system-wrappers.pl 2016-02-02 14:58:45.064112655 +0100
-@@ -19,7 +19,9 @@ while (<STDIN>) {
- open OUT, ">$output_dir/$_";
- print OUT "#pragma GCC system_header\n"; # suppress include_next warning
- print OUT "#pragma GCC visibility push(default)\n";
-+ print OUT "#define _GLIBCXX_INCLUDE_NEXT_C_HEADERS\n";
- print OUT "#include_next \<$_\>\n";
-+ print OUT "#undef _GLIBCXX_INCLUDE_NEXT_C_HEADERS\n";
- print OUT "#pragma GCC visibility pop\n";
- close OUT;
- }
-diff -up firefox-44.0/mozglue/build/arm.cpp.old firefox-44.0/mozglue/build/arm.cpp
---- firefox-44.0/mozglue/build/arm.cpp.old 2016-02-03 10:07:29.879526500 +0100
-+++ firefox-44.0/mozglue/build/arm.cpp 2016-02-03 10:08:11.062697517 +0100
-@@ -104,7 +104,9 @@ check_neon(void)
-
- # elif defined(__linux__) || defined(ANDROID)
- # include <stdio.h>
-+#define _GLIBCXX_INCLUDE_NEXT_C_HEADERS
- # include <stdlib.h>
-+#undef _GLIBCXX_INCLUDE_NEXT_C_HEADERS
- # include <string.h>
-
- enum{
diff --git a/fix-wifi-scanner.diff b/fix-wifi-scanner.diff
new file mode 100644
index 000000000000..f8fdd6c42142
--- /dev/null
+++ b/fix-wifi-scanner.diff
@@ -0,0 +1,16 @@
+ netwerk/wifi/nsWifiScannerDBus.cpp | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git c/netwerk/wifi/nsWifiScannerDBus.cpp i/netwerk/wifi/nsWifiScannerDBus.cpp
+index 182553e18fa6e104..6fa0a0b023d3e45f 100644
+--- c/netwerk/wifi/nsWifiScannerDBus.cpp
++++ i/netwerk/wifi/nsWifiScannerDBus.cpp
+@@ -62,7 +62,7 @@ nsWifiScannerDBus::SendMessage(const char* aInterface,
+ return NS_ERROR_FAILURE;
+ }
+ } else if (!strcmp(aFuncCall, "GetAll")) {
+- const char* param = "";
++ const char* param = "org.freedesktop.NetworkManager.AccessPoint";
+ if (!dbus_message_iter_append_basic(&argsIter, DBUS_TYPE_STRING, &param)) {
+ return NS_ERROR_FAILURE;
+ }
diff --git a/gcc6-fix-compilation-for-IceCat.patch b/gcc6-fix-compilation-for-IceCat.patch
deleted file mode 100644
index 2c291567c116..000000000000
--- a/gcc6-fix-compilation-for-IceCat.patch
+++ /dev/null
@@ -1,37 +0,0 @@
---- a/config/gcc-stl-wrapper.template.h 2016-05-10 22:26:46.000000000 +0200
-+++ b/config/gcc-stl-wrapper.template.h 2016-05-23 23:48:21.137431360 +0200
-@@ -22,6 +22,11 @@
- #define NOMINMAX 1
- #endif
-
-+// Don't include mozalloc for cstdlib. See bug 1245076.
-+#ifndef moz_dont_include_mozalloc_for_cstdlib
-+# define moz_dont_include_mozalloc_for_cstdlib
-+#endif
-+#ifndef moz_dont_include_mozalloc_for_${HEADER}
- // mozalloc.h wants <new>; break the cycle by always explicitly
- // including <new> here. NB: this is a tad sneaky. Sez the gcc docs:
- //
-@@ -30,15 +35,17 @@
- // same name as the current file. It simply looks for the file
- // named, starting with the directory in the search path after the
- // one where the current file was found.
--#include_next <new>
-+# include_next <new>
-
- // See if we're in code that can use mozalloc. NB: this duplicates
- // code in nscore.h because nscore.h pulls in prtypes.h, and chromium
- // can't build with that being included before base/basictypes.h.
--#if !defined(XPCOM_GLUE) && !defined(NS_NO_XPCOM) && !defined(MOZ_NO_MOZALLOC)
--# include "mozilla/mozalloc.h"
--#else
--# error "STL code can only be used with infallible ::operator new()"
-+# if !defined(XPCOM_GLUE) && !defined(NS_NO_XPCOM) && !defined(MOZ_NO_MOZALLOC)
-+# include "mozilla/mozalloc.h"
-+# else
-+# error "STL code can only be used with infallible ::operator new()"
-+# endif
-+
- #endif
-
- #if defined(DEBUG) && !defined(_GLIBCXX_DEBUG)
diff --git a/mozconfig b/mozconfig
index 05cc1fe4bc0a..9be69c316795 100644
--- a/mozconfig
+++ b/mozconfig
@@ -4,7 +4,7 @@ ac_add_options --prefix=/usr
ac_add_options --libdir=/usr/lib
ac_add_options --enable-gold
ac_add_options --enable-pie
-ac_add_options --enable-rust
+#ac_add_options --enable-rust
ac_add_options --enable-official-branding
ac_add_options --with-distribution-id=org.gnu
@@ -13,7 +13,6 @@ ac_add_options --with-system-nspr
ac_add_options --with-system-nss
ac_add_options --with-system-icu
ac_add_options --with-system-jpeg
-ac_add_options --with-system-png
ac_add_options --with-system-zlib
ac_add_options --with-system-bz2
ac_add_options --with-system-libevent
@@ -22,16 +21,12 @@ ac_add_options --enable-system-hunspell
ac_add_options --enable-system-sqlite
ac_add_options --enable-system-ffi
ac_add_options --enable-system-pixman
-ac_add_options --enable-system-cairo
# Features
-ac_add_options --enable-optimize --disable-debug
ac_add_options --enable-startup-notification
-ac_add_options --enable-gstreamer=1.0
+ac_add_options --enable-alsa
ac_add_options --disable-updater
ac_add_options --disable-crashreporter
-ac_add_options --disable-installer
-ac_add_options --disable-telemetry
ac_add_options --disable-debug-symbols
ac_add_options --disable-tests
ac_add_options --disable-eme
diff --git a/rust-i686.patch b/rust-i686.patch
new file mode 100644
index 000000000000..85512e1436b8
--- /dev/null
+++ b/rust-i686.patch
@@ -0,0 +1,16 @@
+ build/moz.configure/rust.configure | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git c/build/moz.configure/rust.configure i/build/moz.configure/rust.configure
+index cd86b24153debb1b..44911715e25d95e3 100644
+--- c/build/moz.configure/rust.configure
++++ i/build/moz.configure/rust.configure
+@@ -81,7 +81,7 @@ def rust_target(rust_compiler, rustc, target, cross_compiling):
+ # OpenBSD
+ ('x86_64', 'OpenBSD'): 'x86_64-unknown-openbsd',
+ # Linux
+- ('x86', 'Linux'): 'i586-unknown-linux-gnu',
++ ('x86', 'Linux'): 'i686-unknown-linux-gnu',
+ # Linux
+ ('x86_64', 'Linux'): 'x86_64-unknown-linux-gnu',
+ # OS X and iOS