summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD11
-rw-r--r--icemon.install13
4 files changed, 32 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f9cefbc8f87c..c55fd5410b1f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,23 @@
+# Generated by mksrcinfo v8
+# Mon Feb 15 21:19:41 UTC 2016
pkgbase = icemon
pkgdesc = Icecream GUI monitor.
- pkgver = 3.0.0
- pkgrel = 2
+ pkgver = 3.0.1
+ pkgrel = 1
url = https://github.com/icecc/icemon
+ install = icemon.install
arch = i686
arch = x86_64
license = GPL
makedepends = cmake
makedepends = docbook2x
- depends = icecc
+ depends = icecream
depends = qt5-base>=5.2
+ depends = hicolor-icon-theme
provides = icemon
conflicts = icemon-git
- source = https://github.com/icecc/icemon/archive/v3.0.0.tar.gz
- md5sums = 7ba23d812db4bdd32d52e947c5749217
+ source = https://github.com/icecc/icemon/archive/v3.0.1.tar.gz
+ md5sums = 0127427ac71ccb198706d2575be246ec
pkgname = icemon
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..ae189c7a3121
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/src
+/pkg
+/*.tar.gz
+/*.pkg.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
index aaac1174dde0..9550d59590cd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,20 @@
# Maintainer: Alex Merry <alexmerry@kde.org>
pkgname='icemon'
-pkgver=3.0.0
-pkgrel=2
+pkgver=3.0.1
+pkgrel=1
pkgdesc='Icecream GUI monitor.'
url='https://github.com/icecc/icemon'
license=('GPL')
-depends=('icecc' 'qt5-base>=5.2')
+depends=('icecream' 'qt5-base>=5.2' 'hicolor-icon-theme')
# docbook2x required for man page generation
makedepends=('cmake' 'docbook2x')
provides=('icemon')
conflicts=('icemon-git')
arch=('i686' 'x86_64')
-source=('https://github.com/icecc/icemon/archive/v3.0.0.tar.gz')
-md5sums=('7ba23d812db4bdd32d52e947c5749217')
+install=icemon.install
+source=("https://github.com/icecc/${pkgname}/archive/v${pkgver}.tar.gz")
+md5sums=('0127427ac71ccb198706d2575be246ec')
build() {
mkdir -p build
diff --git a/icemon.install b/icemon.install
new file mode 100644
index 000000000000..f30d282c7b54
--- /dev/null
+++ b/icemon.install
@@ -0,0 +1,13 @@
+post_install() {
+ xdg-icon-resource forceupdate --theme hicolor &> /dev/null
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ xdg-icon-resource forceupdate --theme hicolor &> /dev/null
+ update-desktop-database -q
+}