summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD12
2 files changed, 14 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f94cff9a7e77..486968737d8c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,12 @@
+# Generated by mksrcinfo v8
+# Fri Dec 18 05:01:36 UTC 2015
pkgbase = icestorm-git
pkgdesc = Lattice iCE40 FPGAs Bitstream Documentation (Reverse Engineered)
- pkgver = r63.c6f1e1f
- pkgrel = 1
+ pkgver = r115.da99818
+ pkgrel = 2
url = http://www.clifford.at/icestorm/
arch = x86_64
- license = unknown
+ license = custom:ISC
makedepends = git
depends = python
depends = libftdi
diff --git a/PKGBUILD b/PKGBUILD
index 3697f886d6b1..ad28c9d4e8fb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,11 @@
# Maintainer: Sebastian Bøe <sebastianbooe@gmail.com>
pkgname=icestorm-git
-pkgver=r63.c6f1e1f
-pkgrel=1
+pkgver=r115.da99818
+pkgrel=2
pkgdesc="Lattice iCE40 FPGAs Bitstream Documentation (Reverse Engineered)"
arch=('x86_64')
url="http://www.clifford.at/icestorm/"
-license=('unknown')
+license=('custom:ISC')
depends=('python' 'libftdi')
makedepends=('git')
provides=("${pkgname%-git}")
@@ -27,5 +27,11 @@ build() {
package() {
cd "$srcdir/${pkgname%-git}"
+
+ # Move the license file into place
+ install -dm 755 "$pkgdir/usr/share/licenses/$pkgname"
+ install -m 644 README "$pkgdir/usr/share/licenses/$pkgname"
+
+ # Install the package
make DESTDIR="$pkgdir/usr" install
}