summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD15
2 files changed, 8 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1a39512dced9..3f96adea8267 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,13 @@
pkgbase = icetop-git
pkgdesc = Terminal top-like monitor for icecream/icecc
- pkgver = r25.8f2a355
+ pkgver = r37.48482f3
pkgrel = 1
url = https://github.com/aperezdc/icetop
arch = x86_64
arch = i686
license = GPL2
- makedepends = autoconf
+ makedepends = meson
+ makedepends = ninja
depends = icecream
depends = libdill
depends = libtickit-bzr
diff --git a/PKGBUILD b/PKGBUILD
index e47b1b261b5c..f074c3fbf87b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,12 @@
# Maintainer: Adrián Pérez de Castro <aperez@igalia.com>
pkgdesc='Terminal top-like monitor for icecream/icecc'
pkgname='icetop-git'
-pkgver=r25.8f2a355
+pkgver=r37.48482f3
pkgrel=1
license=('GPL2')
arch=('x86_64' 'i686')
depends=('icecream' 'libdill' 'libtickit-bzr')
-makedepends=('autoconf')
+makedepends=('meson' 'ninja')
url='https://github.com/aperezdc/icetop'
source=("${pkgname}::git+${url}")
sha512sums=("SKIP")
@@ -20,18 +20,13 @@ pkgver () {
)
}
-prepare () {
- cd "${pkgname}"
- autoreconf -i -v
-}
-
build () {
cd "${pkgname}"
- ./configure --prefix=/usr
- make
+ meson --buildtype release --prefix /usr build
+ ninja -C build
}
package () {
cd "${pkgname}"
- make install DESTDIR="${pkgdir}"
+ DESTDIR="${pkgdir}" ninja -C build install
}