summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD42
-rw-r--r--hotspotfix.patch25
3 files changed, 59 insertions, 27 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e1531ac97cb6..93af5836e4ac 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,19 @@
+# Generated by mksrcinfo v8
+# Wed Mar 27 09:15:59 UTC 2019
pkgbase = icon-slicer
- pkgdesc = A utility for generating icon themes and libXcursor cursor themes
+ pkgdesc = Utility for generating icon themes and libXcursor cursor themes
pkgver = 0.3
- pkgrel = 6
- url = http://freedesktop.org/wiki/Software/icon-slicer
- arch = i686
+ pkgrel = 2
+ url = https://www.freedesktop.org/wiki/Software/icon-slicer/
arch = x86_64
- license = GPL
+ license = MIT
depends = gdk-pixbuf2
depends = popt
depends = xorg-xcursorgen
- source = http://freedesktop.org/software/icon-slicer/releases/icon-slicer-0.3.tar.gz
- source = hotspots.patch
- sha1sums = 82284a87061ad9e1872e61963597c39ddcba53da
- sha1sums = b9bf8e11ebc444fbcb3f6995d7e5a649f79d346f
+ source = https://freedesktop.org/software/icon-slicer/releases/icon-slicer-0.3.tar.gz
+ source = hotspotfix.patch
+ sha256sums = 05f0216dd0c25a17859de66357f64da5033375b6fbf5f31ca54867311160b64d
+ sha256sums = 7000ab887b247f24d22ba225934028b1f5b04c1fb8ceac04d01e925b7a602dd0
pkgname = icon-slicer
diff --git a/PKGBUILD b/PKGBUILD
index 87ffa729da6f..9621f5da63d2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,35 @@
-# Contributor: William Rea <sillywilly@gmail.com>
-# Maintainer: Davorin Učakar <davorin.ucakar@gmail.com>
+# Maintainer:
+# Contributor: Balló György <ballogyor+arch at gmail dot com>
pkgname=icon-slicer
pkgver=0.3
-pkgrel=6
-pkgdesc='A utility for generating icon themes and libXcursor cursor themes'
-arch=('i686' 'x86_64')
-url='http://freedesktop.org/wiki/Software/icon-slicer'
-license=('GPL')
+pkgrel=2
+pkgdesc="Utility for generating icon themes and libXcursor cursor themes"
+arch=('x86_64')
+url="https://www.freedesktop.org/wiki/Software/icon-slicer/"
+license=('MIT')
depends=('gdk-pixbuf2' 'popt' 'xorg-xcursorgen')
-source=("http://freedesktop.org/software/${pkgname}/releases/icon-slicer-${pkgver}.tar.gz"
- 'hotspots.patch')
-sha1sums=('82284a87061ad9e1872e61963597c39ddcba53da'
- 'b9bf8e11ebc444fbcb3f6995d7e5a649f79d346f')
+source=(https://freedesktop.org/software/icon-slicer/releases/$pkgname-$pkgver.tar.gz
+ hotspotfix.patch)
+sha256sums=('05f0216dd0c25a17859de66357f64da5033375b6fbf5f31ca54867311160b64d'
+ '7000ab887b247f24d22ba225934028b1f5b04c1fb8ceac04d01e925b7a602dd0')
-build() {
- cd "${srcdir}/icon-slicer-${pkgver}"
+prepare() {
+ cd $pkgname-$pkgver
+ patch -Np1 -i ../hotspotfix.patch
+}
- patch -p1 -i "${srcdir}/hotspots.patch"
- ./configure --prefix=/usr
- make || return 1
+build() {
+ cd $pkgname-$pkgver
+ ./configure --prefix=/usr
+ make
}
package() {
- cd "${srcdir}/icon-slicer-${pkgver}"
+ cd $pkgname-$pkgver
+ make DESTDIR="$pkgdir" install
- make DESTDIR="${pkgdir}" install
+ # License
+ install -dm755 "$pkgdir/usr/share/licenses/$pkgname"
+ sed '/License/,$!d' README >"$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}
diff --git a/hotspotfix.patch b/hotspotfix.patch
new file mode 100644
index 000000000000..5924f003bbaa
--- /dev/null
+++ b/hotspotfix.patch
@@ -0,0 +1,25 @@
+Description: Fix hotspot y coordinate
+Author: Tim Swast <tswast@gmail.com>
+
+--- a/src/main.c
++++ b/src/main.c
+@@ -103,7 +103,7 @@
+ if (n_channels == 3)
+ {
+ out->x = start_x;
+- out->y = start_x;
++ out->y = start_y;
+ out->width = source->gridsize;
+ out->height = source->gridsize;
+
+@@ -137,8 +137,8 @@
+ {
+ min_x = start_x + i;
+ max_x = start_x + i + 1;
+- min_y = start_y + i;
+- max_y = start_y + i + 1;
++ min_y = start_y + j;
++ max_y = start_y + j + 1;
+
+ found = TRUE;
+ }