summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD27
2 files changed, 26 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3ba0b48a41cb..10ff76ef1457 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,17 @@
-pkgbase = id3
- pkgdesc = Utility to edit id3v1 and id3v2 tags
- pkgver = 0.80
+pkgbase = id3-git
+ pkgdesc = id3 mass tagger is a tool for listing and manipulating ID3 and Lyrics3 tags in multiple files.
+ pkgver = r569.51e738e
pkgrel = 1
url = https://squell.github.io/id3/
+ arch = i686
arch = x86_64
license = BSD
+ makedepends = git
depends = gcc-libs
+ conflicts = id3
options = !makeflags
- source = https://github.com/squell/id3/releases/download/0.80/id3-0.80.tar.gz
- md5sums = 9eb2bca6ec194f0b6a56d91c7f433dd5
+ source = id3-git::git+https://github.com/squell/id3.git
+ md5sums = SKIP
-pkgname = id3
+pkgname = id3-git
diff --git a/PKGBUILD b/PKGBUILD
index ded97a5b08e3..aca41c52e92a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,34 @@
-# Maintainer: Lucas Saliés Brum <lucas@archlinux.com.br>
+# Maintainer: dllud <dllud riseup net>
+# Contributor: Lucas Saliés Brum <lucas@archlinux.com.br>
# Contributor: Giovanni Scafora <giovanni@archlinux.org>
# Contributor: Jochem Kossen <j.kossen@home.nl>
-pkgname=id3
-pkgver=0.80
+pkgname=id3-git
+pkgver=r569.51e738e
pkgrel=1
-pkgdesc="Utility to edit id3v1 and id3v2 tags"
-arch=('x86_64')
+pkgdesc="id3 mass tagger is a tool for listing and manipulating ID3 and Lyrics3 tags in multiple files."
url="https://squell.github.io/id3/"
+arch=('i686' 'x86_64')
license=('BSD')
depends=('gcc-libs')
+makedepends=('git')
+conflicts=('id3')
options=('!makeflags')
-source=("https://github.com/squell/${pkgname}/releases/download/${pkgver}/${pkgname}-${pkgver}.tar.gz")
-md5sums=('9eb2bca6ec194f0b6a56d91c7f433dd5')
+source=("$pkgname::git+https://github.com/squell/id3.git")
+md5sums=('SKIP')
-build() {
- cd "${srcdir}/${pkgname}-${pkgver}"
+pkgver() {
+ cd "$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ }
+build() {
+ cd "$pkgname"
make
}
package() {
- cd "${srcdir}/${pkgname}-${pkgver}"
+ cd "$pkgname"
make prefix="${pkgdir}/usr" mandir="${pkgdir}/usr/share/man" install
#install license