summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PKGBUILD4
1 files changed, 3 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a463da898474..605f49b1a7f6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -16,8 +16,10 @@ package() {
install -d "${pkgdir}/usr/bin"
install -d "${pkgdir}/usr/share/"{icons,applications,licenses/${pkgname}}
+ # chroot is needed to prevent the installer from creating a single file outside of prefix
+ mkdir -p ../tmp
chmod +x ${_installer}
- ./${_installer} --mode unattended --prefix "${pkgdir}/opt/${pkgname}"
+ fakechroot chroot ../ /${_installer} --mode unattended --prefix "/pkg/${pkgname}/opt/${pkgname}"
install ../ida-free.desktop "${pkgdir}/usr/share/applications"
# the installer needlessly makes a lot of files executable