summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD36
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..092d9dc999dd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = ideamaker
+ pkgdesc = Fast and user friendly 3D slicer for FDM printers
+ pkgver = 2.6.0
+ pkgrel = 1
+ url = https://www.raise3d.com/pages/ideamaker
+ arch = x86_64
+ license = other
+ makedepends = binutils
+ depends = mesa-libgl
+ depends = desktop-file-utils
+ source = https://s3.amazonaws.com/ideamaker/linux/ideaMaker_2.6.0-ubuntu_amd64.deb
+ md5sums = fdd940067eca434cf43e608368789452
+
+pkgname = ideamaker
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..639c7339da92
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# Maintainer: Fabien Devaux <fdev31@gmail.com>
+pkgname=ideamaker
+pkgver=2.6.0
+pkgrel=1
+epoch=
+pkgdesc="Fast and user friendly 3D slicer for FDM printers"
+arch=('x86_64')
+url="https://www.raise3d.com/pages/ideamaker"
+license=('other')
+groups=()
+depends=('mesa-libgl' 'desktop-file-utils')
+makedepends=('binutils')
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("https://s3.amazonaws.com/ideamaker/linux/ideaMaker_${pkgver}-ubuntu_amd64.deb")
+noextract=()
+md5sums=('fdd940067eca434cf43e608368789452')
+validpgpkeys=()
+
+package() {
+ tar xf "$srcdir/data.tar.xz" -C "${pkgdir}"
+ mkdir -p "${pkgdir}/usr/bin"
+ ln -fs "/usr/lib/x86_64-linux-gnu/ideamaker/ideamaker-start.sh" "${pkgdir}/usr/bin/ideamaker"
+}