summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD34
2 files changed, 19 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ffbc80c2bd82..8b78cdad78ca 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ido-ubuntu
pkgdesc = Widgets and other objects used for indicators
- pkgver = 13.10.0.15.10.20151002
+ pkgver = 13.10.0.17.04.20161028
pkgrel = 1
url = https://launchpad.net/ido
arch = i686
@@ -11,12 +11,10 @@ pkgbase = ido-ubuntu
makedepends = gtk-doc
makedepends = vala
makedepends = xorg-util-macros
- depends = gtk3-ubuntu
- provides = ido=13.10.0.15.10.20151002
- conflicts = ido
- source = https://launchpad.net/ubuntu/+archive/primary/+files/ido_13.10.0+15.10.20151002.orig.tar.gz
+ depends = gtk3
+ source = https://launchpad.net/ubuntu/+archive/primary/+files/ido_13.10.0+17.04.20161028.orig.tar.gz
source = 0001-Temporarily-disable-previous-button-drop-shadow-draw.patch
- sha512sums = df6b991819da8c680b8019c4834bfe35ca2de8c22c4a49e8f2775da47ebd705df91b73bf95b98d0e9cd3cdad1244c75996febdf7c3a89f3eea258c12411ae398
+ sha512sums = 867157c9e316eb5ed69ebdf1017ed86990aabf7a885ba26acab36782f0f27e10b4621a7db15ac90335e808022490a98560d5ff443e6f697c578eed5868385ebd
sha512sums = 91d19642868a3859a860fc1a32541141472b8af46d9d2fa6983dd41ec6e0497ca6397a836a0921ba000e26be2be5b8d52ae74b0c5c29b4b73e4f6bce67f9b60d
pkgname = ido-ubuntu
diff --git a/PKGBUILD b/PKGBUILD
index c150367dcde0..9e410fb8323b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,47 +1,43 @@
+# Maintainer: Xiao-Long Chen <chenxiaolong@cxl.epac.to>
# Maintainer: Michael Healy <horsemanoffaith@gmail.com>
-# Contributor: Balló György <ballogyor+arch@gmail.com>
+# Original Maintainer: György Balló <ballogy@freestart.hu>
# Contributor: thn81 <root@scrat>
# vercheck-pkgbuild: auto
-# vercheck-ubuntu: name=${pkgname}, repo=xenial
+# vercheck-ubuntu: name=${pkgname}, repo=zesty
# vercheck-launchpad: name=${pkgname}
pkgname=ido-ubuntu
_actual_ver=13.10.0
-_extra_ver=+15.10.20151002
+_extra_ver=+17.04.20161028
pkgver=${_actual_ver}${_extra_ver/\+/.}
pkgrel=1
pkgdesc="Widgets and other objects used for indicators"
arch=(i686 x86_64)
url="https://launchpad.net/ido"
license=(LGPL)
-depends=(gtk3-ubuntu)
+depends=(gtk3)
makedepends=(gobject-introspection gtk-doc vala xorg-util-macros)
-provides=("ido=${pkgver}")
-conflicts=(ido)
groups=(unity)
source=("https://launchpad.net/ubuntu/+archive/primary/+files/ido_${_actual_ver}${_extra_ver}.orig.tar.gz"
0001-Temporarily-disable-previous-button-drop-shadow-draw.patch)
-sha512sums=('df6b991819da8c680b8019c4834bfe35ca2de8c22c4a49e8f2775da47ebd705df91b73bf95b98d0e9cd3cdad1244c75996febdf7c3a89f3eea258c12411ae398'
+sha512sums=('867157c9e316eb5ed69ebdf1017ed86990aabf7a885ba26acab36782f0f27e10b4621a7db15ac90335e808022490a98560d5ff443e6f697c578eed5868385ebd'
'91d19642868a3859a860fc1a32541141472b8af46d9d2fa6983dd41ec6e0497ca6397a836a0921ba000e26be2be5b8d52ae74b0c5c29b4b73e4f6bce67f9b60d')
prepare() {
- cd "ido-${_actual_ver}${_extra_ver}"
-
- patch -p1 -i ../0001-Temporarily-disable-previous-button-drop-shadow-draw.patch
+
+ patch -p1 -i ../0001-Temporarily-disable-previous-button-drop-shadow-draw.patch
}
build() {
- cd "ido-${_actual_ver}${_extra_ver}"
-
- export CFLAGS+=" -Wno-error"
- autoreconf -vfi
- ./configure --prefix=/usr --disable-static --disable-introspection
- make
+
+ export CFLAGS+=" -Wno-error"
+ autoreconf -vfi
+ ./configure --prefix=/usr --disable-static --disable-introspection
+ make
}
package() {
- cd "ido-${_actual_ver}${_extra_ver}"
-
- make DESTDIR="${pkgdir}/" install
+
+ make DESTDIR="${pkgdir}/" install
}