summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD8
-rw-r--r--idos-timetable-browser.install16
-rwxr-xr-xidos-timetable-browser.sh8
4 files changed, 21 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3a22416e7665..941bd95c1401 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = idos-timetable-browser-latest
pkgdesc = Offline railway and other public transport timetable search engine by CHAPS. (Czech language by default.)
pkgver = 1.27_lib2.8.0.1
- pkgrel = 7
+ pkgrel = 8
epoch = 0
url = http://chaps.cz/eng/download/idos/zip#kotvaprg
arch = i686
@@ -28,13 +28,13 @@ pkgbase = idos-timetable-browser-latest
source = ReadMe.en.txt
source = idos-timetable-browser.install
sha256sums = SKIP
- sha256sums = 969d4418181c9fed180e240c4a73fbfa57e126f77c1c4c6e9217d515a1e6913f
+ sha256sums = 013fa1d41b6c13fd079c16578390d5b75ad3f1228fd38a7ac17756bd74ace94e
sha256sums = e904d167ccdcfb2743f4cfd596aaa9dce8b751fb5c8315b972b42b7cbb3189e6
sha256sums = c6bb216055d3670d3100b7a74e04ce0644030f365f4349a09e630ef60fbcb9a4
sha256sums = 45bf7c462d7154360d0007a6d7c00c6aa6b49339b6f178cf24e5b1a40ca702d7
sha256sums = 0ea6e9a36d54a7b9de5b87e9182b40fad0a9f673ae2195c29f32bf4538fa2f76
sha256sums = 3a99d362a56fb52d5259549bf932df184e227fae79ed46be60f5b80e5d95c492
- sha256sums = 670e6a40bade4562fb93c7cb29191c1869c286acbb7f616c8b78f09842a82cbd
+ sha256sums = 297e0326240e7d61b9c9f5a8f8313ce18fde2a14af9ad1f8c1ec03b67729ab57
pkgname = idos-timetable-browser-latest
diff --git a/PKGBUILD b/PKGBUILD
index 34e221c41b95..8e81d8de59f6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,12 @@
# Maintainer: dreieck
-# PKGBUILD last time manually edited: At least on 2016-12-11.
+# PKGBUILD last time manually edited: At least on 2016-12-21.
_pkgname=idos-timetable-browser
pkgname="${_pkgname}-latest"
epoch=0
pkgver=1.27_lib2.8.0.1
-pkgrel=7
+pkgrel=8
pkgdesc="Offline railway and other public transport timetable search engine by CHAPS. (Czech language by default.)"
arch=('i686' 'x86_64')
url="http://chaps.cz/eng/download/idos/zip#kotvaprg"
@@ -56,13 +56,13 @@ source=(
sha256sums=(
"SKIP"
- "969d4418181c9fed180e240c4a73fbfa57e126f77c1c4c6e9217d515a1e6913f"
+ "013fa1d41b6c13fd079c16578390d5b75ad3f1228fd38a7ac17756bd74ace94e"
"e904d167ccdcfb2743f4cfd596aaa9dce8b751fb5c8315b972b42b7cbb3189e6"
"c6bb216055d3670d3100b7a74e04ce0644030f365f4349a09e630ef60fbcb9a4"
"45bf7c462d7154360d0007a6d7c00c6aa6b49339b6f178cf24e5b1a40ca702d7"
"0ea6e9a36d54a7b9de5b87e9182b40fad0a9f673ae2195c29f32bf4538fa2f76"
"3a99d362a56fb52d5259549bf932df184e227fae79ed46be60f5b80e5d95c492"
- "670e6a40bade4562fb93c7cb29191c1869c286acbb7f616c8b78f09842a82cbd"
+ "297e0326240e7d61b9c9f5a8f8313ce18fde2a14af9ad1f8c1ec03b67729ab57"
)
diff --git a/idos-timetable-browser.install b/idos-timetable-browser.install
index 0549175405bc..8655c693512d 100644
--- a/idos-timetable-browser.install
+++ b/idos-timetable-browser.install
@@ -1,12 +1,16 @@
post_install() {
if locale -a | grep -Eq '^cs_CZ'; then
- echo "====> A Czech locale (cs_CZ*) seems to be present. Fine. please keep it in order"
- echo "<==== to keep diacritical characters displaying correctly."
+ echo "====>"
+ echo " A Czech locale (cs_CZ*) seems to be present. Fine. please keep it in order"
+ echo " to keep diacritical characters displaying correctly."
+ echo "<===="
else
- echo "====> It is recommended to generate the locale cs_CZ.ISO.UTF-8 or cs_CZ.ISO-8859-2"
- echo " in order to display diacritical characters correctly."
- echo " In order to do so, edit /etc/locale.gen, if present /etc/locale.nopurge, and"
- echo "<==== then run locale-gen."
+ echo "====>"
+ echo " It is recommended to generate the locale cs_CZ.ISO.UTF-8 or cs_CZ.ISO-8859-2"
+ echo " in order to display diacritical characters correctly."
+ echo " In order to do so, edit /etc/locale.gen, if present /etc/locale.nopurge, and"
+ echo " then run locale-gen."
+ echo "<===="
fi
}
diff --git a/idos-timetable-browser.sh b/idos-timetable-browser.sh
index f68b0a1d7678..fb9be01d72e8 100755
--- a/idos-timetable-browser.sh
+++ b/idos-timetable-browser.sh
@@ -36,7 +36,7 @@ fi
debug() {
case "${DEBUG}" in
"1"|[yY][eE][sS]|[tT][rR][uU][eE])
- echo "$@" > /dev/stderr
+ echo "DEBUG info: $@" > /dev/stderr
;;
esac
}
@@ -150,8 +150,8 @@ fi
cd "${_installdir}"
-debug 'DEBUG: $LC_CTYPE is set to: '"'${LC_CTYPE}' (if it does not begin with 'cs_CZ', try to enable Czech locale on your system to display diacritical characters correctly)."
-debug "DEBUG: We are running from the directory: '$(pwd)'."
-debug "DEBUG: Executing the following command: 'wine ${_executable} ${argsnew[@]}'."
+debug '$LC_CTYPE is set to: '"'${LC_CTYPE}' (if it does not begin with 'cs_CZ', try to enable Czech locale on your system to display diacritical characters correctly)."
+debug "We are running from the directory: '$(pwd)'."
+debug "Executing the following command: 'wine ${_executable} ${argsnew[@]}'."
wine "${_executable}" "${argsnew[@]}"