summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD24
-rw-r--r--archlinux.patch19
-rwxr-xr-xidsk.install29
4 files changed, 41 insertions, 47 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 98a07a4d19c8..b16222b715c4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,14 @@
pkgbase = idsk
pkgdesc = A tool for managing Amstrad CPC DSK images
- pkgver = 0.13
- pkgrel = 3
- url = http://koaks.amstrad.free.fr/amstrad/projets/
- install = idsk.install
+ pkgver = 0.20
+ pkgrel = 1
+ url = https://github.com/cpcsdk/idsk
arch = i686
arch = x86_64
- license = unknown
- source = http://sid.cpc.free.fr/iDSK.0.13-src.tgz
- md5sums = b221623d3039e09b15c5a071caf343b8
+ license = MIT
+ source = https://github.com/cpcsdk/idsk/archive/refs/tags/v0.20.tar.gz
+ source = archlinux.patch
+ md5sums = 5447c6e4460fe19176709c647961c7d3
+ md5sums = 51d54db326d89919acb7d456969d2499
pkgname = idsk
-
diff --git a/PKGBUILD b/PKGBUILD
index efa44f9d635d..6f8c877e7ff4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,29 @@
# Maintainer: Martin C. Doege <mdoege at compuserve dot com>
pkgname=idsk
-pkgver=0.13
-pkgrel=3
+pkgver=0.20
+pkgrel=1
pkgdesc="A tool for managing Amstrad CPC DSK images"
arch=('i686' 'x86_64')
-url="http://koaks.amstrad.free.fr/amstrad/projets/"
-license=('unknown')
+url="https://github.com/cpcsdk/idsk"
+license=('MIT')
depends=()
-install=$pkgname.install
-source=("http://sid.cpc.free.fr/iDSK."$pkgver"-src.tgz")
-md5sums=('b221623d3039e09b15c5a071caf343b8')
+source=("https://github.com/cpcsdk/idsk/archive/refs/tags/v"$pkgver".tar.gz"
+"archlinux.patch")
+md5sums=('5447c6e4460fe19176709c647961c7d3'
+'51d54db326d89919acb7d456969d2499')
build() {
- cd "$srcdir/iDSK."$pkgver"/iDSK"
- ./configure --prefix=/usr
+ cd "$srcdir/idsk-"$pkgver
+ patch -p1 < ../archlinux.patch
+ mkdir -p build
+ cd build
+ cmake ..
make || return 1
}
package() {
- cd "$srcdir/iDSK."$pkgver"/iDSK"
+ cd "$srcdir/idsk-"$pkgver"/build"
make DESTDIR="$pkgdir" install
}
diff --git a/archlinux.patch b/archlinux.patch
new file mode 100644
index 000000000000..bdd08523f832
--- /dev/null
+++ b/archlinux.patch
@@ -0,0 +1,19 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 9e8319e..f41236e 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -1,5 +1,8 @@
+ PROJECT(iDSK)
+
++set(CMAKE_CXX_FLAGS "-std=c++14")
++set(CMAKE_INSTALL_PREFIX "/usr/")
++
+ add_executable(iDSK
+ src/Basic.cpp
+ src/BitmapCPC.cpp
+@@ -13,3 +16,5 @@ add_executable(iDSK
+ src/ViewFile.cpp
+ src/Ascii.cpp
+ )
++
++install(TARGETS iDSK DESTINATION ${CMAKE_INSTALL_BINDIR})
diff --git a/idsk.install b/idsk.install
deleted file mode 100755
index 9bbea234883d..000000000000
--- a/idsk.install
+++ /dev/null
@@ -1,29 +0,0 @@
-post_install() {
- cat << EOF
-==========================================================
-English help text (help text in the program is in French):
-==========================================================
-
-Usage :
- iDSK <DSKfile> [OPTIONS] [files to process]
-OPTIONS : EXAMPLE
--l : List disk catalog iDSK floppy.dsk -l
--g : export ('Get') file iDSK floppy.dsk -g myprog.bas
--r : Remove file iDSK floppy.dsk -r myprog.bas
--n : create New dsk file iDSK floppy2.dsk -n
--z : disassemble a binary file iDSK floppy.dsk -z myprog.bin
--b : list a Basic file iDSK floppy.dsk -b myprog.bas
--d : list a Dams file iDSK floppy.dsk -d myprog.dms
--h : list a binary file as Hexadecimal iDSK floppy.dsk -h myprog.bin
--i : Import file iDSK floppy.dsk -i myprog.bas
- -t : fileType (0=ASCII/1=BINARY) ... -t 1
- -e : hex Execute address of file ... -e C000 -t 1
- -c : hex loading address of file ... -e C000 -c 4000 -t 1
- -f : Force overwriting if file exists ... -f
- -o : insert a read-Only file ... -o
- -s : insert a System file ... -s
- -u : insert file with User number ... -u 3
---------------------------------------------------------------------------------
-Please report bugs ! - Demoniak/Sid/PulkoMandy
-EOF
-}