summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD30
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d7737fce3a17
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = ifrextractor-ls
+ pkgdesc = Utility that can extract the internal forms represenation from both EFI and UEFI modules
+ pkgver = 0.1
+ pkgrel = 1
+ url = https://github.com/LongSoft/Universal-IFR-Extractor
+ arch = any
+ license = GPL3
+ makedepends = cmake
+ makedepends = git
+ provides = ifrextractor
+ conflicts = ifrextractor
+ source = ifrextractor-ls::git+https://github.com/LongSoft/Universal-IFR-Extractor.git#commit=4f9699de9388e29cd31954563b0cf817f8af9f64
+ md5sums = SKIP
+
+pkgname = ifrextractor-ls
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a706a87fdd38
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: xsmile <sascha_r gmx de>
+pkgname=ifrextractor-ls
+pkgver=0.1
+pkgrel=1
+pkgdesc='Utility that can extract the internal forms represenation from both EFI and UEFI modules'
+arch=('any')
+url='https://github.com/LongSoft/Universal-IFR-Extractor'
+license=('GPL3')
+makedepends=('cmake' 'git')
+provides=('ifrextractor')
+conflicts=('ifrextractor')
+source=("${pkgname}::git+${url}.git#commit=4f9699de9388e29cd31954563b0cf817f8af9f64")
+md5sums=('SKIP')
+
+prepare() {
+ cd $pkgname
+ mkdir -p build
+ cd build
+ cmake ..
+}
+
+build() {
+ cd $pkgname/build
+ make
+}
+
+package() {
+ cd $pkgname/build
+ install -Dm755 ifrextract -t "$pkgdir"/usr/bin
+}