summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD22
2 files changed, 18 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b2fff3dd04ba..9cb0b166a341 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ifuse-git
pkgdesc = A fuse filesystem to access the contents of an iPhone or iPod Touch
- pkgver = 1.1.4.r1.g38c9f45
- pkgrel = 1
+ pkgver = 1.1.4.r5.g814a0e3
+ pkgrel = 2
epoch = 2
url = http://libimobiledevice.org/
arch = i686
@@ -11,10 +11,9 @@ pkgbase = ifuse-git
depends = libimobiledevice-git
depends = libplist-git
depends = fuse
- provides = ifuse
+ provides = ifuse=1.1.4.r5.g814a0e3
conflicts = ifuse
source = git+https://github.com/libimobiledevice/ifuse
md5sums = SKIP
pkgname = ifuse-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 7cda7353668b..e0459800da02 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,34 +3,42 @@
pkgname=ifuse-git
epoch=2
-pkgver=1.1.4.r1.g38c9f45
-pkgrel=1
+pkgver=1.1.4.r5.g814a0e3
+pkgrel=2
pkgdesc='A fuse filesystem to access the contents of an iPhone or iPod Touch'
url='http://libimobiledevice.org/'
arch=('i686' 'x86_64')
license=('LGPL2.1')
depends=('libimobiledevice-git' 'libplist-git' 'fuse')
makedepends=('git')
-provides=('ifuse')
+provides=("ifuse=$pkgver")
conflicts=('ifuse')
source=("git+https://github.com/libimobiledevice/ifuse")
md5sums=('SKIP')
pkgver() {
cd ifuse
+ git describe --long --tags | sed 's/[^-]*-g/r&/;s/-/./g'
+}
- git describe --long --tags | sed 's/-/.r/;s/-/./'
+prepare() {
+ cd ifuse
+ NOCONFIGURE=1 ./autogen.sh
}
build() {
cd ifuse
-
- ./autogen.sh --prefix=/usr
+ ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var
+ #sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool # not needed anymore (libtool honors $LDFLAGS now)
make
}
-package() {
+check() {
cd ifuse
+ make check
+}
+package() {
+ cd ifuse
make DESTDIR="${pkgdir}" install
}