summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD9
2 files changed, 9 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6a87dbd1fa83..2e98c00047ad 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ihaskell-git
pkgdesc = A Haskell backend kernel for the IPython project
- pkgver = 2129.e0c1a8d
- pkgrel = 2
+ pkgver = 2140.14059d9
+ pkgrel = 1
url = https://github.com/gibiansky/IHaskell
arch = x86_64
license = MIT
diff --git a/PKGBUILD b/PKGBUILD
index 2ad3bc5833c6..626524f0d7fc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Andrea Manenti <andrea [dot] manenti [at] yahoo [dot] com>
pkgname=ihaskell-git
-pkgver=2129.e0c1a8d
-pkgrel=2
+pkgver=2140.14059d9
+pkgrel=1
pkgdesc="A Haskell backend kernel for the IPython project"
arch=('x86_64')
url="https://github.com/gibiansky/IHaskell"
@@ -17,6 +17,11 @@ conflicts=()
source=("git+https://github.com/gibiansky/IHaskell")
sha256sums=('SKIP')
+pkgver() {
+ cd "$srcdir"/IHaskell
+ echo `git rev-list --count master`.`git rev-parse --short master`
+}
+
build() {
cd IHaskell