summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD26
-rw-r--r--iicalc.install12
3 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..dc6f76a261be
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = iicalc
+ pkgdesc = An extensible calculator written in Python.
+ pkgver = 2.4.5
+ pkgrel = 1
+ install = iicalc.install
+ arch = any
+ groups =
+ license = APLG-3.0
+ depends = bash-completion
+ depends = python-pip
+ options = !strip
+ options = !emptydirs
+ source = iicalc-2.4.5.deb::https://gitlab.com/TurboWafflz/ImaginaryInfinity-Calculator/-/jobs/artifacts/development/raw/iicalc.deb?job=debian%20packager
+ sha512sums = 3b73eaa941553f53c75057c440f8e4872a1ee21b405604fb6a3a34b1497c37093e5fde243df26dea85bce3440147dc2e2516b01f0ce9e4fc3971007a10a9582f
+
+pkgname = iicalc
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0deed42268af
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Generated by debtap
+# Maintainer: tabulatejarl8@gmail.com <TabulateJarl8>
+# Maintainer: TurboWafflz <turbowafflz@gmail.com>
+# Contributor:
+pkgname=iicalc
+pkgver=2.4.5
+pkgrel=1
+pkgdesc="An extensible calculator written in Python."
+arch=('any')
+url=""
+license=('APLG-3.0')
+groups=('')
+depends=('bash-completion' 'python-pip')
+options=('!strip' '!emptydirs')
+install=${pkgname}.install
+source=("iicalc-$pkgver.deb::https://gitlab.com/TurboWafflz/ImaginaryInfinity-Calculator/-/jobs/artifacts/development/raw/iicalc.deb?job=debian%20packager")
+sha512sums=('3b73eaa941553f53c75057c440f8e4872a1ee21b405604fb6a3a34b1497c37093e5fde243df26dea85bce3440147dc2e2516b01f0ce9e4fc3971007a10a9582f')
+
+package(){
+
+ # Extract package data
+ ar vx iicalc-$pkgver.deb
+ tar xf data.tar.xz -C "${pkgdir}"
+ rm debian-binary control.tar.xz data.tar.xz
+
+}
diff --git a/iicalc.install b/iicalc.install
new file mode 100644
index 000000000000..b10006040bac
--- /dev/null
+++ b/iicalc.install
@@ -0,0 +1,12 @@
+post_install() {
+ chmod +x /usr/bin/iicalc
+ pip3 install -r /usr/share/iicalc/requirements.txt
+}
+
+post_upgrade() {
+ post_install
+}
+
+pre_remove() {
+ echo -e "\033[38;5;11mWarning: Removing ImaginaryInfinity Calculator does not remove the .iicalc folder in your home directory. If you want to run the portable version of ImaginaryInfinity Calculator again, you will have to delete it.\033[m"
+}