summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD8
2 files changed, 5 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4c6fab4d0f7d..a20292d7c8fc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -27,7 +27,7 @@ pkgbase = image_optim-git
provides = image_optim=v0.25.0.r0.g4334309
conflicts = image_optim
options = !emptydirs
- source = image_optim-git::git+https://github.com/toy/image_optim.git
+ source = image_optim::git+https://github.com/toy/image_optim.git
md5sums = SKIP
pkgname = image_optim-git
diff --git a/PKGBUILD b/PKGBUILD
index 79651f5a892f..ab04792b50f8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -30,21 +30,21 @@ makedepends=('git' 'ruby')
provides=(${_pkgname}=$pkgver)
conflicts=(${_pkgname})
options=('!emptydirs')
-source=("$pkgname::git+https://github.com/toy/image_optim.git")
+source=("${_pkgname}::git+https://github.com/toy/image_optim.git")
md5sums=("SKIP")
pkgver() {
- cd "$pkgname"
+ cd "${_pkgname}"
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
- cd "$pkgname"
+ cd "${_pkgname}"
gem build $_pkgname.gemspec
}
package() {
- cd "$pkgname"
+ cd "${_pkgname}"
local _gemdir="$(ruby -e 'puts Gem.default_dir')"
gem install --no-user-install --ignore-dependencies \
-i "${pkgdir}${_gemdir}" \