summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD13
-rw-r--r--imagemagick-inkscape-1.0.patch13
3 files changed, 30 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 83ab6b7400be..81d9b6b7247c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = imagemagick-full
pkgdesc = An image viewing/manipulation program (Q32 HDRI with all features)
- pkgver = 7.0.10.10
+ pkgver = 7.0.10.11
pkgrel = 1
url = https://www.imagemagick.org/
arch = x86_64
@@ -57,10 +57,12 @@ pkgbase = imagemagick-full
makedepends = libfpx
makedepends = libumem-git
makedepends = brunsli
- source = git+https://github.com/ImageMagick/ImageMagick.git#commit=0c8d393a2f3f7605dab38d382c21052b87ed3576
+ source = git+https://github.com/ImageMagick/ImageMagick.git#commit=5f07d65ddcb06b3a8a63d734a822ef5c1d93b30b
source = arch-fonts.diff
+ source = imagemagick-inkscape-1.0.patch
sha256sums = SKIP
sha256sums = a85b744c61b1b563743ecb7c7adad999d7ed9a8af816650e3ab9321b2b102e73
+ sha256sums = dd856b0d7b5b98535d2bc61dfa995f4162677486c1eac14b384668a28a60af30
pkgname = imagemagick-full
depends = lcms2
@@ -106,9 +108,9 @@ pkgname = imagemagick-full
depends = libumem-git
depends = brunsli
optdepends = imagemagick-full-doc: manual and API docs
- provides = imagemagick=7.0.10.10
- provides = libmagick=7.0.10.10
- provides = libmagick-full=7.0.10.10
+ provides = imagemagick=7.0.10.11
+ provides = libmagick=7.0.10.11
+ provides = libmagick-full=7.0.10.11
conflicts = imagemagick
conflicts = libmagick
replaces = libmagick-full
@@ -128,6 +130,6 @@ pkgname = imagemagick-full
pkgname = imagemagick-full-doc
pkgdesc = An image viewing/manipulation program (Q32 HDRI with all features) (manual and API docs)
arch = any
- provides = imagemagick-doc=7.0.10.10
+ provides = imagemagick-doc=7.0.10.11
conflicts = imagemagick-doc
diff --git a/PKGBUILD b/PKGBUILD
index 062bf6f7e83d..446f93c8b9cc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -14,13 +14,13 @@
# - deJaVu and GhostScript font directories are the default ones
# - Windows font directory is set according to a Wiki example
-_commit='0c8d393a2f3f7605dab38d382c21052b87ed3576'
+_commit='5f07d65ddcb06b3a8a63d734a822ef5c1d93b30b'
_qdepth='32'
pkgbase=imagemagick-full
pkgname=('imagemagick-full' 'imagemagick-full-doc')
_srcname=ImageMagick
-pkgver=7.0.10.10
+pkgver=7.0.10.11
pkgrel=1
arch=('x86_64')
pkgdesc="An image viewing/manipulation program (Q${_qdepth} HDRI with all features)"
@@ -40,9 +40,11 @@ makedepends=(
'brunsli'
)
source=("git+https://github.com/ImageMagick/ImageMagick.git#commit=${_commit}"
- 'arch-fonts.diff')
+ 'arch-fonts.diff'
+ 'imagemagick-inkscape-1.0.patch')
sha256sums=('SKIP'
- 'a85b744c61b1b563743ecb7c7adad999d7ed9a8af816650e3ab9321b2b102e73')
+ 'a85b744c61b1b563743ecb7c7adad999d7ed9a8af816650e3ab9321b2b102e73'
+ 'dd856b0d7b5b98535d2bc61dfa995f4162677486c1eac14b384668a28a60af30')
prepare() {
cd "$_srcname"
@@ -52,6 +54,9 @@ prepare() {
# fix up typemaps to match Arch Linux packages, where possible
patch -Np1 -i "${srcdir}/arch-fonts.diff"
+ # use correct parameter for inkscape 1.0
+ patch -Np1 -i "${srcdir}/imagemagick-inkscape-1.0.patch"
+
# fix for 'sh: gitversion.sh: command not found' during autoreconf
sed -i 's|(gitversion|(./gitversion|' configure.ac
diff --git a/imagemagick-inkscape-1.0.patch b/imagemagick-inkscape-1.0.patch
new file mode 100644
index 000000000000..02bbc9e77830
--- /dev/null
+++ b/imagemagick-inkscape-1.0.patch
@@ -0,0 +1,13 @@
+diff --git a/config/delegates.xml.in b/config/delegates.xml.in
+index 442fa1aca..19baaee91 100644
+--- a/config/delegates.xml.in
++++ b/config/delegates.xml.in
+@@ -111,7 +111,7 @@
+ <delegate decode="sid" command="&quot;@MrSIDDecodeDelegate@&quot; -if sid -i &quot;%i&quot; -of tif -o &quot;%o&quot; &gt; &quot;%u&quot;"/>
+ <delegate decode="svg" command="&quot;@RSVGDecodeDelegate@&quot; -o &quot;%o&quot; &quot;%i&quot;"/>
+ <!-- Change export-file to export-png for inkscape < 1.0 -->
+- <delegate decode="svg:decode" stealth="True" command="&quot;@SVGDecodeDelegate@&quot; &quot;%s&quot; --export-file=&quot;%s&quot; --export-dpi=&quot;%s&quot; --export-background=&quot;%s&quot; --export-background-opacity=&quot;%s&quot; &gt; &quot;%s&quot; 2&gt;&amp;1"/>
++ <delegate decode="svg:decode" stealth="True" command="&quot;@SVGDecodeDelegate@&quot; &quot;%s&quot; --export-filename=&quot;%s&quot; --export-dpi=&quot;%s&quot; --export-background=&quot;%s&quot; --export-background-opacity=&quot;%s&quot; &gt; &quot;%s&quot; 2&gt;&amp;1"/>
+ <delegate decode="tiff" encode="launch" mode="encode" command="&quot;@LaunchDelegate@&quot; &quot;%i&quot;"/>
+ <delegate decode="wdp" command="@MVDelegate@ &quot;%i&quot; &quot;%i.jxr&quot;; &quot;@JXRDecodeDelegate@&quot; -i &quot;%i.jxr&quot; -o &quot;%o.bmp&quot;; @MVDelegate@ &quot;%i.jxr&quot; &quot;%i&quot;; @MVDelegate@ &quot;%o.bmp&quot; &quot;%o&quot;"/>
+ <delegate decode="webp" command="&quot;@WebPDecodeDelegate@&quot; -pam &quot;%i&quot; -o &quot;%o&quot;"/>