summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rwxr-xr-xPKGBUILD12
-rw-r--r--imagemagick-7.0.2.8-opencl-compile-fix.patch30
3 files changed, 6 insertions, 46 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b99bf6f645a5..1051a5fc98af 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Sun Aug 14 20:46:24 UTC 2016
+# Mon Aug 15 00:53:33 UTC 2016
pkgbase = imagemagick-full
pkgdesc = An image viewing/manipulation program (Q32 HDRI with all libs and features)
- pkgver = 7.0.2.8
+ pkgver = 7.0.2.9
pkgrel = 1
url = http://www.imagemagick.org/
arch = i686
@@ -71,10 +71,8 @@ pkgbase = imagemagick-full
backup = etc/ImageMagick-7/type-dejavu.xml
backup = etc/ImageMagick-7/type-ghostscript.xml
backup = etc/ImageMagick-7/type-windows.xml
- source = http://www.imagemagick.org/download/ImageMagick-7.0.2-8.tar.xz
- source = imagemagick-7.0.2.8-opencl-compile-fix.patch
- sha256sums = 60a2e6811a70612217b2a66a345c6073c6e220a481ce2f5db43fccc5232eb668
- sha256sums = 82e04d016cd9154f7d6edc4a2cb6dad9b226e9cd44116bb48723da3cb2c5fe9b
+ source = http://www.imagemagick.org/download/ImageMagick-7.0.2-9.tar.xz
+ sha256sums = 22df4f197985f36f77b7b0d44de92ff44415885045f0191b3319540bdc82ff53
pkgname = imagemagick-full
diff --git a/PKGBUILD b/PKGBUILD
index 0f4ea60fe987..ef6ddbae829e 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -56,16 +56,8 @@ backup=("etc/ImageMagick-${pkgver%%.*}/coder.xml"
"etc/ImageMagick-${pkgver%%.*}/type-ghostscript.xml"
"etc/ImageMagick-${pkgver%%.*}/type-windows.xml")
options=('!docs' 'libtool' '!emptydirs')
-source=("http://www.imagemagick.org/download/${_srcname}-${_srcver}.tar.xz"
- 'imagemagick-7.0.2.8-opencl-compile-fix.patch'
-)
-sha256sums=('60a2e6811a70612217b2a66a345c6073c6e220a481ce2f5db43fccc5232eb668'
- '82e04d016cd9154f7d6edc4a2cb6dad9b226e9cd44116bb48723da3cb2c5fe9b')
-
-prepare() {
- cd "$_srcname"-"$_srcver"
- patch -p1 -i ../imagemagick-7.0.2.8-opencl-compile-fix.patch
-}
+source=("http://www.imagemagick.org/download/${_srcname}-${_srcver}.tar.xz")
+sha256sums=("$(curl -s ${_digest} | grep -A5 "${_srcname}-${_srcverregex}\.tar\.xz" | grep 'sha256' | grep -oE '>[[:alnum:]]*?<' | sed 's/[><]//g')")
build() {
cd "$_srcname"-"$_srcver"
diff --git a/imagemagick-7.0.2.8-opencl-compile-fix.patch b/imagemagick-7.0.2.8-opencl-compile-fix.patch
deleted file mode 100644
index 5ccc52de780e..000000000000
--- a/imagemagick-7.0.2.8-opencl-compile-fix.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-diff --git a/MagickCore/opencl.c b/MagickCore/opencl.c
-index 6f16996..b8656a2 100644
---- a/MagickCore/opencl.c
-+++ b/MagickCore/opencl.c
-@@ -725,16 +725,12 @@ static void LoadOpenCLDeviceBenchmark(MagickCLEnv clEnv,const char *xml)
- MagickCLDeviceBenchmark
- *device_benchmark;
-
-- MagickStatusType
-- status;
--
- size_t
- i,
- extent;
-
- if (xml == (char *) NULL)
- return;
-- status=MagickTrue;
- device_benchmark=(MagickCLDeviceBenchmark *) NULL;
- token=AcquireString(xml);
- extent=strlen(token)+MagickPathExtent;
-@@ -919,7 +915,7 @@ static MagickBooleanType LoadOpenCLBenchmarks(MagickCLEnv clEnv,
- return(MagickFalse);
- }
-
-- option=ConfigureFileToStringInfo(filename,exception);
-+ option=ConfigureFileToStringInfo(filename);
- LoadOpenCLDeviceBenchmark(clEnv,(const char *) GetStringInfoDatum(option));
- option=DestroyStringInfo(option);
- return(MagickTrue);