summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD8
2 files changed, 12 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 562d8feb1155..2712c286819e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = imagemagick-full
pkgdesc = An image viewing/manipulation program (Q32 HDRI with all possible features)
- pkgver = 7.1.0.62
+ pkgver = 7.1.1.0
pkgrel = 1
url = https://www.imagemagick.org/
arch = x86_64
@@ -55,11 +55,11 @@ pkgbase = imagemagick-full
makedepends = flif
makedepends = libfpx
makedepends = libumem-git
- source = https://imagemagick.org/archive/releases/ImageMagick-7.1.0-62.tar.xz
- source = https://imagemagick.org/archive/releases/ImageMagick-7.1.0-62.tar.xz.asc
+ source = https://imagemagick.org/archive/releases/ImageMagick-7.1.1-0.tar.xz
+ source = https://imagemagick.org/archive/releases/ImageMagick-7.1.1-0.tar.xz.asc
source = arch-fonts.diff
validpgpkeys = D8272EF51DA223E4D05B466989AB63D48277377A
- sha256sums = 8b89c1a023d4b03cca3e63a0f3cb944427d46d1363a20440282d9f6e0e343518
+ sha256sums = 155a0fffafa1f7079ff9d017598da736a22ebb54e931447283874cf20a4fa331
sha256sums = SKIP
sha256sums = 290c6a87845b419459fb552c0e7dcd81fbeafcecc370818d442fedf4d315b7fb
@@ -105,9 +105,9 @@ pkgname = imagemagick-full
depends = libfpx
depends = libumem-git
optdepends = imagemagick-full-doc: manual and API docs
- provides = imagemagick=7.1.0.62
- provides = libmagick=7.1.0.62
- provides = libmagick-full=7.1.0.62
+ provides = imagemagick=7.1.1.0
+ provides = libmagick=7.1.1.0
+ provides = libmagick-full=7.1.1.0
conflicts = imagemagick
conflicts = libmagick
replaces = libmagick-full
@@ -125,10 +125,9 @@ pkgname = imagemagick-full
backup = etc/ImageMagick-7/type-ghostscript.xml
backup = etc/ImageMagick-7/type-urw-base35.xml
backup = etc/ImageMagick-7/type-windows.xml
- backup = etc/ImageMagick-7/type-.xml
pkgname = imagemagick-full-doc
pkgdesc = An image viewing/manipulation program (Q32 HDRI with all possible features) (manual and API docs)
arch = any
- provides = imagemagick-doc=7.1.0.62
+ provides = imagemagick-doc=7.1.1.0
conflicts = imagemagick-doc
diff --git a/PKGBUILD b/PKGBUILD
index bd4c19703951..f33d26f86360 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,7 +13,7 @@
pkgbase=imagemagick-full
pkgname=('imagemagick-full' 'imagemagick-full-doc')
-pkgver=7.1.0.62
+pkgver=7.1.1.0
pkgrel=1
arch=('x86_64')
_qdepth='32'
@@ -34,7 +34,7 @@ makedepends=(
)
source=("https://imagemagick.org/archive/releases/ImageMagick-${pkgver%.*}-${pkgver##*.}.tar.xz"{,.asc}
'arch-fonts.diff')
-sha256sums=('8b89c1a023d4b03cca3e63a0f3cb944427d46d1363a20440282d9f6e0e343518'
+sha256sums=('155a0fffafa1f7079ff9d017598da736a22ebb54e931447283874cf20a4fa331'
'SKIP'
'290c6a87845b419459fb552c0e7dcd81fbeafcecc370818d442fedf4d315b7fb')
validpgpkeys=('D8272EF51DA223E4D05B466989AB63D48277377A') # Lexie Parsimoniae
@@ -131,7 +131,7 @@ package_imagemagick-full() {
'dmalloc' 'flif' 'libfpx' 'libumem-git'
)
optdepends=('imagemagick-full-doc: manual and API docs')
- backup=("etc/ImageMagick-${pkgver%%.*}"/{colors,delegates,log,mime,policy,quantization-table,thresholds,type-{apple,dejavu,ghostscript,urw-base35,windows,}}.xml)
+ backup=("etc/ImageMagick-${pkgver%%.*}"/{colors,delegates,log,mime,policy,quantization-table,thresholds,type-{apple,dejavu,ghostscript,urw-base35,windows}}.xml)
options=('!emptydirs' 'libtool')
provides=("imagemagick=${pkgver}" "libmagick=${pkgver}" "libmagick-full=${pkgver}")
conflicts=('imagemagick' 'libmagick')
@@ -139,7 +139,7 @@ package_imagemagick-full() {
make -C "ImageMagick-${pkgver%.*}-${pkgver##*.}" DESTDIR="$pkgdir" install
find "${pkgdir}/usr/lib/perl5" -name '*.so' -exec chrpath -d {} +
- rm "$pkgdir"/usr/lib/*.la
+ rm "${pkgdir}/usr/lib"/*.la
mv "${pkgdir}/usr/share/doc" .
install -D -m644 "ImageMagick-${pkgver%.*}-${pkgver##*.}"/{LICENSE,NOTICE} -t "${pkgdir}/usr/share/licenses/${pkgname}"
}