summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD20
2 files changed, 35 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e2f6bce25b52
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = imeditor
+ pkgdesc = Simple & versatile image editor.
+ pkgver = 0.1
+ pkgrel = 1
+ url = https://github.com/ImEditor/ImEditor
+ arch = any
+ license = GPL
+ depends = python,
+ depends = gtk3,
+ depends = python-pillow
+ source = git+https://github.com/ImEditor/ImEditor.git
+ md5sums = e1ccff9137139d8f347c9f544af9afe7
+
+pkgname = imeditor
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0857e663834e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: Hugo Posnic <hugo.posnic@gmail.com>
+# Author: Hugo Posnic <hugo.posnic@gmail.com>
+# Author: Nathan Seva <nathan.seva@outlook.fr>
+pkgname=imeditor
+pkgver=0.1
+pkgrel=1
+pkgdesc="Simple & versatile image editor."
+arch=("any")
+url="https://github.com/ImEditor/ImEditor"
+license=('GPL')
+depends=('python', 'gtk3', 'python-pillow')
+source=("git+https://github.com/ImEditor/ImEditor.git")
+md5sums=("e1ccff9137139d8f347c9f544af9afe7")
+
+package() {
+ cd ${srcdir}/ImEditor-$pkgver
+ install -dm755 ${pkgdir}/usr/share/${pkgname}
+ cp -R imeditor/* ${pkgdir}/usr/share/${pkgname}
+ install -D -m644 ${pkgname}.desktop ${pkgdir}/usr/share/applications/${pkgname}.desktop
+}