summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD16
2 files changed, 9 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d1bc47e00b54..f0ec2563434e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,6 @@
-# Generated by mksrcinfo v8
-# Fri Mar 24 17:59:35 UTC 2017
pkgbase = imgp-git
pkgdesc = Resize or rotate JPEG and PNG images.
- pkgver = 141.ac30556
+ pkgver = r262.9d570e3
pkgrel = 1
url = https://github.com/jarun/imgp
arch = any
@@ -16,4 +14,3 @@ pkgbase = imgp-git
sha256sums = SKIP
pkgname = imgp-git
-
diff --git a/PKGBUILD b/PKGBUILD
index f6fbd914e43e..f3b93bf8f844 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,26 @@
-# Maintainer: zach <zach {at} zach-adams {dot} com>
+# Maintainer: Frederic Bezies < fredbezies at gmail dot com >
+# Contributor: zach <zach {at} zach-adams {dot} com>
pkgname=imgp-git
_pkgname=imgp
-_pkgauthor=jarun
-pkgver=141.ac30556
+pkgver=r262.9d570e3
pkgrel=1
pkgdesc="Resize or rotate JPEG and PNG images."
arch=('any')
-url="https://github.com/${_pkgauthor}/${_pkgname}"
+url="https://github.com/jarun/${_pkgname}"
license=('GPL3')
depends=('python3' 'python-pillow')
makedepends=('git')
-source=(${_pkgname}::"git+https://github.com/${_pkgauthor}/${_pkgname}.git")
+source=(${_pkgname}::"git+https://github.com/jarun/${_pkgname}.git")
sha256sums=('SKIP')
conflicts=('imgp')
provides=('imgp')
pkgver() {
- cd "${srcdir}/${_pkgname}"
- echo "$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
+ cd "$_pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
package() {
- make -C "${srcdir}/${_pkgname}" DESTDIR="${pkgdir}" PREFIX="/usr" install
+ make -C "${srcdir}/${_pkgname}" DESTDIR="${pkgdir}" PREFIX="/usr" install
}