aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD26
-rw-r--r--README.md20
4 files changed, 66 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..40cafc0bcb4d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = imgproxy
+ pkgdesc = Fast and secure standalone server for resizing and converting remote images
+ pkgver = 2.2.13
+ pkgrel = 1
+ url = https://github.com/imgproxy/imgproxy
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = go
+ makedepends = rsync
+ makedepends = vips
+ source = https://github.com/imgproxy/imgproxy/archive/v2.2.13.tar.gz
+ sha256sums = 3a8a4ff27a919ceea48d95a49f13f4a131fde551502f522c11054ce4d586f337
+
+pkgname = imgproxy
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..17ac5abc4ae3
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg/
+src/
+*.pkg.tar.xz
+*.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c60613798b72
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Andrey Novikov <envek@envek.name>
+
+pkgname=imgproxy
+pkgdesc="Fast and secure standalone server for resizing and converting remote images"
+pkgver=2.2.13
+pkgrel=1
+arch=('i686' 'x86_64')
+url="https://github.com/imgproxy/imgproxy"
+license=('MIT')
+makedepends=('go' 'rsync' 'vips')
+source=("https://github.com/imgproxy/imgproxy/archive/v${pkgver}.tar.gz")
+sha256sums=('3a8a4ff27a919ceea48d95a49f13f4a131fde551502f522c11054ce4d586f337')
+
+build() {
+ cd "$pkgname-$pkgver"
+ env CGO_LDFLAGS_ALLOW="-s|-w" go build \
+ -gcflags "all=-trimpath=${PWD}" \
+ -asmflags "all=-trimpath=${PWD}" \
+ -ldflags "-extldflags ${LDFLAGS}" \
+ .
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ install -Dm755 $pkgname "$pkgdir"/usr/bin/$pkgname
+} \ No newline at end of file
diff --git a/README.md b/README.md
new file mode 100644
index 000000000000..9d1a2a694cda
--- /dev/null
+++ b/README.md
@@ -0,0 +1,20 @@
+# imgproxy
+
+Fast and secure standalone server for resizing and converting remote images
+
+## Upgrading
+
+ 1. Change version and checksum in `PKGBUILD` according to git tag and source code archive checksum published in https://github.com/imgproxy/imgproxy/releases
+
+ 2. Update `.SRCINFO` file:
+
+ ```sh
+ makepkg --printsrcinfo > .SRCINFO
+ ```
+ 3. Build package
+
+ ```sh
+ makepkg
+ ```
+
+ 4. Commit and push changes