summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO5
-rw-r--r--0001-fix-main-Handle-different-LLVM-version.patch62
-rw-r--r--PKGBUILD17
3 files changed, 5 insertions, 79 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9346071d1c8a..3c74a3a5cc60 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = imhex
pkgdesc = A Hex Editor for Reverse Engineers, Programmers and people that value their eye sight when working at 3 AM
pkgver = 1.34.0
- pkgrel = 1
+ pkgrel = 2
url = https://imhex.werwolv.net
arch = x86_64
license = GPL-2.0-or-later
@@ -31,12 +31,9 @@ pkgbase = imhex
options = !strip
source = imhex-1.34.0.tar.gz::https://github.com/WerWolv/ImHex/releases/download/v1.34.0/Full.Sources.tar.gz
source = imhex-patterns-1.34.0.tar.gz::https://github.com/WerWolv/ImHex-Patterns/archive/refs/tags/ImHex-v1.34.0.tar.gz
- source = 0001-fix-main-Handle-different-LLVM-version.patch
sha256sums = 0918470bfa9603c423fb4708258d18195fbae582c585bcb822ceded141cf75f0
sha256sums = fa0d7862ecf4698e6b26fde1307b314f2ddc16d7e2c99e80d9b18c357e43bf06
- sha256sums = 10824e6dfd8fedbad13c32be0ec3f4db09c250db827d8781869875426ee8b451
b2sums = ef746a991eb72c10747450d869eea5a5acc275cdbb75ecbb4c0d5ea66de0b09fa4606f6e4989b5c80988c805028f03ec2ea374d6bf0ef143c7ef5fc61ee551d0
b2sums = d2601f344d51598a3e27da014617bed7e8cd5891bdbfc01a03aa6a337ca21d40bcd09d6de87c10971c49d6830672dbe8a6ec09c581ce329132ee495c0b131792
- b2sums = c9ac00ac69426f484ae2852c53bc2f9403859c4b38568b44c8c4a1c6258b33d7cf0429617aaf7cd5a356fd65a9647639f7f447451e493020439c259dae9e8dad
pkgname = imhex
diff --git a/0001-fix-main-Handle-different-LLVM-version.patch b/0001-fix-main-Handle-different-LLVM-version.patch
deleted file mode 100644
index 4eb9e2f65058..000000000000
--- a/0001-fix-main-Handle-different-LLVM-version.patch
+++ /dev/null
@@ -1,62 +0,0 @@
-From 78cb353dc49523f968d7f002ec0357aae8bde787 Mon Sep 17 00:00:00 2001
-From: KokaKiwi <kokakiwi+git@kokakiwi.net>
-Date: Sun, 31 Dec 2023 13:29:36 +0100
-Subject: [PATCH] fix(main): Handle different LLVM version
-
----
- main/gui/source/crash_handlers.cpp | 6 ++++++
- .../include/content/popups/popup_crash_recovered.hpp | 5 +++++
- 2 files changed, 11 insertions(+)
-
-diff --git a/main/gui/source/crash_handlers.cpp b/main/gui/source/crash_handlers.cpp
-index 4b013d9e..9dfdebdc 100644
---- a/main/gui/source/crash_handlers.cpp
-+++ b/main/gui/source/crash_handlers.cpp
-@@ -14,6 +14,8 @@
- #include <nlohmann/json.hpp>
-
- #include <stacktrace.hpp>
-+
-+#include <llvm/Config/llvm-config.h>
- #include <llvm/Demangle/Demangle.h>
-
- #include <csignal>
-@@ -142,7 +144,11 @@ namespace hex::crash {
- try {
- std::rethrow_exception(std::current_exception());
- } catch (std::exception &ex) {
-+#if LLVM_VERSION_MAJOR >= 17
- std::string exceptionStr = hex::format("{}()::what() -> {}", llvm::itaniumDemangle(typeid(ex).name()), ex.what());
-+#else
-+ std::string exceptionStr = hex::format("{}()::what() -> {}", llvm::itaniumDemangle(typeid(ex).name(), nullptr, nullptr, nullptr), ex.what());
-+#endif
-
- handleCrash(exceptionStr);
- log::fatal("Program terminated with uncaught exception: {}", exceptionStr);
-diff --git a/plugins/builtin/include/content/popups/popup_crash_recovered.hpp b/plugins/builtin/include/content/popups/popup_crash_recovered.hpp
-index 962f57a0..7e05935c 100644
---- a/plugins/builtin/include/content/popups/popup_crash_recovered.hpp
-+++ b/plugins/builtin/include/content/popups/popup_crash_recovered.hpp
-@@ -4,6 +4,7 @@
-
- #include <hex/api/localization_manager.hpp>
-
-+#include <llvm/Config/llvm-config.h>
- #include <llvm/Demangle/Demangle.h>
-
- #include <string>
-@@ -20,7 +21,11 @@ namespace hex::plugin::builtin {
- void drawContent() override {
- ImGuiExt::TextFormattedWrapped("hex.builtin.popup.crash_recover.message"_lang);
-
-+#if LLVM_VERSION_MAJOR >= 17
- ImGuiExt::TextFormattedWrapped(hex::format("Error: {}: {}", llvm::itaniumDemangle(this->m_errorType), this->m_errorMessage));
-+#else
-+ ImGuiExt::TextFormattedWrapped(hex::format("Error: {}: {}", llvm::itaniumDemangle(this->m_errorType.c_str(), nullptr, nullptr, nullptr), this->m_errorMessage));
-+#endif
-
- if (ImGui::Button("hex.ui.common.okay"_lang)) {
- this->close();
---
-2.44.0
-
diff --git a/PKGBUILD b/PKGBUILD
index 2107f283ad8a..b811bb6d39a1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
_pkgname=ImHex
pkgname=${_pkgname,,}
pkgver=1.34.0
-pkgrel=1
+pkgrel=2
pkgdesc='A Hex Editor for Reverse Engineers, Programmers and people that value their eye sight when working at 3 AM'
url='https://imhex.werwolv.net'
license=('GPL-2.0-or-later')
@@ -19,22 +19,13 @@ optdepends=('dotnet-runtime: support for .NET scripts')
provides=('imhex-patterns')
conflicts=('imhex-patterns-git')
source=("$pkgname-$pkgver.tar.gz::https://github.com/WerWolv/ImHex/releases/download/v$pkgver/Full.Sources.tar.gz"
- "imhex-patterns-$pkgver.tar.gz::https://github.com/WerWolv/ImHex-Patterns/archive/refs/tags/ImHex-v$pkgver.tar.gz"
- 0001-fix-main-Handle-different-LLVM-version.patch)
+"imhex-patterns-$pkgver.tar.gz::https://github.com/WerWolv/ImHex-Patterns/archive/refs/tags/ImHex-v$pkgver.tar.gz")
sha256sums=('0918470bfa9603c423fb4708258d18195fbae582c585bcb822ceded141cf75f0'
- 'fa0d7862ecf4698e6b26fde1307b314f2ddc16d7e2c99e80d9b18c357e43bf06'
- '10824e6dfd8fedbad13c32be0ec3f4db09c250db827d8781869875426ee8b451')
+ 'fa0d7862ecf4698e6b26fde1307b314f2ddc16d7e2c99e80d9b18c357e43bf06')
b2sums=('ef746a991eb72c10747450d869eea5a5acc275cdbb75ecbb4c0d5ea66de0b09fa4606f6e4989b5c80988c805028f03ec2ea374d6bf0ef143c7ef5fc61ee551d0'
- 'd2601f344d51598a3e27da014617bed7e8cd5891bdbfc01a03aa6a337ca21d40bcd09d6de87c10971c49d6830672dbe8a6ec09c581ce329132ee495c0b131792'
- 'c9ac00ac69426f484ae2852c53bc2f9403859c4b38568b44c8c4a1c6258b33d7cf0429617aaf7cd5a356fd65a9647639f7f447451e493020439c259dae9e8dad')
+ 'd2601f344d51598a3e27da014617bed7e8cd5891bdbfc01a03aa6a337ca21d40bcd09d6de87c10971c49d6830672dbe8a6ec09c581ce329132ee495c0b131792')
options=(!lto !strip)
-prepare() {
- cd "$_pkgname"
-
- patch -Np1 -i "$srcdir/0001-fix-main-Handle-different-LLVM-version.patch"
-}
-
build() {
export CXXFLAGS="$CXXFLAGS -Wno-inconsistent-missing-override"