summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO11
-rw-r--r--LICENSE29
-rw-r--r--PKGBUILD18
3 files changed, 14 insertions, 44 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 23462effcc03..20a2c317e7f6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,16 @@
pkgbase = imlib2-heic
pkgdesc = HEIC/HEIF decoder for imlib2
- pkgver = 0.1.0
- pkgrel = 2
+ pkgver = 0.1.1
+ pkgrel = 1
url = https://github.com/vi/imlib2-heic
arch = x86_64
license = BSD
makedepends = git
depends = imlib2
depends = libheif
- source = git+https://github.com/vi/imlib2-heic.git#commit=d500fad6cc2411e41daaf305b77428bf2aa6c681?signed
- source = LICENSE
- validpgpkeys = 331079CCE5FF6E6C6F2B3019C097221D6E03DF68
+ source = git+https://github.com/vi/imlib2-heic.git#commit=8362aa93d4aa1826d1293b805c4dd10b9eb206b8?signed
+ validpgpkeys = 5DE3E0509C47EA3CF04A42D34AEE18F83AFDEB23
sha256sums = SKIP
- sha256sums = 003ec66759cd96918994a2b65f19352c3caf75def596a6fa047d5ed78b12b7c8
pkgname = imlib2-heic
+
diff --git a/LICENSE b/LICENSE
deleted file mode 100644
index 9a1e6864a313..000000000000
--- a/LICENSE
+++ /dev/null
@@ -1,29 +0,0 @@
-Copyright (c) 2011 David Hauweele <david@hauweele.net>
-All rights reserved.
-
-Modified by Vitaly "_Vi" Shukela to use heic instead of webp.
-
-Redistribution and use in source and binary forms, with or without
-modification, are permitted provided that the following conditions
-are met:
-
-1. Redistributions of source code must retain the above copyright
- notice, this list of conditions and the following disclaimer.
-2. Redistributions in binary form must reproduce the above copyright
- notice, this list of conditions and the following disclaimer in the
- documentation and/or other materials provided with the distribution.
-3. Neither the name of the University nor the names of its contributors
- may be used to endorse or promote products derived from this software
- without specific prior written permission.
-
-THIS SOFTWARE IS PROVIDED BY THE REGENTS AND CONTRIBUTORS ``AS IS'' AND
-ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
-IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE
-ARE DISCLAIMED. IN NO EVENT SHALL THE REGENTS OR CONTRIBUTORS BE LIABLE
-FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL
-DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS
-OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
-HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT
-LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY
-OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF
-SUCH DAMAGE.
diff --git a/PKGBUILD b/PKGBUILD
index 765f73ea0ac9..c31ae6e030d5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,20 @@
-# Maintainer: Daniel Moch <daniel@danielmoch.com>
+# Maintainer: dllud <dllud riseup net>
+# Contributor: Daniel Moch <daniel@danielmoch.com>
# Release tag is a lightweight tag, so we need to verify it as a commit
-_commit=d500fad6cc2411e41daaf305b77428bf2aa6c681
+_commit=8362aa93d4aa1826d1293b805c4dd10b9eb206b8
pkgname=imlib2-heic
-pkgver=0.1.0
-pkgrel=2
+pkgver=0.1.1
+pkgrel=1
pkgdesc="HEIC/HEIF decoder for imlib2"
arch=('x86_64')
url="https://github.com/vi/${pkgname}"
license=('BSD')
depends=(imlib2 libheif)
makedepends=(git)
-source=("git+${url}.git#commit=${_commit}?signed" "LICENSE")
-validpgpkeys=('331079CCE5FF6E6C6F2B3019C097221D6E03DF68') # Vitaly Shukela
-sha256sums=('SKIP'
- '003ec66759cd96918994a2b65f19352c3caf75def596a6fa047d5ed78b12b7c8')
+source=("git+${url}.git#commit=${_commit}?signed")
+validpgpkeys=('5DE3E0509C47EA3CF04A42D34AEE18F83AFDEB23') # GitHub key
+sha256sums=('SKIP')
build()
{
@@ -24,8 +24,8 @@ build()
package()
{
- install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
cd ${pkgname}
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
make install DESTDIR=${pkgdir}
}