summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD16
2 files changed, 11 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 98fec8377e44..59f4535dfea4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,8 @@
pkgbase = inadyn-fork
pkgdesc = Dynamic DNS client with SSL/TLS support
- pkgver = 2.4
+ pkgver = 2.9.1
pkgrel = 1
url = http://troglobit.com/inadyn.html
- arch = i686
arch = x86_64
license = GPL
depends = ca-certificates
@@ -11,8 +10,7 @@ pkgbase = inadyn-fork
depends = openssl
provides = inadyn
backup = etc/inadyn.conf
- source = https://github.com/troglobit/inadyn/releases/download/v2.4/inadyn-2.4.tar.xz
- sha256sums = f1c2a6a513506444ebf5052982b6b13fa0b280ff737cb56f510488f8dd432727
+ source = https://github.com/troglobit/inadyn/releases/download/v2.9.1/inadyn-2.9.1.tar.xz
+ sha256sums = 0094d20cfcd431674b8d658e93169c7589bf8f2b351b2860818a1ca05f0218c5
pkgname = inadyn-fork
-
diff --git a/PKGBUILD b/PKGBUILD
index 30fc0c0e32fe..0dfe9cc612a6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,29 +4,29 @@
# Contributor: Eric Engestrom <aur [at] engestrom [dot] ch>
# Contributor: trile7 at gmail dot com
-_name=inadyn
pkgname=inadyn-fork
-pkgver=2.4
+pkgver=2.9.1
pkgrel=1
pkgdesc="Dynamic DNS client with SSL/TLS support"
-arch=('i686' 'x86_64')
+arch=('x86_64')
url="http://troglobit.com/inadyn.html"
license=('GPL')
depends=('ca-certificates' 'confuse' 'openssl')
provides=('inadyn')
backup=('etc/inadyn.conf')
-source=(https://github.com/troglobit/inadyn/releases/download/v$pkgver/$_name-$pkgver.tar.xz)
-sha256sums=('f1c2a6a513506444ebf5052982b6b13fa0b280ff737cb56f510488f8dd432727')
+#source=("https://github.com/troglobit/inadyn/archive/refs/tags/v$pkgver.tar.gz")
+source=("https://github.com/troglobit/inadyn/releases/download/v$pkgver/inadyn-$pkgver.tar.xz")
+sha256sums=('0094d20cfcd431674b8d658e93169c7589bf8f2b351b2860818a1ca05f0218c5')
build() {
- cd $_name-$pkgver
+ cd "${pkgname%-fork}-$pkgver"
./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --sbindir=/usr/bin --enable-openssl
make
}
package() {
- cd $_name-$pkgver
- install -Dm600 examples/inadyn.conf "$pkgdir/etc/inadyn.conf"
+ cd "${pkgname%-fork}-$pkgver"
+ install -Dm600 examples/inadyn.conf -t "$pkgdir/etc"
make DESTDIR="$pkgdir" install-strip
}