summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD14
-rw-r--r--inadyn.conf103
3 files changed, 64 insertions, 58 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 199558eedfcf..11e055acb83c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,20 @@
pkgbase = inadyn-fork
pkgdesc = Dynamic DNS client with SSL/TLS support
pkgver = 2.2.1
- pkgrel = 1
+ pkgrel = 2
url = http://troglobit.com/inadyn.html
arch = i686
arch = x86_64
license = GPL
depends = ca-certificates
depends = confuse
- depends = libite
depends = openssl
provides = inadyn
backup = etc/inadyn.conf
source = https://github.com/troglobit/inadyn/releases/download/v2.2.1/inadyn-2.2.1.tar.xz
source = inadyn.conf
sha256sums = e7a74fcf8b7c069990940c0dc4d4d18071005be225667fdfcfa4156c44384579
- sha256sums = 4967d5fad250f38167b78c53862674afec7851f7c7bb648d00afe34db062bc60
+ sha256sums = a8203feb57e02d52f2ce4857e0ee8193b51da945b5f6966d223dd04dc6efdcbc
pkgname = inadyn-fork
diff --git a/PKGBUILD b/PKGBUILD
index 8c841c45a7cd..3991b650f75a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,23 +7,22 @@
_name=inadyn
pkgname=inadyn-fork
pkgver=2.2.1
-pkgrel=1
+pkgrel=2
pkgdesc="Dynamic DNS client with SSL/TLS support"
arch=('i686' 'x86_64')
url="http://troglobit.com/inadyn.html"
license=('GPL')
-#depends=('ca-certificates' 'confuse' 'openssl')
-depends=('ca-certificates' 'confuse' 'libite' 'openssl')
+depends=('ca-certificates' 'confuse' 'openssl')
provides=('inadyn')
backup=('etc/inadyn.conf')
source=(https://github.com/troglobit/inadyn/releases/download/v$pkgver/$_name-$pkgver.tar.xz
inadyn.conf)
sha256sums=('e7a74fcf8b7c069990940c0dc4d4d18071005be225667fdfcfa4156c44384579'
- '4967d5fad250f38167b78c53862674afec7851f7c7bb648d00afe34db062bc60')
+ 'a8203feb57e02d52f2ce4857e0ee8193b51da945b5f6966d223dd04dc6efdcbc')
build() {
cd $_name-$pkgver
- ./configure --prefix=/usr --sbindir=/usr/bin --sysconfdir=/etc --enable-openssl
+ ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --sbindir=/usr/bin --enable-openssl
make
}
@@ -31,9 +30,6 @@ package() {
install -Dm600 inadyn.conf "$pkgdir/etc/inadyn.conf"
cd $_name-$pkgver
- #install -Dm644 examples/dyndns.conf "$pkgdir/usr/share/inadyn/examples/dyndns.conf"
- #install -Dm644 examples/freedns.conf "$pkgdir/usr/share/inadyn/examples/freedns.conf"
- #install -Dm644 examples/custom.conf "$pkgdir/usr/share/inadyn/examples/custom.conf"
- make DESTDIR="$pkgdir" install
+ make DESTDIR="$pkgdir" install-strip
}
diff --git a/inadyn.conf b/inadyn.conf
index 54fa1b40bb5d..822ac9e03351 100644
--- a/inadyn.conf
+++ b/inadyn.conf
@@ -1,54 +1,65 @@
-# Example configuration of '/etc/inadyn.conf'
-# For more details see 'man inadyn.conf' and 'man inadyn'
-
-# In-A-Dyn v2.0 configuration file format
-#startup-delay = 60
-#period = 300
-#user-agent = Mozilla/5.0
+# /etc/inadyn.conf :: v2 configuration file format
#
-#provider default@dyndns.org {
-# ssl = false
-# username = charlie
-# password = snoopy
-# hostname = { peanuts, woodstock }
-# user-agent = Mozilla/4.0
-#}
+# 1. Select a matching DDNS provider to uncomment, this file lists a few
+# common ones, including a custom one, see inadyn(8) for the full list
#
-## With multiple usernames at the same provider, index with :#
-#provider default@no-ip.com:1 {
-# username = ian
-# password = secret
-# hostname = flemming.no-ip.com
-# user-agent = inadyn/2.2
-#}
+# 2. Edit the following options:
+# <username> - your username at the DDNS provider
+# <password> - your password at the DDNS provider
+# <hostname> - the DNS hostname(s) you want to update
#
-## With multiple usernames at the same provider, index with :#
-#provider default@no-ip.com:2 {
-# username = james
-# password = bond
-# hostname = spectre.no-ip.com
-# checkip-ssl = false
-# checkip-server = api.ipify.org
-#}
+# 3. Ensure to set 600 permissions on this file!
#
-## With multiple usernames at the same provider, index with :#
-#provider default@no-ip.com:3 {
-# username = spaceman
-# password = bowie
-# hostname = spaceman.no-ip.com
-# checkip-command = /sbin/ifconfig eth0 | grep 'inet6 addr'
+# See inadyn.conf(5) for detailed information on the syntax
+
+# How often the IP is checked. The value denotes seconds
+#period = 300
+
+# Custom HTTP user agent, some DDNS providers require this.
+# Default is inadyn/VERSION, you rarely need this.
+#user-agent = Mozilla/4.1
+
+# Set interface to check for IP, default is to ask an external
+# checkip server -- you rarely need this.
+#iface = eth1
+
+### FreeDNS -- https://freedns.afraid.org
+#provider freedns.afraid.org {
+# username = <username>
+# password = <password>
+# hostname = <hostname>
#}
-#
-## Note: hostname == update-key from Advanced tab in the Web UI
-#provider default@tunnelbroker.net {
-# username = futurekid
-# password = dreoadsad/+dsad21321 # update-key-in-advanced-tab
-# hostname = 1234534245321 # tunnel-id
+
+### Loopia -- https://www.loopia.com
+#provider loopia {
+# username = <username>
+# password = <password>
+## wildcard = true
+# hostname = { <hostname1>, <hostname2>, ... }
#}
-#
-#provider default@dynv6.com {
-# username = your_token
-# password = n/a
-# hostname = { host1.dynv6.net, host2.dynv6.net }
+
+### DYN.com -- http://www.dyn.com
+#provider Dyn {
+# username = <username>
+# password = <password>
+# hostname = <hostname>
#}
+### FreeMyIP -- https://freemyip.com
+#provider freemyip.com {
+# password = <your_token>
+# hostname = <your_hostname>.freemyip.com
+#}
+
+### Custom provider setup for http://twoDNS.de
+#custom twoDNS {
+# username = <username>
+# password = <password>
+# checkip-server = checkip.two-dns.de
+# checkip-path = /
+# checkip-ssl = false
+# ddns-server = update.twodns.de
+# ddns-path = "/update?hostname=%h"
+# ssl = true
+# hostname = <hostname>.dd-dns.de
+#}