summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD11
-rw-r--r--inadyn.conf65
3 files changed, 5 insertions, 75 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f184f57587c0..026bcf0ef51d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = inadyn-fork
pkgdesc = Dynamic DNS client with SSL/TLS support
pkgver = 2.3.1
- pkgrel = 1
+ pkgrel = 2
url = http://troglobit.com/inadyn.html
arch = i686
arch = x86_64
@@ -12,9 +12,7 @@ pkgbase = inadyn-fork
provides = inadyn
backup = etc/inadyn.conf
source = https://github.com/troglobit/inadyn/releases/download/v2.3.1/inadyn-2.3.1.tar.xz
- source = inadyn.conf
sha256sums = 81c942db6eab27fa16e868175bdb7aff963eeee06d48bc5443e0dcd6f7c2da40
- sha256sums = a8203feb57e02d52f2ce4857e0ee8193b51da945b5f6966d223dd04dc6efdcbc
pkgname = inadyn-fork
diff --git a/PKGBUILD b/PKGBUILD
index 959b6cbd25c3..825254457034 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
_name=inadyn
pkgname=inadyn-fork
pkgver=2.3.1
-pkgrel=1
+pkgrel=2
pkgdesc="Dynamic DNS client with SSL/TLS support"
arch=('i686' 'x86_64')
url="http://troglobit.com/inadyn.html"
@@ -15,10 +15,8 @@ license=('GPL')
depends=('ca-certificates' 'confuse' 'openssl')
provides=('inadyn')
backup=('etc/inadyn.conf')
-source=(https://github.com/troglobit/inadyn/releases/download/v$pkgver/$_name-$pkgver.tar.xz
- inadyn.conf)
-sha256sums=('81c942db6eab27fa16e868175bdb7aff963eeee06d48bc5443e0dcd6f7c2da40'
- 'a8203feb57e02d52f2ce4857e0ee8193b51da945b5f6966d223dd04dc6efdcbc')
+source=(https://github.com/troglobit/inadyn/releases/download/v$pkgver/$_name-$pkgver.tar.xz)
+sha256sums=('81c942db6eab27fa16e868175bdb7aff963eeee06d48bc5443e0dcd6f7c2da40')
build() {
cd $_name-$pkgver
@@ -27,9 +25,8 @@ build() {
}
package() {
- install -Dm600 inadyn.conf "$pkgdir/etc/inadyn.conf"
-
cd $_name-$pkgver
+ install -Dm600 examples/inadyn.conf "$pkgdir/etc/inadyn.conf"
make DESTDIR="$pkgdir" install-strip
}
diff --git a/inadyn.conf b/inadyn.conf
deleted file mode 100644
index 822ac9e03351..000000000000
--- a/inadyn.conf
+++ /dev/null
@@ -1,65 +0,0 @@
-# /etc/inadyn.conf :: v2 configuration file format
-#
-# 1. Select a matching DDNS provider to uncomment, this file lists a few
-# common ones, including a custom one, see inadyn(8) for the full list
-#
-# 2. Edit the following options:
-# <username> - your username at the DDNS provider
-# <password> - your password at the DDNS provider
-# <hostname> - the DNS hostname(s) you want to update
-#
-# 3. Ensure to set 600 permissions on this file!
-#
-# See inadyn.conf(5) for detailed information on the syntax
-
-# How often the IP is checked. The value denotes seconds
-#period = 300
-
-# Custom HTTP user agent, some DDNS providers require this.
-# Default is inadyn/VERSION, you rarely need this.
-#user-agent = Mozilla/4.1
-
-# Set interface to check for IP, default is to ask an external
-# checkip server -- you rarely need this.
-#iface = eth1
-
-### FreeDNS -- https://freedns.afraid.org
-#provider freedns.afraid.org {
-# username = <username>
-# password = <password>
-# hostname = <hostname>
-#}
-
-### Loopia -- https://www.loopia.com
-#provider loopia {
-# username = <username>
-# password = <password>
-## wildcard = true
-# hostname = { <hostname1>, <hostname2>, ... }
-#}
-
-### DYN.com -- http://www.dyn.com
-#provider Dyn {
-# username = <username>
-# password = <password>
-# hostname = <hostname>
-#}
-
-### FreeMyIP -- https://freemyip.com
-#provider freemyip.com {
-# password = <your_token>
-# hostname = <your_hostname>.freemyip.com
-#}
-
-### Custom provider setup for http://twoDNS.de
-#custom twoDNS {
-# username = <username>
-# password = <password>
-# checkip-server = checkip.two-dns.de
-# checkip-path = /
-# checkip-ssl = false
-# ddns-server = update.twodns.de
-# ddns-path = "/update?hostname=%h"
-# ssl = true
-# hostname = <hostname>.dd-dns.de
-#}