summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD50
-rw-r--r--inadyn.conf74
-rw-r--r--inadyn.service11
4 files changed, 85 insertions, 73 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 10441787d098..9d0601991f5e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,26 +1,21 @@
pkgbase = inadyn-fork
- pkgdesc = Simple dynamic DNS client - fork of the original INADYN implementation from Narcis Ilisei
- pkgver = 1.99.15
+ pkgdesc = Dynamic DNS client with SSL/TLS support
+ pkgver = 2.1
pkgrel = 1
url = http://troglobit.com/inadyn.html
- arch = x86_64
arch = i686
- arch = armv6h
- arch = armv7h
+ arch = x86_64
license = GPL
+ depends = ca-certificates
+ depends = confuse
+ depends = libite
depends = openssl
provides = inadyn
- conflicts = inadyn-opendns
- conflicts = inadyn
- conflicts = inadyn-mt
- conflicts = inadyn-fork-git
backup = etc/inadyn.conf
- source = https://github.com/troglobit/inadyn/releases/download/1.99.15/inadyn-1.99.15.tar.xz
+ source = https://github.com/troglobit/inadyn/releases/download/v2.1/inadyn-2.1.tar.xz
source = inadyn.conf
- source = inadyn.service
- sha256sums = b54ed82653e9bd6624e579433907aecfd3e83bdab9ed0b3c21d6817c799ac715
- sha256sums = 2da656ca5b971484c7e033e9e9bcd26afbf4fa08f707f7ca44d954d1646353d7
- sha256sums = 4587f4ae2a4215f9ba67d5b3b7d0aa120a9ebd31677472fa68d8792f42d7135f
+ sha256sums = 87639a7c1ddc047074601ad60188279a2a0d9393367f046c153de0e24586b3ac
+ sha256sums = 4967d5fad250f38167b78c53862674afec7851f7c7bb648d00afe34db062bc60
pkgname = inadyn-fork
diff --git a/PKGBUILD b/PKGBUILD
index 057e9b9c00a1..56bea1d738e3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,37 +1,39 @@
-# Maintainer: David Schury <dasc at posteo de>
+# Maintainer: willemw <willemw12@gmail.com>
+# Contributor: David Schury <dasc at posteo de>
# Contributor: reMiND <detanator_at_gmail_com>
# Contributor: Eric Engestrom <aur [at] engestrom [dot] ch>
# Contributor: trile7 at gmail dot com
-pkgname=inadyn-fork
_name=inadyn
-pkgver=1.99.15
+pkgname=inadyn-fork
+pkgver=2.1
pkgrel=1
-pkgdesc='Simple dynamic DNS client - fork of the original INADYN implementation from Narcis Ilisei'
-url='http://troglobit.com/inadyn.html'
-arch=('x86_64' 'i686' 'armv6h' 'armv7h')
+pkgdesc="Dynamic DNS client with SSL/TLS support"
+arch=('i686' 'x86_64')
+url="http://troglobit.com/inadyn.html"
license=('GPL')
-depends=('openssl')
-backup=('etc/inadyn.conf')
-conflicts=('inadyn-opendns' 'inadyn' 'inadyn-mt' 'inadyn-fork-git')
+#depends=('ca-certificates' 'confuse' 'openssl')
+depends=('ca-certificates' 'confuse' 'libite' 'openssl')
provides=('inadyn')
-source=(https://github.com/troglobit/inadyn/releases/download/$pkgver/${_name}-$pkgver.tar.xz
- inadyn.conf
- inadyn.service)
-sha256sums=('b54ed82653e9bd6624e579433907aecfd3e83bdab9ed0b3c21d6817c799ac715'
- '2da656ca5b971484c7e033e9e9bcd26afbf4fa08f707f7ca44d954d1646353d7'
- '4587f4ae2a4215f9ba67d5b3b7d0aa120a9ebd31677472fa68d8792f42d7135f')
+backup=('etc/inadyn.conf')
+source=(https://github.com/troglobit/inadyn/releases/download/v$pkgver/$_name-$pkgver.tar.xz
+ inadyn.conf)
+sha256sums=('87639a7c1ddc047074601ad60188279a2a0d9393367f046c153de0e24586b3ac'
+ '4967d5fad250f38167b78c53862674afec7851f7c7bb648d00afe34db062bc60')
-build(){
- cd ${_name}-$pkgver
- ./configure --prefix=/usr --sbindir=/usr/bin --enable-openssl
- export prefix=/usr # libite needs this
+build() {
+ cd $_name-$pkgver
+ ./configure --prefix=/usr --sbindir=/usr/bin --sysconfdir=/etc --enable-openssl
make
}
-package(){
- cd ${_name}-$pkgver
- make DESTDIR=$pkgdir install
- install -Dm644 ../inadyn.service $pkgdir/usr/lib/systemd/system/inadyn.service
- install -Dm600 ../inadyn.conf $pkgdir/etc/inadyn.conf
+package() {
+ install -Dm600 inadyn.conf "$pkgdir/etc/inadyn.conf"
+
+ cd $_name-$pkgver
+ #install -Dm644 examples/dyndns.conf "$pkgdir/usr/share/inadyn/examples/dyndns.conf"
+ #install -Dm644 examples/freedns.conf "$pkgdir/usr/share/inadyn/examples/freedns.conf"
+ #install -Dm644 examples/custom.conf "$pkgdir/usr/share/inadyn/examples/custom.conf"
+ make DESTDIR="$pkgdir" install
}
+
diff --git a/inadyn.conf b/inadyn.conf
index aa9c2527ba36..54fa1b40bb5d 100644
--- a/inadyn.conf
+++ b/inadyn.conf
@@ -1,28 +1,54 @@
# Example configuration of '/etc/inadyn.conf'
# For more details see 'man inadyn.conf' and 'man inadyn'
-background
-verbose 1
-period 300
-cache-dir /mnt/ddns
-startup-delay 60
-#logfile /var/log/ddns.log
-#pidfile /var/run/ddns.pid
+# In-A-Dyn v2.0 configuration file format
+#startup-delay = 60
+#period = 300
+#user-agent = Mozilla/5.0
+#
+#provider default@dyndns.org {
+# ssl = false
+# username = charlie
+# password = snoopy
+# hostname = { peanuts, woodstock }
+# user-agent = Mozilla/4.0
+#}
+#
+## With multiple usernames at the same provider, index with :#
+#provider default@no-ip.com:1 {
+# username = ian
+# password = secret
+# hostname = flemming.no-ip.com
+# user-agent = inadyn/2.2
+#}
+#
+## With multiple usernames at the same provider, index with :#
+#provider default@no-ip.com:2 {
+# username = james
+# password = bond
+# hostname = spectre.no-ip.com
+# checkip-ssl = false
+# checkip-server = api.ipify.org
+#}
+#
+## With multiple usernames at the same provider, index with :#
+#provider default@no-ip.com:3 {
+# username = spaceman
+# password = bowie
+# hostname = spaceman.no-ip.com
+# checkip-command = /sbin/ifconfig eth0 | grep 'inet6 addr'
+#}
+#
+## Note: hostname == update-key from Advanced tab in the Web UI
+#provider default@tunnelbroker.net {
+# username = futurekid
+# password = dreoadsad/+dsad21321 # update-key-in-advanced-tab
+# hostname = 1234534245321 # tunnel-id
+#}
+#
+#provider default@dynv6.com {
+# username = your_token
+# password = n/a
+# hostname = { host1.dynv6.net, host2.dynv6.net }
+#}
-# system default@dyndns.org
-# ssl
-# username yxxx
-# password xyxx
-# alias yyy
-# alias zzz
-
-# system default@no-ip.com
-# username xxyx
-# password xxxy
-# alias yyy
-
-# system default@tunnelbroker.net
-# ssl
-# username xyzzy
-# password update-key-in-advanced-tab
-# alias tunnel-id
diff --git a/inadyn.service b/inadyn.service
deleted file mode 100644
index fd44aa134d35..000000000000
--- a/inadyn.service
+++ /dev/null
@@ -1,11 +0,0 @@
-[Unit]
-Description=Inadyn DNS service updater
-After=network.target
-
-[Service]
-Type=forking
-ExecStart=/usr/sbin/inadyn --background --config /etc/inadyn.conf
-PIDFile=/run/inadyn/inadyn.pid
-
-[Install]
-WantedBy=multi-user.target