summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD62
-rw-r--r--_htaccess5
-rw-r--r--git.crontab2
-rw-r--r--papp.php56
-rw-r--r--path.php18
6 files changed, 165 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4555c1dc4dca
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = indefero-git
+ pkgdesc = Bug tracking, code review and free software forge
+ pkgver = 20091115
+ pkgrel = 3
+ url = http://www.indefero.net
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ depends = pluf
+ options = !purge
+ source = _htaccess
+ source = git.crontab
+ source = path.php
+ source = papp.php
+ md5sums = a9f992911798a18b94ac0d8eb4d990f8
+ md5sums = 8385e1a7ede6321c29643e54483f82aa
+ md5sums = 7a9212b9509f4ad7678ade42c3280283
+ md5sums = 4daff5fd70c18e761a4a3a7040405f37
+
+pkgname = indefero-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6f9389cad65b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,62 @@
+# Contributor: Jakub Vitak <mainiak@gmail.com>
+pkgname=indefero-git
+pkgver=20091115
+pkgrel=3
+pkgdesc="Bug tracking, code review and free software forge"
+arch=('i686' 'x86_64')
+url="http://www.indefero.net"
+license=('GPL')
+groups=()
+depends=('pluf')
+makedepends=('git')
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=(!purge)
+install=
+source=('_htaccess' 'git.crontab' 'path.php' 'papp.php')
+noextract=()
+
+_gitroot="git://projects.ceondo.com/indefero.git"
+_gitname="indefero"
+
+_FQDN="your-domain"
+_git_user="git"
+_http_user="http"
+
+build() {
+ cd "$srcdir"
+ msg "Connecting to GIT server...."
+
+ if [ -d $_gitname ] ; then
+ cd $_gitname && git pull origin
+ msg "The local files are updated."
+ else
+ git clone $_gitroot
+ fi
+
+ msg "GIT checkout done or server timeout"
+ msg "Starting make..."
+
+ rm -rf $pkgdir
+ mkdir -p $pkgdir/srv/http
+ cp -r $srcdir/$_gitname $pkgdir/srv/http
+ rm -rf $pkgdir/srv/http/$_gitname/.git
+ find $pkgdir -type f -name ".gitignore" -exec rm -f {} \;
+
+ cp $srcdir/_htaccess $pkgdir/srv/http/$_gitname/www/.htaccess
+ #crontab git.crontab -u $_git_user
+ #crontab - -u $_git_user < git.crontab
+
+ cd $pkgdir/srv/http/$_gitname/src/IDF
+ install -m644 $srcdir/papp.php ./
+
+ cd conf
+ install -m644 $srcdir/path.php ./
+
+}
+md5sums=('a9f992911798a18b94ac0d8eb4d990f8'
+ '8385e1a7ede6321c29643e54483f82aa'
+ '7a9212b9509f4ad7678ade42c3280283'
+ '4daff5fd70c18e761a4a3a7040405f37')
diff --git a/_htaccess b/_htaccess
new file mode 100644
index 000000000000..5ef7fd3dc0db
--- /dev/null
+++ b/_htaccess
@@ -0,0 +1,5 @@
+Options +FollowSymLinks
+RewriteEngine On
+RewriteCond %{REQUEST_FILENAME} !-f
+RewriteCond %{REQUEST_FILENAME} !-d
+RewriteRule ^(.*) /index.php/$1
diff --git a/git.crontab b/git.crontab
new file mode 100644
index 000000000000..42b1bfd089ec
--- /dev/null
+++ b/git.crontab
@@ -0,0 +1,2 @@
+## every minute
+* * * * * php /srv/http/indefero/scripts/gitcron.php >>/tmp/cron.log 2>&1
diff --git a/papp.php b/papp.php
new file mode 100644
index 000000000000..3cc48de09058
--- /dev/null
+++ b/papp.php
@@ -0,0 +1,56 @@
+<?php
+/* -*- tab-width: 4; indent-tabs-mode: nil; c-basic-offset: 4 -*- */
+/*
+# ***** BEGIN LICENSE BLOCK *****
+# This file is part of Plume Framework, a simple PHP Application Framework.
+# Copyright (C) 2001-2007 Loic d'Anterroches and contributors.
+#
+# Plume Framework is free software; you can redistribute it and/or modify
+# it under the terms of the GNU Lesser General Public License as published by
+# the Free Software Foundation; either version 2.1 of the License, or
+# (at your option) any later version.
+#
+# Plume Framework is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU Lesser General Public License for more details.
+#
+# You should have received a copy of the GNU Lesser General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301 USA
+#
+# ***** END LICENSE BLOCK ***** */
+
+/**
+ * This file contains the define of the [P]luf [App]lication for the
+ * automatic admin generation.
+ */
+return array(
+ 'path' => 'idf',
+ 'name' => __('Indefero'),
+ 'models' => array(
+ 'commit' => array('model' => 'IDF_Commit'),
+ 'conf' => array('model' => 'IDF_Conf'),
+ 'issue' => array('model' => 'IDF_Issue'),
+ 'issue_comment' => array('model' => 'IDF_IssueComment'),
+ 'issue_file' => array('model' => 'IDF_IssueFile'),
+ 'key' => array('model' => 'IDF_Key'),
+ 'project' => array('model' => 'IDF_Project'),
+ 'review' => array('model' => 'IDF_Review'),
+ 'review_comment' => array('model' => 'IDF_Review_Comment'),
+ 'review_file_comment' => array('model' => 'IDF_Review_FileComment'),
+ 'review_patch' => array('model' => 'IDF_Review_Patch'),
+ 'scm_cache_git' => array('model' => 'IDF_Scm_Cache_Git'),
+ 'search_occ' => array('model' => 'IDF_Search_Occ'),
+ 'tag' => array('model' => 'IDF_Tag'),
+ 'upload' => array('model' => 'IDF_Upload'),
+ 'wiki_page' => array('model' => 'IDF_WikiPage'),
+ 'wiki_revision' => array('model' => 'IDF_WikiRevision'),
+ 'message' => array('model' => 'Pluf_Message'),
+ 'permission' => array('model' => 'Pluf_Permission'),
+ 'row_permission' => array('model' => 'Pluf_RowPermission'),
+ 'search_occ' => array('model' => 'Pluf_Search_Occ'),
+ 'search_word' => array('model' => 'Pluf_Search_Word')
+ 'timeline' => array('model' => 'IDF_Timeline')
+ )
+);
diff --git a/path.php b/path.php
new file mode 100644
index 000000000000..25311575f6ae
--- /dev/null
+++ b/path.php
@@ -0,0 +1,18 @@
+<?php
+/* -*- tab-width: 4; indent-tabs-mode: nil; c-basic-offset: 4 -*- */
+
+/**
+ * This file define the paths to where the Pluf and InDefero libraries
+ * are installed. If you followed the recommended layout of the files
+ * in the installation procedure, they should work out of the box.
+ *
+ * PLUF_PATH: path to the folder containing the Pluf.php file.
+ * IDF_PATH: path to the folder containing the IDF folder.
+ */
+define('PLUF_PATH', '/srv/http/pluf/src');
+define('IDF_PATH', dirname(__FILE__).'/../..');
+
+set_include_path(get_include_path()
+ .PATH_SEPARATOR.PLUF_PATH
+ .PATH_SEPARATOR.IDF_PATH
+ );