summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD6
-rw-r--r--informant.install8
3 files changed, 12 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9faf1193d824..d320fa2e4417 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = informant
pkgdesc = An Arch Linux News reader and pacman hook
- pkgver = 0.1.0
- pkgrel = 2
+ pkgver = 0.2.0
+ pkgrel = 1
url = https://github.com/bradford-smith94/informant
install = informant.install
arch = any
@@ -11,7 +11,7 @@ pkgbase = informant
depends = python-dateutil
depends = python-feedparser
depends = python-html2text
- source = https://github.com/bradford-smith94/informant/archive/v0.1.0.tar.gz
+ source = https://github.com/bradford-smith94/informant/archive/v0.2.0.tar.gz
sha256sums = b0181dbb940a27328524f0ee0c3aede9eef26c77d25d92868cbde4b6db071fea
pkgname = informant
diff --git a/PKGBUILD b/PKGBUILD
index 83faab6276fd..83a1915a3c16 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Bradford Smith <aur@bradfords.me>
pkgname=informant
-pkgver=0.1.0
-pkgrel=2
+pkgver=0.2.0
+pkgrel=1
pkgdesc="An Arch Linux News reader and pacman hook"
arch=('any')
url="https://github.com/bradford-smith94/$pkgname"
@@ -10,7 +10,7 @@ license=('MIT')
install=informant.install
depends=('python' 'python-docopt' 'python-dateutil' 'python-feedparser' 'python-html2text')
source=("https://github.com/bradford-smith94/$pkgname/archive/v$pkgver.tar.gz")
-sha256sums=('b0181dbb940a27328524f0ee0c3aede9eef26c77d25d92868cbde4b6db071fea')
+sha256sums=('5911681cec9b3d49b469f94fea638d30386c4b08f9b19d93bb023143a04d877e')
package() {
cd "$srcdir/$pkgname-$pkgver"
diff --git a/informant.install b/informant.install
index 33493a403a03..17ce7bc062b7 100644
--- a/informant.install
+++ b/informant.install
@@ -1,11 +1,15 @@
+CLEAR="$(tput sgr0)"
+YELLOW="${bold}$(tput setaf 3)"
+
post_install() {
- groupadd informant
+ groupadd informant 2>/dev/null
touch /var/cache/informant.dat
chgrp informant /var/cache/informant.dat
chmod 664 /var/cache/informant.dat
- printf 'NOTE: Add yourself to group "informant" to avoid the need for sudo'
+ printf "%sNOTE%s: Add yourself to group \"informant\" to avoid the need for sudo\n" "$YELLOW" "$CLEAR"
}
post_upgrade() {
post_install
+ printf "%sWARNING%s: This update changes the format of the /var/cache/informant.dat file, you will need to re-read all news items.\n" "$YELLOW" "$CLEAR"
}