summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD31
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6c4beea0513d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = inkscape-applytransforms-git
+ pkgdesc = An Inkscape extension which removes all matrix transforms by applying them recursively to shapes
+ pkgver = r20.1d86e12
+ pkgrel = 1
+ url = https://github.com/Klowner/inkscape-applytransforms
+ arch = any
+ license = GPL2
+ depends = inkscape
+ depends = python2-lxml
+ source = git+https://github.com/Klowner/inkscape-applytransforms.git
+ md5sums = SKIP
+
+pkgname = inkscape-applytransforms-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b8307a79febe
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Marius Knaust <marius.knaust@gmail.com>
+
+_name=inkscape-applytransforms
+pkgname=$_name-git
+pkgver=r20.1d86e12
+pkgrel=1
+pkgdesc="An Inkscape extension which removes all matrix transforms by applying them recursively to shapes"
+arch=("any")
+url="https://github.com/Klowner/$_name"
+license=("GPL2")
+depends=("inkscape" "python2-lxml")
+makedepends=("git")
+provides=("_name")
+conflicts=("_name")
+source=("git+https://github.com/Klowner/$_name.git")
+md5sums=("SKIP")
+
+pkgver()
+{
+ cd "$_name"
+
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package()
+{
+ cd "$srcdir/$_name"
+
+ install -m755 -Dt "$pkgdir/usr/share/inkscape/extensions" applytransform.py
+ install -m644 -Dt "$pkgdir/usr/share/inkscape/extensions" applytransform.inx
+}