summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD37
2 files changed, 21 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d31421173d7b..e6aa7ad5c5bf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = inlets
pkgdesc = Expose your local endpoints to the Internet
- pkgver = 2.1.0
- pkgrel = 2
- url = https://github.com/alexellis/inlets
+ pkgver = 2.7.4
+ pkgrel = 1
+ url = https://github.com/inlets/inlets
arch = any
license = MIT
makedepends = go
@@ -10,10 +10,10 @@ pkgbase = inlets
options = !strip
source = inlets-server.service
source = inlets-client.service
- source = https://github.com/alexellis/inlets/archive/2.1.0.tar.gz
+ source = https://github.com/inlets/inlets/archive/2.7.4.tar.gz
sha256sums = 79bad343a925292d0a5cc5164bff28fe95d9512a5dded04568af61d71e1e0a79
sha256sums = f7f85bb083b8839a89f715f882bf0e0f556cf183aa7ed653a1c87c5822762163
- sha256sums = 8424ba7c94716e6d5ad18e4960bd23632c4353b2a1fefc51129a4c6dec353153
+ sha256sums = 55cab0f01b19f653637f4230bdb0ff15e4618a59651f37cad6bc69ff79460e7c
pkgname = inlets
diff --git a/PKGBUILD b/PKGBUILD
index 7e959bb0be62..f1c460a9acdb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,41 +1,36 @@
# Maintainer: Thor77 <thor77 at thor77 dot org>
pkgname=inlets
-pkgver=2.1.0
-pkgrel=2
+pkgver=2.7.4
+pkgrel=1
pkgdesc='Expose your local endpoints to the Internet'
arch=('any')
-url='https://github.com/alexellis/inlets'
+url='https://github.com/inlets/inlets'
license=('MIT')
makedepends=('go' 'git')
options=('!strip')
-_repo="github.com/alexellis"
-source=('inlets-server.service' 'inlets-client.service' "https://github.com/alexellis/inlets/archive/${pkgver}.tar.gz")
+source=('inlets-server.service' 'inlets-client.service' "https://github.com/inlets/inlets/archive/${pkgver}.tar.gz")
sha256sums=('79bad343a925292d0a5cc5164bff28fe95d9512a5dded04568af61d71e1e0a79'
'f7f85bb083b8839a89f715f882bf0e0f556cf183aa7ed653a1c87c5822762163'
- '8424ba7c94716e6d5ad18e4960bd23632c4353b2a1fefc51129a4c6dec353153')
-
-prepare() {
- export GOPATH="${srcdir}/gopath"
- export GOBIN="${GOPATH}/bin"
-
- mkdir -p "${GOPATH}/src/${_repo}/"
- ln -fsT "${srcdir}/${pkgname}-${pkgver}" "${GOPATH}/src/${_repo}/${pkgname}"
-}
+ '55cab0f01b19f653637f4230bdb0ff15e4618a59651f37cad6bc69ff79460e7c')
build() {
- export GOPATH="${srcdir}/gopath"
-
- cd "${GOPATH}/src/${_repo}/${pkgname}"
+ cd "$pkgname-$pkgver"
+ export CGO_CPPFLAGS="${CPPFLAGS}"
+ export CGO_CFLAGS="${CFLAGS}"
+ export CGO_CXXFLAGS="${CXXFLAGS}"
+ export CGO_LDFLAGS="${LDFLAGS}"
+ export GOFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external -mod=readonly -modcacherw"
- go build
+ go build .
}
package() {
- export GOPATH="${srcdir}/gopath"
- cd $srcdir
+ cd "$srcdir"
install -Dm644 inlets-server.service "$pkgdir/usr/lib/systemd/system/inlets-server.service"
install -Dm644 inlets-client.service "$pkgdir/usr/lib/systemd/system/inlets-client.service"
- install -Dm755 "${GOPATH}/src/${_repo}/${pkgname}/${pkgname}" "$pkgdir/usr/bin/inlets"
+
+ cd "$pkgname-$pkgver"
+ install -Dm755 $pkgname "$pkgdir/usr/bin/inlets"
}