summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO38
-rw-r--r--PKGBUILD55
-rw-r--r--instantbird.desktop10
-rw-r--r--libxul-fixes.patch71
-rw-r--r--mozconfig16
-rw-r--r--nss.patch24
-rw-r--r--shared-libs.patch12
7 files changed, 226 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..097351060887
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,38 @@
+pkgbase = instantbird
+ pkgdesc = Instant messenger using libpurple and xulrunner
+ pkgver = 1.5
+ pkgrel = 1
+ url = http://instantbird.com
+ arch = i686
+ arch = x86_64
+ license = MPL
+ license = GPL
+ license = LGPL
+ makedepends = unzip
+ makedepends = zip
+ makedepends = pkg-config
+ makedepends = diffutils
+ makedepends = python2
+ makedepends = wireless_tools
+ makedepends = yasm
+ makedepends = libidl2
+ makedepends = mesa
+ makedepends = autoconf2.13
+ depends = xulrunner<26.0
+ options = !buildflags
+ options = staticlibs
+ source = http://instantbird.com/downloads/1.5/instantbird-1.5.src.tgz
+ source = nss.patch
+ source = libxul-fixes.patch
+ source = shared-libs.patch
+ source = mozconfig
+ source = instantbird.desktop
+ md5sums = 5654c1b1c48f73699b218ea877a1252e
+ md5sums = b4c43e622dd62a4dc6a446d9f40fa6b2
+ md5sums = 358728705ee83b21a05c0bfd587e791b
+ md5sums = f2165407567b2d0f8fe90a9785a53025
+ md5sums = 7e4dd7027afd4a18129e569adcb080c3
+ md5sums = 9149cae331413af6430c7b5b8f9cfd80
+
+pkgname = instantbird
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5eca99a774a8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,55 @@
+# Contributor: Connor Behan <connor.behan@gmail.com>
+
+pkgname=instantbird
+pkgver=1.5
+pkgrel=1
+pkgdesc="Instant messenger using libpurple and xulrunner"
+arch=('i686' 'x86_64')
+license=('MPL' 'GPL' 'LGPL')
+url="http://instantbird.com"
+depends=('xulrunner<26.0')
+makedepends=('unzip' 'zip' 'pkg-config' 'diffutils' 'python2' 'wireless_tools' 'yasm' 'libidl2' 'mesa' 'autoconf2.13')
+source=(http://instantbird.com/downloads/${pkgver}/${pkgname}-${pkgver}.src.tgz nss.patch libxul-fixes.patch shared-libs.patch mozconfig ${pkgname}.desktop)
+options=('!buildflags' 'staticlibs')
+_xulnum=`ls /usr/lib | grep -m1 xulrunner-devel | sed -e 's/.*-//'`
+
+build() {
+ cd "${srcdir}"/${pkgname}-${pkgver}-src
+
+ cp "${srcdir}"/mozconfig .
+ patch -Np1 -i ../nss.patch
+ patch -Np1 -i ../libxul-fixes.patch
+ patch -Np1 -i ../shared-libs.patch
+ echo "ac_add_options --with-libxul-sdk=/usr/lib/xulrunner-devel-"${_xulnum} >> mozconfig
+
+ make -j1 -f client.mk build
+}
+
+package() {
+ cd "${srcdir}"/obj-${pkgname}/mozilla/dist
+
+ # This will take up more space but omni.ja appears to be broken
+ # https://bugzilla.mozilla.org/show_bug.cgi?id=956509
+ mkdir -p "${pkgdir}"/usr/bin
+ mkdir -p "${pkgdir}"/usr/lib
+ mkdir -p "${pkgdir}"/usr/share/pixmaps
+ mkdir -p "${pkgdir}"/usr/share/applications
+ cp -RL ./bin "${pkgdir}"/usr/lib/instantbird
+
+ cd "${pkgdir}"/usr/bin
+ ln -sf /usr/lib/instantbird/instantbird instantbird
+
+ # No idea why this is needed now
+ cd "${pkgdir}"/usr/lib/instantbird
+ ln -sf /usr/lib/xulrunner-${_xulnum} xulrunner
+
+ install -D -m 644 icons/mozicon128.png ../../share/pixmaps/instantbird.png
+ install -D -m 644 "${srcdir}"/instantbird.desktop ../../share/applications/instantbird.desktop
+}
+
+md5sums=('5654c1b1c48f73699b218ea877a1252e'
+ 'b4c43e622dd62a4dc6a446d9f40fa6b2'
+ '358728705ee83b21a05c0bfd587e791b'
+ 'f2165407567b2d0f8fe90a9785a53025'
+ '7e4dd7027afd4a18129e569adcb080c3'
+ '9149cae331413af6430c7b5b8f9cfd80')
diff --git a/instantbird.desktop b/instantbird.desktop
new file mode 100644
index 000000000000..25e281d9196d
--- /dev/null
+++ b/instantbird.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Name=Instandbird
+GenericName=Instant Messenger
+Comment=Multi-protocol Instant Messaging Client
+Exec=instantbird
+Icon=/usr/share/pixmaps/instantbird.png
+Terminal=false
+Type=Application
+Categories=Network;
+StartupNotify=false
diff --git a/libxul-fixes.patch b/libxul-fixes.patch
new file mode 100644
index 000000000000..e874de269fa5
--- /dev/null
+++ b/libxul-fixes.patch
@@ -0,0 +1,71 @@
+diff -ru instantbird-1.3-src.orig/config/config.mk instantbird-1.3-src/config/config.mk
+--- instantbird-1.3-src.orig/config/config.mk 2012-11-15 13:03:50.000000000 -0800
++++ instantbird-1.3-src/config/config.mk 2012-11-22 12:59:21.000000000 -0800
+@@ -457,7 +457,7 @@
+ endif
+
+ SDK_LIB_DIR = $(DIST)/sdk/lib
+-SDK_BIN_DIR = $(DIST)/sdk/bin
++SDK_BIN_DIR = $(LIBXUL_DIST)/sdk/bin
+
+ DEPENDENCIES = .md
+
+diff -ru instantbird-1.3-src.orig/mozilla/build/unix/Makefile.in instantbird-1.3-src/mozilla/build/unix/Makefile.in
+--- instantbird-1.3-src.orig/mozilla/build/unix/Makefile.in 2012-11-15 13:11:38.000000000 -0800
++++ instantbird-1.3-src/mozilla/build/unix/Makefile.in 2012-11-22 12:56:46.000000000 -0800
+@@ -23,7 +23,6 @@
+
+ TEST_DIRS = test
+
+-SDK_BINARY = run-mozilla.sh
+
+ include $(topsrcdir)/config/rules.mk
+
+diff -ru instantbird-1.3-src.orig/mozilla/config/config.mk instantbird-1.3-src/mozilla/config/config.mk
+--- instantbird-1.3-src.orig/mozilla/config/config.mk 2012-11-15 13:11:38.000000000 -0800
++++ instantbird-1.3-src/mozilla/config/config.mk 2012-11-22 12:59:41.000000000 -0800
+@@ -527,7 +527,7 @@
+ endif
+
+ SDK_LIB_DIR = $(DIST)/sdk/lib
+-SDK_BIN_DIR = $(DIST)/sdk/bin
++SDK_BIN_DIR = $(LIBXUL_DIST)/sdk/bin
+
+ DEPENDENCIES = .md
+
+diff -ru instantbird-1.3-src.orig/mozilla/js/src/config/config.mk instantbird-1.3-src/mozilla/js/src/config/config.mk
+--- instantbird-1.3-src.orig/mozilla/js/src/config/config.mk 2012-11-15 13:11:42.000000000 -0800
++++ instantbird-1.3-src/mozilla/js/src/config/config.mk 2012-11-22 13:00:00.000000000 -0800
+@@ -527,7 +527,7 @@
+ endif
+
+ SDK_LIB_DIR = $(DIST)/sdk/lib
+-SDK_BIN_DIR = $(DIST)/sdk/bin
++SDK_BIN_DIR = $(LIBXUL_DIST)/sdk/bin
+
+ DEPENDENCIES = .md
+
+diff -ru instantbird-1.5-src.orig/instantbird/locales/Makefile.in instantbird-1.5-src/instantbird/locales/Makefile.in
+--- instantbird-1.5-src.orig/instantbird/locales/Makefile.in 2014-01-03 11:44:32.000000000 -0800
++++ instantbird-1.5-src/instantbird/locales/Makefile.in 2014-01-03 11:45:52.000000000 -0800
+@@ -83,10 +82,8 @@
+
+ libs-%:
+ $(NSINSTALL) -D $(DIST)/install
+- @$(MAKE) -C ../../mozilla/toolkit/locales libs-$*
+ @$(MAKE) -C ../../chat/locales AB_CD=$* XPI_NAME=locale-$*
+ @$(MAKE) -C ../../purple/locales AB_CD=$* XPI_NAME=locale-$*
+- @$(MAKE) -C ../../mozilla/extensions/spellcheck/locales AB_CD=$* XPI_NAME=locale-$*
+ @$(MAKE) -C ../../mozilla/intl/locales AB_CD=$* XPI_NAME=locale-$*
+ @$(MAKE) libs AB_CD=$* XPI_NAME=locale-$* PREF_DIR=defaults/pref
+ @$(MAKE) -C $(DEPTH)/$(MOZ_BRANDING_DIRECTORY)/locales AB_CD=$* XPI_NAME=locale-$*
+@@ -134,7 +131,7 @@
+ $(STAGEDIST)/isp/$(AB_CD) \
+ $(STAGEDIST)/chrome/$(AB_CD)
+
+-langpack: langpack-$(AB_CD)
++langpack:
+
+ # This is a generic target that will make a langpack, repack ZIP (+tarball)
+ # builds, and repack and installer if applicable. It is called from the
+
diff --git a/mozconfig b/mozconfig
new file mode 100644
index 000000000000..2159eb2e7f00
--- /dev/null
+++ b/mozconfig
@@ -0,0 +1,16 @@
+ac_add_options --enable-application=instantbird
+ac_add_options --prefix=/usr
+ac_add_options --with-system-nss
+ac_add_options --with-system-nspr
+ac_add_options --disable-crashreporter
+ac_add_options --disable-installer
+ac_add_options --disable-tests
+
+if [ "$DEBUG" ]; then
+ mk_add_options MOZ_OBJDIR=@TOPSRCDIR@/../obj-instantbird-dbg
+ ac_add_options --enable-extensions=inspector
+ ac_add_options --enable-debug --disable-optimize --disable-jemalloc
+else
+ mk_add_options MOZ_OBJDIR=@TOPSRCDIR@/../obj-instantbird
+ ac_add_options --disable-debug --enable-optimize
+fi
diff --git a/nss.patch b/nss.patch
new file mode 100644
index 000000000000..9f971e33c0aa
--- /dev/null
+++ b/nss.patch
@@ -0,0 +1,24 @@
+diff -ru instantbird-1.5-src.orig/mozilla/configure.in instantbird-1.3-src/mozilla/configure.in
+--- instantbird-1.5-src.orig/mozilla/configure.in 2012-11-15 13:11:47.000000000 -0800
++++ instantbird-1.5-src/mozilla/configure.in 2012-11-22 12:38:19.000000000 -0800
+@@ -3911,7 +3911,7 @@
+ if test -n "$MOZ_NATIVE_NSS"; then
+ NSS_LIBS="$NSS_LIBS -lcrmf"
+ else
+- NSS_CFLAGS='-I$(LIBXUL_DIST)/include/nss'
++ NSS_CFLAGS=`$NSS_CONFIG $nss_config_args --cflags`
+
+ if test -z "$GNU_CC" -a "$OS_ARCH" = "WINNT" -o "$OS_ARCH" = "OS2"; then
+ NSS_LIBS="\
+diff -ru instantbird-1.5-src.orig/purple/libpurple/Makefile.in instantbird-1.3-src/purple/libpurple/Makefile.in
+--- instantbird-1.5-src.orig/purple/libpurple/Makefile.in 2012-11-15 13:03:51.000000000 -0800
++++ instantbird-1.5-src/purple/libpurple/Makefile.in 2012-11-22 12:42:54.000000000 -0800
+@@ -19,7 +19,7 @@
+ VISIBILITY_FLAGS=
+
+ ifeq (,$(filter WINNT Darwin,$(OS_ARCH)))
+-LOCAL_INCLUDES = $(GLIB_CFLAGS) $(LIBXML2_CFLAGS)
++LOCAL_INCLUDES = $(NSS_CFLAGS) $(GLIB_CFLAGS) $(LIBXML2_CFLAGS)
+ else
+ LOCAL_INCLUDES = -I$(DIST)/include/glib
+ SHARED_LIBRARY_LIBS += $(foreach lib,glib xml2,../libraries/$(lib)/$(LIB_PREFIX)$(lib).$(LIB_SUFFIX))
diff --git a/shared-libs.patch b/shared-libs.patch
new file mode 100644
index 000000000000..fa24df8b84e1
--- /dev/null
+++ b/shared-libs.patch
@@ -0,0 +1,12 @@
+diff -Nur instantbird-1.5-src.orig/instantbird/installer/Makefile.in instantbird-1.5-src/instantbird/installer/Makefile.in
+--- instantbird-1.5-src/instantbird/installer/Makefile.in 2012-07-17 16:19:29.480356991 +0000
++++ instantbird-1.5-src/instantbird/installer/Makefile.in 2012-07-17 17:32:41.250937293 +0000
+@@ -50,7 +50,7 @@
+ MOZ_PKG_MANIFEST_P = $(srcdir)/package-manifest.in
+ # Some files have been already bundled with xulrunner
+ ifndef SYSTEM_LIBXUL
+-MOZ_PKG_FATAL_WARNINGS = 1
++MOZ_PKG_FATAL_WARNINGS = 0
+ endif
+
+ MOZ_NONLOCALIZED_PKG_LIST = \