summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD50
2 files changed, 35 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a21029d87535..22d37cedb39f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,18 @@
pkgbase = intel-graphics-compiler-git
pkgdesc = Intel Graphics Compiler for OpenCL (git version)
- pkgver = r869.4128b9e
+ pkgver = 2018.12.12.r50.g66ad47d
pkgrel = 1
url = https://github.com/intel/intel-graphics-compiler/
- arch = i686
arch = x86_64
license = MIT
makedepends = git
makedepends = cmake
- makedepends = clang
+ makedepends = python
makedepends = python2
+ makedepends = python2-pygments
+ makedepends = python2-yaml
+ makedepends = spirv-tools
+ makedepends = clang40
depends = gcc-libs
depends = ncurses
depends = zlib
@@ -20,6 +23,7 @@ pkgbase = intel-graphics-compiler-git
source = igc::git+https://github.com/intel/intel-graphics-compiler.git
source = llvm_source::git+https://github.com/llvm-mirror/llvm#branch=release_40
source = clang_source::git+https://github.com/llvm-mirror/clang#branch=release_40
+ source = llvm7.0.0_source::git+https://github.com/llvm-mirror/llvm#branch=release_70
source = llvm_patches::git+https://github.com/intel/llvm-patches
source = common_clang::git+https://github.com/intel/opencl-clang
source = opencl_headers::git+https://github.com/KhronosGroup/OpenCL-Headers
@@ -29,6 +33,7 @@ pkgbase = intel-graphics-compiler-git
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
+ sha256sums = SKIP
pkgname = intel-graphics-compiler-git
diff --git a/PKGBUILD b/PKGBUILD
index 3b0d169bf576..35ea033d3936 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,27 @@
# Maintainer: Daniel Bermond < gmail-com: danielbermond >
-_llvm_branch='release_40'
-
pkgname=intel-graphics-compiler-git
-pkgver=r869.4128b9e
+pkgver=2018.12.12.r50.g66ad47d
pkgrel=1
pkgdesc='Intel Graphics Compiler for OpenCL (git version)'
-arch=('i686' 'x86_64')
+arch=('x86_64')
url='https://github.com/intel/intel-graphics-compiler/'
license=('MIT')
depends=('gcc-libs' 'ncurses' 'zlib')
-makedepends=('git' 'cmake' 'clang' 'python2')
+makedepends=(
+ # official repositories:
+ 'git' 'cmake' 'python' 'python2' 'python2-pygments' 'python2-yaml'
+ 'spirv-tools'
+ # AUR:
+ 'clang40'
+)
provides=('intel-graphics-compiler')
conflicts=('intel-graphics-compiler' 'compute-runtime')
options=('!emptydirs')
source=('igc'::'git+https://github.com/intel/intel-graphics-compiler.git'
- 'llvm_source'::"git+https://github.com/llvm-mirror/llvm#branch=${_llvm_branch}"
- 'clang_source'::"git+https://github.com/llvm-mirror/clang#branch=${_llvm_branch}"
+ 'llvm_source'::'git+https://github.com/llvm-mirror/llvm#branch=release_40'
+ 'clang_source'::'git+https://github.com/llvm-mirror/clang#branch=release_40'
+ 'llvm7.0.0_source'::"git+https://github.com/llvm-mirror/llvm#branch=release_70"
'llvm_patches'::'git+https://github.com/intel/llvm-patches'
'common_clang'::'git+https://github.com/intel/opencl-clang'
'opencl_headers'::'git+https://github.com/KhronosGroup/OpenCL-Headers')
@@ -25,33 +30,35 @@ sha256sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
+ 'SKIP'
'SKIP')
+prepare() {
+ mkdir -p build
+}
+
pkgver() {
cd igc
- # git, no tags available
- printf 'r%s.%s' "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ # git, tags available
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/^igc_release_//'
}
build() {
- [ "$CARCH" = 'i686' ] && local _arch='Linux32'
- [ "$CARCH" = 'x86_64' ] && local _arch='Linux64'
-
- mkdir -p build
cd build
cmake \
- -DCMAKE_BUILD_TYPE:STRING='Release' \
-DCMAKE_INSTALL_PREFIX:PATH='/usr' \
- -DIGC_OPTION__ARCHITECTURE_TARGET:STRING="$_arch" \
-DIGC_OPTION__OUTPUT_DIR:PATH='../igc-install/Release' \
-Wno-dev \
../igc/IGC
make
-
make package
+
+ # license
+ sed -n '2,20p' igc.opencl.h > LICENSE # create file
+ sed -i '1,22s/^.\{,3\}//' LICENSE # erase C comments
}
package() {
@@ -59,16 +66,13 @@ package() {
cd "$(find . -maxdepth 1 -type d -name 'intel-*')"
- for _dir in igc-*
+ local _dir
+ while read -rd '' _dir
do
cd "$_dir"
cp -af * "$pkgdir"
cd ..
- done
+ done < <(find . -maxdepth 1 -type d -name 'igc-*' -print0)
- # license
- cd "${srcdir}/build"
- sed -n '2,20p' igc.opencl.h > LICENSE # create file
- sed -i '1,22s/^.\{,3\}//' LICENSE # erase C comments
- install -D -m644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -D -m644 "${srcdir}/build/LICENSE" -t "${pkgdir}/usr/share/licenses/${pkgname}"
}