summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rwxr-xr-xPKGBUILD18
2 files changed, 17 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4470508f9407..f6dc247a07e6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = intel-media-sdk-git
pkgdesc = API to access hardware-accelerated video decode, encode and filtering on Intel platforms with integrated graphics (git version)
- pkgver = 2018.3.pre1.r44.gea19516
- pkgrel = 2
+ pkgver = 2018.3.pre1.r64.g7557124
+ pkgrel = 1
url = https://github.com/Intel-Media-SDK/MediaSDK/
arch = x86_64
license = MIT
diff --git a/PKGBUILD b/PKGBUILD
index bb34adf3354d..9b5dc058ddf8 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,8 +8,8 @@
# Currently it will not be a mandatory makedepend.
pkgname=intel-media-sdk-git
-pkgver=2018.3.pre1.r44.gea19516
-pkgrel=2
+pkgver=2018.3.pre1.r64.g7557124
+pkgrel=1
pkgdesc='API to access hardware-accelerated video decode, encode and filtering on Intel platforms with integrated graphics (git version)'
arch=('x86_64')
url='https://github.com/Intel-Media-SDK/MediaSDK/'
@@ -63,9 +63,16 @@ build() {
-D__GENERATOR:STRING='make' \
-D__IPP:STRING='e9' \
-D__TARGET_PLATFORM:STRING='BDW' \
+ -DBUILD_ALL:BOOL='ON' \
+ -DBUILD_DISPATCHER:BOOL='ON' \
+ -DBUILD_RUNTIME:BOOL='ON' \
+ -DBUILD_SAMPLES:BOOL='ON' \
+ -DBUILD_TOOLS:BOOL='ON' \
+ -DENABLE_ALL:BOOL='ON' \
-DENABLE_ITT:BOOL='OFF' \
-DENABLE_OPENCL:BOOL='ON' \
- -DENABLE_TOOLS:BOOL='ON' \
+ -DENABLE_STAT:BOOL='OFF' \
+ -DENABLE_TEXTLOG:BOOL='OFF' \
-DENABLE_WAYLAND:BOOL='ON' \
-DENABLE_X11_DRI3:BOOL='ON' \
--no-warn-unused-cli \
@@ -80,6 +87,11 @@ package() {
make DESTDIR="$pkgdir" install
+ # tools
+ cd __bin/release
+ install -D -m755 asg-hevc -t "${pkgdir}/usr/bin"
+ install -D -m755 hevc_fei_extractor -t "${pkgdir}/usr/bin"
+
# ld.so and profile configuration files
cd "$srcdir"
install -D -m644 intel-media-sdk-git.conf -t "${pkgdir}/etc/ld.so.conf.d"