summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD25
2 files changed, 25 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index da3131885fc0..b41ef2e182e1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Tue Aug 1 20:24:44 UTC 2017
+# Mon Aug 14 07:03:54 UTC 2017
pkgbase = intellij-idea-ultimate-edition
pkgdesc = An intelligent IDE for Java, Groovy and other programming languages with advanced refactoring features intensely focused on developer productivity.
pkgver = 2017.2.1
@@ -11,15 +11,18 @@ pkgbase = intellij-idea-ultimate-edition
depends = giflib
depends = libxtst
options = !strip
- backup = usr/share/intellij-idea-ultimate-edition/bin/idea.vmoptions
- backup = usr/share/intellij-idea-ultimate-edition/bin/idea64.vmoptions
- backup = usr/share/intellij-idea-ultimate-edition/bin/idea.properties
- source = https://download.jetbrains.com/idea/ideaIU-2017.2.1-no-jdk.tar.gz
+ source = https://download.jetbrains.com/idea/ideaIU-2017.2.1.tar.gz
source = intellijidea.sh
source = jetbrains-idea.desktop
- sha256sums = 733c3a799283ffb9b07a8aba72688f3bf23c27d92efa1eb9a7a72521a2407978
+ sha256sums = 136674855d26fb7f07a914eecc7236b177ef8349c23aa7811b9670da43d62ae2
sha256sums = ed7883b33b6fa9f2e303e5549bd238ceb552ec11ca116730271a58aca685229a
sha256sums = 83af2ba8f9f14275a6684e79d6d4bd9b48cd852c047dacfc81324588fa2ff92b
pkgname = intellij-idea-ultimate-edition
+ backup = usr/share/intellij-idea-ultimate-edition/bin/idea.vmoptions
+ backup = usr/share/intellij-idea-ultimate-edition/bin/idea64.vmoptions
+ backup = usr/share/intellij-idea-ultimate-edition/bin/idea.properties
+
+pkgname = intellij-idea-ultimate-edition-jre
+ arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 3c450f8f7915..00f5b1927c8e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,31 +1,32 @@
# Maintainer: Urs Wolfer <uwolfer @ fwo.ch>
-pkgname=intellij-idea-ultimate-edition
+pkgbase=intellij-idea-ultimate-edition
+pkgname=(intellij-idea-ultimate-edition intellij-idea-ultimate-edition-jre)
pkgver=2017.2.1
_buildver=172.3544.35
pkgrel=1
-pkgdesc="An intelligent IDE for Java, Groovy and other programming languages with advanced refactoring features intensely focused on developer productivity."
arch=('any')
+pkgdesc="An intelligent IDE for Java, Groovy and other programming languages with advanced refactoring features intensely focused on developer productivity."
url="https://www.jetbrains.com/idea/"
-backup=("usr/share/${pkgname}/bin/idea.vmoptions" "usr/share/${pkgname}/bin/idea64.vmoptions" "usr/share/${pkgname}/bin/idea.properties")
license=('Commercial')
depends=('java-environment' 'giflib' 'libxtst')
options=(!strip)
-source=(https://download.jetbrains.com/idea/ideaIU-$pkgver-no-jdk.tar.gz \
+source=(https://download.jetbrains.com/idea/ideaIU-$pkgver.tar.gz \
intellijidea.sh \
jetbrains-idea.desktop
)
-sha256sums=('733c3a799283ffb9b07a8aba72688f3bf23c27d92efa1eb9a7a72521a2407978'
+sha256sums=('136674855d26fb7f07a914eecc7236b177ef8349c23aa7811b9670da43d62ae2'
'ed7883b33b6fa9f2e303e5549bd238ceb552ec11ca116730271a58aca685229a'
'83af2ba8f9f14275a6684e79d6d4bd9b48cd852c047dacfc81324588fa2ff92b')
-package() {
+package_intellij-idea-ultimate-edition() {
+ backup=("usr/share/${pkgname}/bin/idea.vmoptions" "usr/share/${pkgname}/bin/idea64.vmoptions" "usr/share/${pkgname}/bin/idea.properties")
cd "$srcdir"
- install -d -m755 "$pkgdir"/usr/{bin,share}
- cp -a "idea-IU-$_buildver" "$pkgdir"/usr/share/"$pkgname"
+ install -d -m755 "${pkgdir}"/usr/{bin,share}
+ rsync -rtl "idea-IU-${_buildver}/" "${pkgdir}/usr/share/${pkgbase}" --exclude=/jre64
# make sure that all files are owned by root
- chown -R root:root "$pkgdir"/usr/share
+ chown -R root:root "${pkgdir}/usr/share"
find "$pkgdir"/usr/share/"$pkgname" -type d -exec chmod 0755 {} ';'
find "$pkgdir"/usr/share/"$pkgname" -type f -exec chmod 0644 {} ';'
@@ -42,4 +43,10 @@ package() {
sed -i 's|lcd|on|' "$pkgdir"/usr/share/"$pkgname"/bin/*.vmoptions
}
+package_intellij-idea-ultimate-edition-jre() {
+ arch=('x86_64')
+ install -d -m 755 "${pkgdir}/usr/share/${pkgbase}"
+ rsync -rtl "${srcdir}/idea-IU-${_buildver}/jre64" "${pkgdir}/usr/share/${pkgbase}"
+}
+
# vim:set ts=2 sw=2 et: