summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD14
2 files changed, 13 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a16e4f1e2fa0..422246a79fab 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,23 +1,24 @@
pkgbase = ioquake3-git
pkgdesc = The de-facto OSS Quake 3 distribution. You need the retail/demo .pk3 files to play.
pkgver = 20131217.gbc2efc4
- pkgrel = 1
+ pkgrel = 2
url = http://ioquake3.org/
install = quake3.install
arch = i686
arch = x86_64
license = GPL
- makedepends = nasm
makedepends = git
depends = curl
depends = freetype2
depends = libjpeg
depends = libvorbis
depends = openal
+ depends = opus
+ depends = opusfile
depends = sdl
depends = speex
depends = zlib
- optdepends = mumble
+ optdepends = mumble: Mumble VoIP support
provides = quake3
provides = ioquake3
conflicts = quake3
@@ -28,7 +29,7 @@ pkgbase = ioquake3-git
replaces = ioquake3-svn
source = quake3.desktop
source = http://ftp.gwdg.de/pub/misc/ftp.idsoftware.com/idstuff/quake3/linux/linuxq3apoint-1.32b-3.x86.run
- source = quake3::git://github.com/ioquake/ioq3.git
+ source = quake3::git+https://github.com/ioquake/ioq3.git
sha256sums = 12dbd31e9de1493642d120bfd1548dfc4935e47fec806003cfc04b9d84b85673
sha256sums = c36132c5556b35e01950f1e9c646235033a5130f87ad776ba2bc7becf4f4f186
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index d1f60a54c39a..0e35daab11ff 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,21 +3,21 @@
pkgname=ioquake3-git
pkgver=20131217.gbc2efc4
-pkgrel=1
+pkgrel=2
pkgdesc="The de-facto OSS Quake 3 distribution. You need the retail/demo .pk3 files to play."
url="http://ioquake3.org/"
license=('GPL')
arch=('i686' 'x86_64')
-depends=('curl' 'freetype2' 'libjpeg' 'libvorbis' 'openal' 'sdl' 'speex' 'zlib')
-makedepends=('nasm' 'git')
-optdepends=('mumble')
+depends=('curl' 'freetype2' 'libjpeg' 'libvorbis' 'openal' 'opus' 'opusfile' 'sdl' 'speex' 'zlib')
+makedepends=('git')
+optdepends=('mumble: Mumble VoIP support')
conflicts=('quake3' 'quake3-icculus-svn' 'quake3-svn' 'ioquake3-svn')
provides=('quake3' 'ioquake3')
replaces=('quake3-icculus-svn' 'ioquake3-svn')
install=quake3.install
source=('quake3.desktop' \
'http://ftp.gwdg.de/pub/misc/ftp.idsoftware.com/idstuff/quake3/linux/linuxq3apoint-1.32b-3.x86.run'
-'quake3::git://github.com/ioquake/ioq3.git')
+'quake3::git+https://github.com/ioquake/ioq3.git')
sha256sums=('12dbd31e9de1493642d120bfd1548dfc4935e47fec806003cfc04b9d84b85673'
'c36132c5556b35e01950f1e9c646235033a5130f87ad776ba2bc7becf4f4f186'
'SKIP')
@@ -37,6 +37,8 @@ prepare() {
}
q3make() {
+ export CFLAGS="${CFLAGS} $(pkg-config --cflags opusfile)"
+
make $@ \
BUILD_CLIENT=1 \
BUILD_SERVER=1 \
@@ -54,7 +56,7 @@ q3make() {
USE_CURL=1 \
USE_CURL_DLOPEN=0 \
USE_CODEC_VORBIS=1 \
- USE_CODEC_OPUS=0 \
+ USE_CODEC_OPUS=1 \
USE_FREETYPE=1 \
USE_MUMBLE=1 \
USE_VOIP=1 \