summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD35
-rw-r--r--iozone-3_420.diff96
3 files changed, 23 insertions, 121 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6212b1b845bd..b6d9d74ca8dd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,18 @@
+# Generated by mksrcinfo v8
+# Mon Jan 18 07:03:27 UTC 2016
pkgbase = iozone
pkgdesc = A filesystem benchmark tool
- pkgver = 3_420
+ pkgver = 3_434
pkgrel = 1
url = http://www.iozone.org/
install = iozone.install
arch = i686
arch = x86_64
- arch = ppc
- arch = armv6h
- arch = armv7h
license = custom
depends = sh
optdepends = gnuplot: for generating graph reports
- source = http://www.iozone.org/src/current/iozone3_420.tar
- source = iozone-3_420.diff
- md5sums = 5205cd571c6e68440772f7e0af0712d6
- md5sums = a8fcaa9f51095d4c65bddcf7f4ed7cd8
+ source = http://www.iozone.org/src/current/iozone3_434.tar
+ md5sums = 3e8f4213581407225065b91774e970ed
pkgname = iozone
diff --git a/PKGBUILD b/PKGBUILD
index 95571e833b32..b47dd5f27dd1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,34 +1,35 @@
-# Maintainer: Joris Steyn <jorissteyn@gmail.com>
+# Maintainer: brent s. <bts[at]square-r00t[dot]net>
+# Past maintainer: Joris Steyn <jorissteyn@gmail.com>
# Contributor: TDY <tdy@gmx.com>
pkgname=iozone
-pkgver=3_420
+pkgver=3_434
pkgrel=1
pkgdesc="A filesystem benchmark tool"
-arch=('i686' 'x86_64' 'ppc' 'armv6h' 'armv7h')
+arch=('i686' 'x86_64')
url="http://www.iozone.org/"
license=('custom')
depends=('sh')
optdepends=('gnuplot: for generating graph reports')
install=$pkgname.install
-source=(http://www.$pkgname.org/src/current/$pkgname$pkgver.tar
- $pkgname-$pkgver.diff)
-md5sums=('5205cd571c6e68440772f7e0af0712d6'
- 'a8fcaa9f51095d4c65bddcf7f4ed7cd8')
+source=(http://www.${pkgname}.org/src/current/${pkgname}${pkgver}.tar)
+md5sums=('3e8f4213581407225065b91774e970ed')
build() {
- cd "$srcdir/$pkgname$pkgver/src/current"
- patch -Np2 -i "$srcdir/$pkgname-$pkgver.diff"
+ cd "${srcdir}/${pkgname}${pkgver}/src/current"
- if test "$CARCH" == 'armv6h' || \
- test "$CARCH" == 'armv7h' ; then
- maketarget=linux-arm
- else
- maketarget=linux-$CARCH
+ if [[ "${CARCH}" == 'x86_64' ]];
+ then
+ TARGET='-AMD64'
fi
- make $maketarget CFLAGS="$CFLAGS"
+
+ make linux${TARGET} CFLAGS="${CFLAGS}"
}
package() {
- cd "$srcdir/$pkgname$pkgver/src/current"
- make DESTDIR="$pkgdir" install
+ cd "${srcdir}/${pkgname}${pkgver}/src/current"
+ make DESTDIR="${pkgdir}"
+
+ install -D -m 755 ${srcdir}/${pkgname}${pkgver}/src/current/iozone ${pkgdir}/usr/bin/iozone
+ install -D -m 755 ${srcdir}/${pkgname}${pkgver}/src/current/fileop ${pkgdir}/usr/bin/fileop
+ install -D -m 755 ${srcdir}/${pkgname}${pkgver}/src/current/pit_server ${pkgdir}/usr/bin/pit_server
}
diff --git a/iozone-3_420.diff b/iozone-3_420.diff
deleted file mode 100644
index 1aec5f04e68e..000000000000
--- a/iozone-3_420.diff
+++ /dev/null
@@ -1,96 +0,0 @@
-diff -Naur src~/current/COPYING src/current/COPYING
---- src~/current/COPYING 1969-12-31 18:00:00.000000000 -0600
-+++ src/current/COPYING 2009-10-31 09:42:05.000000000 -0500
-@@ -0,0 +1,19 @@
-+ Original Author: William Norcott (wnorcott@us.oracle.com)
-+ 4 Dunlap Drive
-+ Nashua, NH 03060
-+
-+ Enhancements: Don Capps (capps@iozone.org)
-+ 7417 Crenshaw
-+ Plano, TX 75025
-+
-+ Copyright 1991, 1992, 1994, 1998, 1999, 2002 William D. Norcott
-+
-+ License to freely use and distribute this software is hereby granted
-+ by the author, subject to the condition that this copyright notice
-+ remains intact. The author retains the exclusive right to publish
-+ derivative works based on this work, including, but not limited to,
-+ revised versions of this work
-+
-+ Other contributors:
-+
-+ Don Capps (Network Appliance) capps@iozone.org
-diff -Naur src~/current/makefile src/current/makefile
---- src~/current/makefile 2010-06-24 20:22:56.000000000 -0500
-+++ src/current/makefile 2010-06-24 20:24:34.000000000 -0500
-@@ -19,6 +19,15 @@
- S10CCFLAGS = -m64
- FLAG64BIT = -m64
-
-+BINS = iozone fileop Generate_Graphs gengnuplot.sh gnu3d.dem
-+
-+BINDIR = /usr/bin
-+MANDIR = /usr/share/man
-+DOCDIR = /usr/share/doc/iozone
-+COPYDIR = /usr/share/licenses/iozone
-+
-+DESTDIR =
-+
- all:
- @echo ""
- @echo "You must specify the target. "
-@@ -42,11 +52,11 @@
- @echo " -> hpux_no_ansi-10.1 (32bit) <-"
- @echo " -> IRIX (32bit) <-"
- @echo " -> IRIX64 (64bit) <-"
-- @echo " -> linux (32bit) <-"
-+ @echo " -> linux-i686 (32bit) <-"
- @echo " -> linux-arm (32bit) <-"
-- @echo " -> linux-AMD64 (64bit) <-"
-+ @echo " -> linux-x86_64 (64bit) <-"
- @echo " -> linux-ia64 (64bit) <-"
-- @echo " -> linux-powerpc (32bit) <-"
-+ @echo " -> linux-ppc (32bit) <-"
- @echo " -> linux-powerpc64 (64bit) <-"
- @echo " -> linux-sparc (32bit) <-"
- @echo " -> macosx (32bit) <-"
-@@ -158,7 +168,7 @@
- #
- # GNU 'C' compiler Linux build with threads, largefiles, async I/O
- #
--linux: iozone_linux.o libasync.o libbif.o fileop_linux.o pit_server.o
-+linux-i686: iozone_linux.o libasync.o libbif.o fileop_linux.o pit_server.o
- $(CC) -O3 $(LDFLAGS) iozone_linux.o libasync.o libbif.o -lpthread \
- -lrt -o iozone
- $(CC) -O3 -Dlinux fileop_linux.o -o fileop
-@@ -167,7 +177,7 @@
- #
- # GNU 'C' compiler Linux build for powerpc chip with threads, largefiles, async I/O
- #
--linux-powerpc: iozone_linux-powerpc.o libbif.o libasync.o fileop_linux-ppc.o pit_server.o
-+linux-ppc: iozone_linux-powerpc.o libbif.o libasync.o fileop_linux-ppc.o pit_server.o
- $(CC) -O3 $(LDFLAGS) iozone_linux-powerpc.o libasync.o \
- libbif.o -lpthread -lrt -o iozone
- $(CC) -O3 -Dlinux fileop_linux-ppc.o -o fileop
-@@ -213,7 +223,7 @@
- #
- # GNU 'C' compiler Linux build with threads, largefiles, async I/O
- #
--linux-AMD64: iozone_linux-AMD64.o libbif.o libasync.o fileop_linux-AMD64.o pit_server.o
-+linux-x86_64: iozone_linux-AMD64.o libbif.o libasync.o fileop_linux-AMD64.o pit_server.o
- $(CC) -O3 $(LDFLAGS) iozone_linux-AMD64.o libbif.o libasync.o \
- -lrt -lpthread -o iozone
- $(CC) -O3 -Dlinux fileop_linux-AMD64.o -o fileop
-@@ -1333,3 +1343,11 @@
- -DNAME='"netbsd"' -DSHARED_MEM $(CFLAGS) iozone.c -o iozone_netbsd.o
- $(CC) -c -O -Dunix -Dbsd4_4 -DHAVE_ANSIC_C -DNO_THREADS \
- -DSHARED_MEM $(CFLAGS) libbif.c -o libbif.o
-+
-+install:
-+ install -dm755 $(DESTDIR)$(BINDIR)
-+ install -Dm755 $(BINS) $(DESTDIR)$(BINDIR)
-+ install -Dm644 ../../docs/iozone.1 $(DESTDIR)$(MANDIR)/man1/iozone.1
-+ install -Dm644 ../../docs/Run_rules.doc $(DESTDIR)$(DOCDIR)/Guidelines.doc
-+ install -Dm644 Gnuplot.txt $(DESTDIR)$(DOCDIR)/Generate_Graphs.txt
-+ install -Dm644 COPYING $(DESTDIR)$(COPYDIR)/COPYING