summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD60
-rw-r--r--config.patch36
-rw-r--r--ipe.bash-completion16
-rw-r--r--svgtoipe-python2.patch4
5 files changed, 142 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ead9f7aa75b9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = ipe
+ pkgdesc = The extensible drawing editor
+ pkgver = 7.1.7
+ pkgrel = 2
+ url = http://tclab.kaist.ac.kr/ipe/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = lua
+ depends = qt4
+ depends = freetype2
+ depends = zlib
+ depends = poppler
+ depends = python2
+ conflicts = ipe
+ source = http://downloads.sourceforge.net/project/ipe7/ipe/7.1/ipe-7.1.7-src.tar.gz
+ source = http://hg.mrzv.org/IpePresenter/archive/d0b0ea368ce9.tar.gz
+ source = ipe.bash-completion
+ source = config.patch
+ md5sums = 8c31313ec839fb7958b4a627634c907e
+ md5sums = 3bc8dc576ee3acced2ff3c6ea6a01319
+ md5sums = 694f0d5402655901be385647e5d8d6e3
+ md5sums = af3db2930ff57decb63cd322a845b025
+
+pkgname = ipe
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..982c66991ac6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,60 @@
+# Contributor: Dmitriy Morozov <archlinux@foxcub.org>
+
+pkgname=ipe
+_sfproject=ipe7
+_dirver=7.1
+pkgver=7.1.7
+pkgrel=2
+pkgdesc="The extensible drawing editor"
+url="http://tclab.kaist.ac.kr/ipe/"
+depends=('lua' 'qt4' 'freetype2' 'zlib' 'poppler' 'python2')
+arch=('i686' 'x86_64')
+license=("GPL")
+conflicts=('ipe')
+ipepresenter_version_=d0b0ea368ce9
+source=("http://downloads.sourceforge.net/project/$_sfproject/$pkgname/$_dirver/$pkgname-$pkgver-src.tar.gz"
+ "http://hg.mrzv.org/IpePresenter/archive/$ipepresenter_version_.tar.gz"
+ "ipe.bash-completion"
+ "config.patch"
+ )
+md5sums=('8c31313ec839fb7958b4a627634c907e'
+ '3bc8dc576ee3acced2ff3c6ea6a01319'
+ '694f0d5402655901be385647e5d8d6e3'
+ 'af3db2930ff57decb63cd322a845b025')
+
+prepare() {
+ cd "$srcdir/$pkgname-$pkgver/src"
+ patch config.mak < "$srcdir/config.patch"
+}
+
+build() {
+ # Ipe
+ cd "$srcdir/$pkgname-$pkgver/src"
+ make IPEPREFIX=/usr
+
+ # IpePresenter
+ cd "$srcdir/IpePresenter-$ipepresenter_version_"
+ CPPFLAGS+=" -I ../$pkgname-$pkgver/src/include -I ../$pkgname-$pkgver/src/ipecanvas" \
+ LIBS=" -L ../$pkgname-$pkgver/build/lib" \
+ make
+}
+
+package() {
+ # Ipe
+ cd "$srcdir/$pkgname-$pkgver/src"
+ INSTALL_ROOT="$pkgdir" make install IPEPREFIX=/usr
+
+ # IpePresenter
+ cd "$srcdir/IpePresenter-$ipepresenter_version_"
+ install -m755 ipepresenter "$pkgdir/usr/bin"
+
+ # Lua binding
+ mkdir "$pkgdir/usr/lib/lua"
+ ln -s /usr/lib/libipelua.so "$pkgdir/usr/lib/lua/ipe.so"
+
+ # Bash completion
+ mkdir -p "$pkgdir/etc/bash_completion.d"
+ install "$srcdir/ipe.bash-completion" "$pkgdir/etc/bash_completion.d/ipe"
+}
+
+# vim: ft=sh syn=sh et ts=2 sw=2
diff --git a/config.patch b/config.patch
new file mode 100644
index 000000000000..0c9dad699aa9
--- /dev/null
+++ b/config.patch
@@ -0,0 +1,36 @@
+--- config.mak 2014-05-07 00:28:31.000000000 -0700
++++ ../../../ipe-7.1.5/src/config.mak 2014-05-07 07:08:11.675366079 -0700
+@@ -31,7 +31,7 @@
+ #
+ # The name of the Lua package (it could be "lua", "lua52", or "lua5.2")
+ #
+-LUA_PACKAGE ?= lua5.2
++LUA_PACKAGE ?= lua
+ #
+ ZLIB_CFLAGS ?=
+ ZLIB_LIBS ?= -lz
+@@ -57,7 +57,7 @@
+ # If you have different Qt versions installed, you may have to change
+ # this to "moc-qt4" if the default is Qt3's "moc".
+ #
+-MOC ?= moc
++MOC ?= moc-qt4
+ #
+ else
+ #
+@@ -76,13 +76,13 @@
+ -I/usr/X11/include/libpng12
+ CAIRO_LIBS ?= -L/usr/X11/lib -lcairo
+ LUA_CFLAGS ?= -I/usr/local/include
+-LUA_LIBS ?= -L/usr/local/lib -llua52 -lm
++LUA_LIBS ?= -L/usr/local/lib -llua -lm
+ QT_CFLAGS ?= -I/Library/Frameworks/QtCore.framework/Versions/4/Headers \
+ -I/Library/Frameworks/QtGui.framework/Versions/4/Headers
+ QT_LIBS ?= -F/Library/Frameworks -L/Library/Frameworks \
+ -framework QtCore -framework ApplicationServices \
+ -framework QtGui -framework AppKit -framework Cocoa -lz -lm
+-MOC ?= moc
++MOC ?= moc-qt4
+ endif
+ #
+ # --------------------------------------------------------------------
diff --git a/ipe.bash-completion b/ipe.bash-completion
new file mode 100644
index 000000000000..6ccc11e01988
--- /dev/null
+++ b/ipe.bash-completion
@@ -0,0 +1,16 @@
+have ipe &&
+_ipe()
+{
+ local cur xspec
+
+ COMPREPLY=()
+ _get_comp_words_by_ref cur
+
+ xspec="!*.@(ipe|pdf|eps)"
+
+ _expand || return 0
+
+ COMPREPLY=( $( compgen -f -X "$xspec" -- "$cur" ) \
+ $( compgen -d -- "$cur" ) )
+} &&
+complete -F _ipe -o filenames ipe
diff --git a/svgtoipe-python2.patch b/svgtoipe-python2.patch
new file mode 100644
index 000000000000..276e48fe79b3
--- /dev/null
+++ b/svgtoipe-python2.patch
@@ -0,0 +1,4 @@
+1c1
+< #!/usr/bin/env python
+---
+> #!/usr/bin/env python2