summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD27
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ced33e6d5a2c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = iphonebackuptools
+ pkgdesc = extract
+ pkgver = 1.78
+ pkgrel = 1
+ url = https://github.com/richinfante/iphonebackuptools
+ arch = any
+ license = MIT
+ makedepends = npm
+ makedepends = python
+ depends = nodejs
+ depends = sqlite
+ source = https://github.com/richinfante/iphonebackuptools/archive/c5573a3e5446ea420a56d2477ef78550cee224fb.tar.gz
+ sha256sums = 6cc52d2fe0b09a5b5fa8f9f80f4de77d9cc7dbf130057432a7267c9093372828
+
+pkgname = iphonebackuptools
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2e50731ab39c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: graysky <graysky AT archlinux DOT us>
+
+pkgname=iphonebackuptools
+_commit=c5573a3e5446ea420a56d2477ef78550cee224fb
+_short=78
+# work around until upstream versions
+# https://github.com/richinfante/iphonebackuptools/issues/68
+pkgver=1.$_short
+pkgrel=1
+pkgdesc="extract"
+arch=('any')
+url="https://github.com/richinfante/iphonebackuptools"
+license=('MIT')
+depends=('nodejs' 'sqlite')
+makedepends=('npm' 'python')
+source=(
+https://github.com/richinfante/iphonebackuptools/archive/$_commit.tar.gz
+)
+sha256sums=('6cc52d2fe0b09a5b5fa8f9f80f4de77d9cc7dbf130057432a7267c9093372828')
+
+package() {
+ npm install -g --user root --prefix "$pkgdir"/usr "$srcdir/$_commit.tar.gz"
+
+ # Fix permissions
+ find "$pkgdir/usr" -type d -exec chmod 755 '{}' +
+ chown -R root:root "${pkgdir}"
+}