summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD19
2 files changed, 21 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7aea1bc5ada4..0b2eb66bc3ad 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,18 @@
pkgbase = ipod-shuffle-4g
pkgdesc = Python script for building the track and playlist database for the newer gen IPod Shuffle
- pkgver = 1.4
+ pkgver = 1.5
pkgrel = 1
- url = https://github.com/nims11/
+ url = https://github.com/nims11/IPod-Shuffle-4g
arch = any
license = GPL2
- depends = python2
- depends = mutagen
+ depends = python
optdepends = espeak: Voiceover support
- source = https://github.com/nims11/ipod-shuffle-4g/archive/v1.4.tar.gz
- sha512sums = 949c79e82f00119c7233a5d5a21f2f513dad370d1e94d5f1d97a18ff5f42c61d3088369bb385aeb616620a852628f2f1dd1ec1ead2bab72df863defc42fa9a83
+ optdepends = python-mutagen: album/artist information and auto-id3-playlists support
+ source = ipod-shuffle-4g-1.5.tar.gz::https://github.com/nims11/IPod-Shuffle-4g/releases/download/v1.5/IPod-Shuffle-4g-1.5.tar.gz
+ source = ipod-shuffle-4g-1.5.tar.gz.sig::https://github.com/nims11/IPod-Shuffle-4g/releases/download/v1.5/IPod-Shuffle-4g-1.5.tar.gz.asc
+ validpgpkeys = C838FC13F0FD455541C590412B6DAF67FFAE3F83
+ sha512sums = 8d7121ad5cd4bb64c8a33848ddf25d206cbef798ca5823ef0c3b1573afc010f9471e97e27da5771302e93c7cb378fac57a8e082d23af9ed7d423c0bcabdddaee
+ sha512sums = SKIP
pkgname = ipod-shuffle-4g
diff --git a/PKGBUILD b/PKGBUILD
index 73eb2c4f2f7a..f74b5328559e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,21 @@
-# Maintainer: NicoHood <aur {at} nicohood {dot} de>
+# Maintainer: NicoHood <archlinux {cat} nicohood {dog} de>
+# PGP ID: 97312D5EB9D7AE7D0BD4307351DAE9B7C1AE9161
pkgname=ipod-shuffle-4g
-pkgver=1.4
+pkgver=1.5
pkgrel=1
pkgdesc="Python script for building the track and playlist database for the newer gen IPod Shuffle"
arch=('any')
-url="https://github.com/nims11/${_pkgname}"
+url="https://github.com/nims11/IPod-Shuffle-4g"
license=('GPL2')
-depends=('python2' 'mutagen')
-optdepends=('espeak: Voiceover support')
-source=("https://github.com/nims11/${pkgname}/archive/v${pkgver}.tar.gz")
-sha512sums=('949c79e82f00119c7233a5d5a21f2f513dad370d1e94d5f1d97a18ff5f42c61d3088369bb385aeb616620a852628f2f1dd1ec1ead2bab72df863defc42fa9a83')
+depends=('python')
+optdepends=('espeak: Voiceover support'
+ 'python-mutagen: album/artist information and auto-id3-playlists support')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/nims11/IPod-Shuffle-4g/releases/download/v${pkgver}/IPod-Shuffle-4g-${pkgver}.tar.gz"
+ "${pkgname}-${pkgver}.tar.gz.sig::https://github.com/nims11/IPod-Shuffle-4g/releases/download/v${pkgver}/IPod-Shuffle-4g-${pkgver}.tar.gz.asc")
+sha512sums=('8d7121ad5cd4bb64c8a33848ddf25d206cbef798ca5823ef0c3b1573afc010f9471e97e27da5771302e93c7cb378fac57a8e082d23af9ed7d423c0bcabdddaee'
+ 'SKIP')
+validpgpkeys=('C838FC13F0FD455541C590412B6DAF67FFAE3F83') # Nimesh Ghelani <nimeshghelani@gmail.com>
package() {
cd "IPod-Shuffle-4g-${pkgver}"