summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD42
2 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3029950975cc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = ipwatchd-gnotify
+ pkgdesc = IP conflict notification for Gnome desktops
+ pkgver = 1.0.1
+ pkgrel = 1
+ url = http://ipwatchd.sourceforge.net/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = ipwatchd
+ optdepends = arp-scan: scan entire networks for IP address conflicts
+ optdepends = arpwatch: monitor entire networks for IP address conflicts
+ source = http://downloads.sourceforge.net/project/ipwatchd/ipwatchd-gnotify/1.0.1/ipwatchd-gnotify-1.0.1.tar.gz
+ sha256sums = f67798791c8dea16331d5f642d26d38aa5378fe824d61c89426d6770fac54be8
+
+pkgname = ipwatchd-gnotify
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ddb57a162715
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Chris Severance aur.severach aATt spamgourmet dott com
+
+set -u
+pkgname='ipwatchd-gnotify'
+pkgver='1.0.1'
+pkgrel='1'
+pkgdesc='IP conflict notification for Gnome desktops'
+arch=('i686' 'x86_64')
+url='http://ipwatchd.sourceforge.net/'
+license=('GPL')
+depends=('ipwatchd')
+optdepends=('arp-scan: scan entire networks for IP address conflicts' # Can also be used to redisplay conflict notifications.
+ 'arpwatch: monitor entire networks for IP address conflicts')
+_verwatch=("http://sourceforge.net/projects/ipwatchd/files/${pkgname}/" '.*href="'"/projects/ipwatchd/files/${pkgname}/\([^/]\+\)/"'".*' 'f')
+source=("http://downloads.sourceforge.net/project/${pkgname%%-*}/${pkgname}/${pkgver}/${pkgname}-${pkgver}.tar.gz")
+sha256sums=('f67798791c8dea16331d5f642d26d38aa5378fe824d61c89426d6770fac54be8')
+
+prepare() {
+ set -u
+ cd "${pkgname}-${pkgver}/src"
+ sed -i -e 's:/sbin:/bin:g' 'Makefile'
+ set +u
+}
+
+build() {
+ set -u
+ cd "${pkgname}-${pkgver}/src"
+
+ make
+ set +u
+}
+
+package() {
+ set -u
+ cd "${pkgname}-${pkgver}/src"
+
+ make DESTDIR="${pkgdir}/" install
+ set +u
+}
+set +u
+
+# vim:set ts=2 sw=2 et: