summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD24
-rw-r--r--chromium-use-non-versioned-icu-namespace.patch14
3 files changed, 37 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0baead10f5f3..c3a63b6a5575 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Thu Dec 10 15:37:59 UTC 2015
+# Sat Feb 20 15:40:37 UTC 2016
pkgbase = iridium
pkgdesc = a free, open, and libre browser modification of the Chromium code base
- pkgver = 46.0
+ pkgver = 48.1
pkgrel = 1
url = https://iridiumbrowser.de/
install = iridium.install
@@ -43,14 +43,16 @@ pkgbase = iridium
optdepends = gnome-keyring: for storing passwords in GNOME keyring
optdepends = kwallet: for storing passwords in KWallet
options = !strip
- source = https://downloads.iridiumbrowser.de/source/iridium-browser-46.0.tar.xz
+ source = https://downloads.iridiumbrowser.de/source/iridium-browser-48.1.tar.xz
source = chromium-launcher-3.tar.gz::https://github.com/foutrelis/chromium-launcher/archive/v3.tar.gz
source = chromium.desktop
+ source = chromium-use-non-versioned-icu-namespace.patch
source = chromium-fix-print-preview-on-en_GB-locale.patch
source = chromium-widevine.patch
- sha256sums = 13783ef0325f6f6ff65ac2ceb546af549403975d76ee528cebe07a0e8a5383a2
+ sha256sums = 8f542ae1d3029c254c36dce5e540a6653700236be6808de6d3c29537e47a0725
sha256sums = 8b01fb4efe58146279858a754d90b49e5a38c9a0b36a1f84cbb7d12f92b84c28
sha256sums = 028a748a5c275de9b8f776f97909f999a8583a4b77fd1cd600b4fc5c0c3e91e9
+ sha256sums = e4192446cc0ab6a5c540599c8a149f4f2208f0014da2786ada6c9544913d7426
sha256sums = 6fff45aafa31fb35a032b4e2175a341e08f9d2a9b37c5cf080c318180f558378
sha256sums = 379b746e187de28f80f5a7cd19edcfa31859656826f802a1ede054fcb6dfb221
makedepends_x86_64 = lib32-gcc-libs
diff --git a/PKGBUILD b/PKGBUILD
index 73feb60d5013..6c237ea06806 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Maintainer: Iru Cai <mytbk920423@gmail.com>
pkgname=iridium
-pkgver=46.0
+pkgver=48.1
pkgrel=1
_launcher_ver=3
pkgdesc="a free, open, and libre browser modification of the Chromium code base"
@@ -24,18 +24,25 @@ install=iridium.install
source=(https://downloads.iridiumbrowser.de/source/iridium-browser-${pkgver}.tar.xz
chromium-launcher-$_launcher_ver.tar.gz::https://github.com/foutrelis/chromium-launcher/archive/v$_launcher_ver.tar.gz
chromium.desktop
+ chromium-use-non-versioned-icu-namespace.patch
chromium-fix-print-preview-on-en_GB-locale.patch
chromium-widevine.patch)
-sha256sums=('13783ef0325f6f6ff65ac2ceb546af549403975d76ee528cebe07a0e8a5383a2'
+sha256sums=('8f542ae1d3029c254c36dce5e540a6653700236be6808de6d3c29537e47a0725'
'8b01fb4efe58146279858a754d90b49e5a38c9a0b36a1f84cbb7d12f92b84c28'
'028a748a5c275de9b8f776f97909f999a8583a4b77fd1cd600b4fc5c0c3e91e9'
+ 'e4192446cc0ab6a5c540599c8a149f4f2208f0014da2786ada6c9544913d7426'
'6fff45aafa31fb35a032b4e2175a341e08f9d2a9b37c5cf080c318180f558378'
'379b746e187de28f80f5a7cd19edcfa31859656826f802a1ede054fcb6dfb221')
-# We can't build (P)NaCL on i686 because the toolchain is x86_64 only and the
-# instructions on how to build the toolchain from source don't work that well
-# (at least not from within the Chromium 39 source tree).
-# https://sites.google.com/a/chromium.org/dev/nativeclient/pnacl/building-pnacl-components-for-distribution-packagers
+# Google API keys (see http://www.chromium.org/developers/how-tos/api-keys)
+# Note: These are for Arch Linux use ONLY. For your own distribution, please
+# get your own set of keys. Feel free to contact foutrelis@archlinux.org for
+# more information.
+_google_api_key=AIzaSyDwr302FpOSkGRpLlUpPThNTDPbXcIn_FM
+_google_default_client_id=413772536636.apps.googleusercontent.com
+_google_default_client_secret=0ZChLK6AxeA3Isu96MkwqDR4
+
+# We don't build PNaCL in Iridium
_build_nacl=0
if [[ $CARCH == i686 ]]; then
_build_nacl=0
@@ -50,6 +57,9 @@ prepare() {
# https://code.google.com/p/chromium/issues/detail?id=541273
#sed -i "/'target_name': 'libvpx'/s/libvpx/&_new/" build/linux/unbundle/libvpx.gyp
+ # https://codereview.chromium.org/1505763002
+ patch -Np1 -i ../chromium-use-non-versioned-icu-namespace.patch
+
# https://code.google.com/p/chromium/issues/detail?id=480415
patch -Np1 -i ../chromium-fix-print-preview-on-en_GB-locale.patch
@@ -114,7 +124,7 @@ build() {
-Drelease_extra_cflags="$CFLAGS"
-Dlibspeechd_h_prefix=speech-dispatcher/
-Dffmpeg_branding=Chrome
- -Dproprietary_codecs=1
+ -Dproprietary_codecs=0
-Duse_gnome_keyring=0
-Duse_system_bzip2=1
-Duse_system_flac=1
diff --git a/chromium-use-non-versioned-icu-namespace.patch b/chromium-use-non-versioned-icu-namespace.patch
new file mode 100644
index 000000000000..f7b0b6d80517
--- /dev/null
+++ b/chromium-use-non-versioned-icu-namespace.patch
@@ -0,0 +1,14 @@
+Index: components/autofill/core/common/autofill_l10n_util.cc
+diff --git a/components/autofill/core/common/autofill_l10n_util.cc b/components/autofill/core/common/autofill_l10n_util.cc
+index 2ee517faf82b1feb224f83ae533092ae3b31f5af..c29b0a299b7215895874adf9241e4705247161ab 100644
+--- a/components/autofill/core/common/autofill_l10n_util.cc
++++ b/components/autofill/core/common/autofill_l10n_util.cc
+@@ -22,7 +22,7 @@ CaseInsensitiveCompare::CaseInsensitiveCompare(const icu::Locale& locale) {
+ // library. This could be due to a device-specific issue (has been seen in
+ // the wild on Android devices). In the failure case, |collator_| will be
+ // null. See http://crbug.com/558625.
+- icu_54::UnicodeString name;
++ icu::UnicodeString name;
+ std::string locale_name;
+ locale.getDisplayName(name).toUTF8String(locale_name);
+ LOG(ERROR) << "Failed to initialize the ICU Collator for "